aboutsummaryrefslogtreecommitdiff
path: root/package/perl-gd
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-08-27 13:51:59 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-08-27 21:31:02 +0200
commit0f46e48c9c55e85b365ae93ef9aabe9e4121652b (patch)
treeb0ae9a809cb7350ca51e448dab8c4c5cbaf2b32e /package/perl-gd
parent5e6b7159d76852a8f3789e751f45aa4e49d5df77 (diff)
downloadbuildroot-0f46e48c9c55e85b365ae93ef9aabe9e4121652b.tar.gz
buildroot-0f46e48c9c55e85b365ae93ef9aabe9e4121652b.tar.bz2
perl-gd: mark as broken
perl-gd doesn't build on gcc10 due to the host Perl being a bit old. This shows a defiency in the perl package infrastructure, which is being worked on. However, since it won't be solved before 2014.08, our only solution for now is to mark perl-gd as broken, as well as its reverse dependency perl-gdgraph. Avoids: http://autobuild.buildroot.org/results/228/228b43e67e683cecfa3851a8a030d06e9fdc6dac/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/perl-gd')
-rw-r--r--package/perl-gd/Config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/perl-gd/Config.in b/package/perl-gd/Config.in
index 7c85cfcb5b..3434507b39 100644
--- a/package/perl-gd/Config.in
+++ b/package/perl-gd/Config.in
@@ -1,6 +1,8 @@
config BR2_PACKAGE_PERL_GD
bool "perl-gd"
depends on !BR2_PREFER_STATIC_LIB
+ # Does not build on machines having a old host perl
+ depends on BR2_BROKEN
select BR2_PACKAGE_ZLIB
select BR2_PACKAGE_LIBPNG
select BR2_PACKAGE_FREETYPE