aboutsummaryrefslogtreecommitdiff
path: root/package/python-service-identity
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-17 23:39:58 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-24 17:15:29 +0200
commit518cb7ff03ceb0bbc7aa6eb6fafbf43d1e3025b7 (patch)
treec7b0e18dfc97a7857af63e4022876f4c165d9009 /package/python-service-identity
parent5ebf6282413c96937ffabf4d2d3b6ce75a344693 (diff)
downloadbuildroot-518cb7ff03ceb0bbc7aa6eb6fafbf43d1e3025b7.tar.gz
buildroot-518cb7ff03ceb0bbc7aa6eb6fafbf43d1e3025b7.tar.bz2
python-service-identity: add missing BR2_INSTALL_LIBSTDCPP dependency
python-service-identity selects python-pyopenssl and python-pyasn, both of which depend on C++ support, but this dependency was not propagated to python-service-identity causing the following kconfig warning: warning: (BR2_PACKAGE_PYTHON_SERVICE_IDENTITY) selects BR2_PACKAGE_PYTHON_PYOPENSSL which has unmet direct dependencies ((BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3) && BR2_INSTALL_LIBSTDCPP) warning: (BR2_PACKAGE_PYTHON_SERVICE_IDENTITY) selects BR2_PACKAGE_PYTHON_PYASN which has unmet direct dependencies ((BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3) && BR2_INSTALL_LIBSTDCPP) warning: (BR2_PACKAGE_PYTHON_SERVICE_IDENTITY) selects BR2_PACKAGE_PYTHON_PYASN_MODULES which has unmet direct dependencies ((BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3) && BR2_INSTALL_LIBSTDCPP) Cc: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: add Config.in comment.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-service-identity')
-rw-r--r--package/python-service-identity/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/python-service-identity/Config.in b/package/python-service-identity/Config.in
index e2200f67a8..c9cbb6cca1 100644
--- a/package/python-service-identity/Config.in
+++ b/package/python-service-identity/Config.in
@@ -4,7 +4,11 @@ config BR2_PACKAGE_PYTHON_SERVICE_IDENTITY
select BR2_PACKAGE_PYTHON_PYASN # runtime
select BR2_PACKAGE_PYTHON_PYASN_MODULES # runtime
select BR2_PACKAGE_PYTHON_PYOPENSSL # runtime
+ depends on BR2_INSTALL_LIBSTDCPP # python-pyopenssl, python-pyasn
help
Service identity verification for pyOpenSSL.
https://pypi.python.org/pypi/service_identity
+
+comment "python-service-identify needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP