aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5declarative
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-22 22:50:34 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-22 22:50:34 +0200
commitbdd522f9213788d404540f5c016bdd431d9be04a (patch)
tree61cc81f1db978ec99f09868092cd4639f102f129 /package/qt5/qt5declarative
parent7b146a0225809be236995aa4e102d30352eb2274 (diff)
downloadbuildroot-bdd522f9213788d404540f5c016bdd431d9be04a.tar.gz
buildroot-bdd522f9213788d404540f5c016bdd431d9be04a.tar.bz2
qt5: remove GPLv2 license from qt5declarative, qt5script and qt5svg
Since Qt 5.5, those three modules have lost their GPLv2 licensing option. Remains the LGPLv2.1 with exception and LGPLv3 as the possible open-source licenses. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt5/qt5declarative')
-rw-r--r--package/qt5/qt5declarative/qt5declarative.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/qt5/qt5declarative/qt5declarative.mk b/package/qt5/qt5declarative/qt5declarative.mk
index 30c0813f06..296292b1b3 100644
--- a/package/qt5/qt5declarative/qt5declarative.mk
+++ b/package/qt5/qt5declarative/qt5declarative.mk
@@ -11,8 +11,8 @@ QT5DECLARATIVE_DEPENDENCIES = qt5base qt5xmlpatterns
QT5DECLARATIVE_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
-QT5DECLARATIVE_LICENSE = LGPLv2.1 with exception or LGPLv3 or GPLv2
-QT5DECLARATIVE_LICENSE_FILES = LICENSE.LGPLv21 LGPL_EXCEPTION.txt LICENSE.LGPLv3 LICENSE.GPLv2
+QT5DECLARATIVE_LICENSE = LGPLv2.1 with exception or LGPLv3
+QT5DECLARATIVE_LICENSE_FILES = LICENSE.LGPLv21 LGPL_EXCEPTION.txt LICENSE.LGPLv3
else
QT5DECLARATIVE_LICENSE = Commercial license
QT5DECLARATIVE_REDISTRIBUTE = NO