aboutsummaryrefslogtreecommitdiff
path: root/package/qt5
diff options
context:
space:
mode:
authorGravatar Yann E. MORIN <yann.morin.1998@free.fr>2014-04-05 17:21:39 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-05 19:20:50 +0200
commit2bb9df30ad8736567dd4f9244e255ddb37171d1d (patch)
treee0529f52ef43889f6ac2ae6b4a70f57e464436e6 /package/qt5
parentec0de5d26b082aff298cd907c8db8f7675e7865d (diff)
downloadbuildroot-2bb9df30ad8736567dd4f9244e255ddb37171d1d.tar.gz
buildroot-2bb9df30ad8736567dd4f9244e255ddb37171d1d.tar.bz2
package/libegl: rename the _HAS and _PROVIDES variables
The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libegl to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/Config.in4
-rw-r--r--package/qt5/qt5declarative/Config.in4
-rw-r--r--package/qt5/qt5graphicaleffects/Config.in4
-rw-r--r--package/qt5/qt5multimedia/Config.in4
-rw-r--r--package/qt5/qt5quick1/Config.in4
-rw-r--r--package/qt5/qt5quickcontrols/Config.in4
6 files changed, 12 insertions, 12 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 437b1d2493..5d5b7f60ee 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -137,11 +137,11 @@ comment "X.org XCB backend available if X.org is enabled"
config BR2_PACKAGE_QT5BASE_EGLFS
bool "eglfs support"
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
comment "eglfs backend available if OpenGLES and EGL are enabled"
- depends on !BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES
+ depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
bool "print support module"
diff --git a/package/qt5/qt5declarative/Config.in b/package/qt5/qt5declarative/Config.in
index 5e1516dd87..4a6e805b81 100644
--- a/package/qt5/qt5declarative/Config.in
+++ b/package/qt5/qt5declarative/Config.in
@@ -4,7 +4,7 @@ config BR2_PACKAGE_QT5DECLARATIVE
select BR2_PACKAGE_QT5BASE
select BR2_PACKAGE_QT5BASE_GUI
select BR2_PACKAGE_QT5BASE_EGLFS
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
help
@@ -16,5 +16,5 @@ config BR2_PACKAGE_QT5DECLARATIVE
http://qt-project.org
comment "qt5declarative requires an OpenGL-capable backend"
- depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES) && \
+ depends on (!BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES) && \
BR2_PACKAGE_QT5_JSCORE_AVAILABLE
diff --git a/package/qt5/qt5graphicaleffects/Config.in b/package/qt5/qt5graphicaleffects/Config.in
index a821b40fd4..2747af85b2 100644
--- a/package/qt5/qt5graphicaleffects/Config.in
+++ b/package/qt5/qt5graphicaleffects/Config.in
@@ -3,7 +3,7 @@ config BR2_PACKAGE_QT5GRAPHICALEFFECTS
select BR2_PACKAGE_QT5BASE
select BR2_PACKAGE_QT5DECLARATIVE
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
help
Qt is a cross-platform application and UI framework for
@@ -14,5 +14,5 @@ config BR2_PACKAGE_QT5GRAPHICALEFFECTS
http://qt-project.org
comment "qt5graphicaleffects requires an OpenGL-capable backend"
- depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES) && \
+ depends on (!BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES) && \
BR2_PACKAGE_QT5_JSCORE_AVAILABLE
diff --git a/package/qt5/qt5multimedia/Config.in b/package/qt5/qt5multimedia/Config.in
index 765bdc110c..c00491c12e 100644
--- a/package/qt5/qt5multimedia/Config.in
+++ b/package/qt5/qt5multimedia/Config.in
@@ -2,7 +2,7 @@ config BR2_PACKAGE_QT5MULTIMEDIA
bool "qt5multimedia"
select BR2_PACKAGE_QT5BASE
select BR2_PACKAGE_QT5DECLARATIVE
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
help
@@ -14,5 +14,5 @@ config BR2_PACKAGE_QT5MULTIMEDIA
http://qt-project.org
comment "qt5multimedia requires an OpenGL-capable backend"
- depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES) && \
+ depends on (!BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES) && \
BR2_PACKAGE_QT5_JSCORE_AVAILABLE
diff --git a/package/qt5/qt5quick1/Config.in b/package/qt5/qt5quick1/Config.in
index 1ffcc0d78d..30c2e79182 100644
--- a/package/qt5/qt5quick1/Config.in
+++ b/package/qt5/qt5quick1/Config.in
@@ -8,7 +8,7 @@ config BR2_PACKAGE_QT5QUICK1
select BR2_PACKAGE_QT5DECLARATIVE
# This module does not support static linking
depends on !BR2_PREFER_STATIC_LIB
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
help
@@ -21,5 +21,5 @@ config BR2_PACKAGE_QT5QUICK1
comment "qt5quick1 needs a toolchain w/ dynamic library and an OpenGL-capable backend"
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
- depends on !BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES || \
+ depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES || \
BR2_PREFER_STATIC_LIB
diff --git a/package/qt5/qt5quickcontrols/Config.in b/package/qt5/qt5quickcontrols/Config.in
index 355aef0ce0..c350a7440d 100644
--- a/package/qt5/qt5quickcontrols/Config.in
+++ b/package/qt5/qt5quickcontrols/Config.in
@@ -4,7 +4,7 @@ config BR2_PACKAGE_QT5QUICKCONTROLS
select BR2_PACKAGE_QT5BASE_NETWORK
select BR2_PACKAGE_QT5DECLARATIVE
depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
- depends on BR2_PACKAGE_HAS_OPENGL_EGL
+ depends on BR2_PACKAGE_HAS_LIBEGL
depends on BR2_PACKAGE_HAS_LIBGLES
help
Qt is a cross-platform application and UI framework for
@@ -15,5 +15,5 @@ config BR2_PACKAGE_QT5QUICKCONTROLS
http://qt-project.org
comment "qt5quickcontrols requires an OpenGL-capable backend"
- depends on (!BR2_PACKAGE_HAS_OPENGL_EGL || !BR2_PACKAGE_HAS_LIBGLES) && \
+ depends on (!BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES) && \
BR2_PACKAGE_QT5_JSCORE_AVAILABLE