aboutsummaryrefslogtreecommitdiff
path: root/package/racehound
diff options
context:
space:
mode:
authorGravatar Yann E. MORIN <yann.morin.1998@free.fr>2016-04-12 19:20:50 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2016-04-12 23:30:49 +0200
commit64870d18282a17849eb806f85ac116ad140187c0 (patch)
tree7a8cd300af0add3950e36d4a687218a6ecd67fa6 /package/racehound
parent4bcc4f3e6ddb2fad7cf5a0ecd75536a2f3e26bf2 (diff)
downloadbuildroot-64870d18282a17849eb806f85ac116ad140187c0.tar.gz
buildroot-64870d18282a17849eb806f85ac116ad140187c0.tar.bz2
package/racehound: fix comment
racehound requires a kernel >= 3.14 to be built and to run. However, the current conditions on the corresponding comments are wrong: - the comment about the kernel has a dependency on the requested headers - the comment on the toolchain features does not have this condition. Thus, the comments are not shown/hidden under the appropriate conditions, like in this situation: - toolchain with headers < 3.14 (e.g. Sourcery CodeBench x86/x86_64 2012.09 with headers 3.5) - kernel 4.5 enabled this comment is shown: racehound needs an Linux kernel >= 3.14 to be built So, this is incorrect, because: 1- a kernel >= 3.14 is indeed to be built 2- the headers version mismatch is not reported Fix that by moving the dependency on the kernel headers to the appropriate comment and enhance it. Since there is no way we can know the kernel version to be built, we can not add such a condition; still, we leave the kernel message as-is. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/racehound')
-rw-r--r--package/racehound/Config.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/racehound/Config.in b/package/racehound/Config.in
index 9f1011bf0e..53e39a8c64 100644
--- a/package/racehound/Config.in
+++ b/package/racehound/Config.in
@@ -27,10 +27,11 @@ config BR2_PACKAGE_RACEHOUND
https://github.com/winnukem/racehound
comment "racehound needs an Linux kernel >= 3.14 to be built"
- depends on !BR2_LINUX_KERNEL || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
+ depends on !BR2_LINUX_KERNEL
depends on BR2_i386 || BR2_x86_64
-comment "racehound needs a uClibc or (e)glibc toolchain w/ C++, wchar, dynamic library"
+comment "racehound needs a uClibc or (e)glibc toolchain w/ C++, wchar, dynamic library, headers >= 3.14"
depends on BR2_i386 || BR2_x86_64
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || BR2_STATIC_LIBS \
- || !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+ || !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC) \
+ || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14