aboutsummaryrefslogtreecommitdiff
path: root/package/rdesktop/rdesktop.mk
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2020-03-13 22:39:31 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2020-03-14 15:06:46 +0100
commit89bc5e0f2aa8e8e2b215da8864e0022a4122caed (patch)
treeb89f0e1f07ba226c12fadd0575e436acf2e8d33f /package/rdesktop/rdesktop.mk
parent66f1f62f5af7a4093b2c11c7bf3ab28cd31cbb7a (diff)
downloadbuildroot-89bc5e0f2aa8e8e2b215da8864e0022a4122caed.tar.gz
buildroot-89bc5e0f2aa8e8e2b215da8864e0022a4122caed.tar.bz2
package/rdesktop: bump to version 1.9.0
- Retrieve official tarball and so remove autoreconf - xlib_Xcursor is a mandatory dependency since https://github.com/rdesktop/rdesktop/commit/6dd85edc6f8293acd100b34add1405ea5a744111 - libtasn1 is a mandatory dependency since https://github.com/rdesktop/rdesktop/commit/673b267e665642def474f228142e46b18d195e01 - nettle is a mandatory dependency since https://github.com/rdesktop/rdesktop/commit/00d9e0c4c806c1d5d21ec7865f03cafe9acbeab3 - gnutls is a mandatory dependency instead of openssl since https://github.com/rdesktop/rdesktop/commit/166d1bc14d34c20dd0c640571a749a6599180367 - pulseaudio is an optional dependency since https://github.com/rdesktop/rdesktop/commit/9b98c3b2296f07b99b94aceb2c19131f32bde476 - iconv is mandatory since https://github.com/rdesktop/rdesktop/commit/2ea3f69873d18d07ef79c724c656d25b9d63a114 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/rdesktop/rdesktop.mk')
-rw-r--r--package/rdesktop/rdesktop.mk20
1 files changed, 14 insertions, 6 deletions
diff --git a/package/rdesktop/rdesktop.mk b/package/rdesktop/rdesktop.mk
index f40521d2b1..672d85b5c5 100644
--- a/package/rdesktop/rdesktop.mk
+++ b/package/rdesktop/rdesktop.mk
@@ -4,18 +4,26 @@
#
################################################################################
-RDESKTOP_VERSION = 1.8.6
-RDESKTOP_SITE = $(call github,rdesktop,rdesktop,v$(RDESKTOP_VERSION))
-RDESKTOP_DEPENDENCIES = host-pkgconf openssl xlib_libX11 xlib_libXt \
+RDESKTOP_VERSION = 1.9.0
+RDESKTOP_SITE = \
+ https://github.com/rdesktop/rdesktop/releases/download/v$(RDESKTOP_VERSION)
+RDESKTOP_DEPENDENCIES = \
+ host-pkgconf \
+ gnutls \
+ libtasn1 \
+ nettle \
+ xlib_libX11 \
+ xlib_libXcursor \
+ xlib_libXt \
$(if $(BR2_PACKAGE_ALSA_LIB_PCM),alsa-lib) \
$(if $(BR2_PACKAGE_LIBAO),libao) \
+ $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
+ $(if $(BR2_PACKAGE_PULSEAUDIO),pulseaudio) \
$(if $(BR2_PACKAGE_XLIB_LIBXRANDR),xlib_libXrandr)
-RDESKTOP_CONF_OPTS = --with-openssl=$(STAGING_DIR)/usr --disable-credssp
+RDESKTOP_CONF_OPTS = --disable-credssp
RDESKTOP_LICENSE = GPL-3.0+
RDESKTOP_LICENSE_FILES = COPYING
-# From git
-RDESKTOP_AUTORECONF = YES
ifeq ($(BR2_PACKAGE_PCSC_LITE),y)
RDESKTOP_DEPENDENCIES += pcsc-lite