aboutsummaryrefslogtreecommitdiff
path: root/package/tovid
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-11 15:55:07 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-11 15:55:07 +0100
commit8b58ec016973bee87a4fc1cc99a32b206bdee136 (patch)
treeb01d5a621940ecf427fcc9655f16a95892c8f805 /package/tovid
parentcdf55a12658dc9ff5496f4bf0cc980a662008cd6 (diff)
downloadbuildroot-8b58ec016973bee87a4fc1cc99a32b206bdee136.tar.gz
buildroot-8b58ec016973bee87a4fc1cc99a32b206bdee136.tar.bz2
ffmpeg: mark as not available on nios2
ffmpeg was already marked as not available for the NIOS2 Sourcery toolchains, but it could still be built with the internal toolchain backend or a custom external toolchain. However, an inspection of the latest glibc source code indicates that FE_INVALID, FE_OVERFLOW and FE_UNDERFLOW and indeed not available in the nios2 variant of <fenv.h>. Consequently, this patch makes ffmpeg not available on nios2, which allows to simplify a bit the dependencies. It propagates this dependency to: - minidlna (and at the same time makes sure the minidlna comment is not displayed on nios2, which wasn't properly taken into account until now) - mpd - opencv - opencv3 - squeezelite - tovid Even if it selects ffmpeg, Kodi does not need an update since Kodi is only available on a limited number of architectures (which don't include nios2, obviously). Other packages only make use of ffmpeg when available. Fixes: http://autobuild.buildroot.org/results/921/9212f5a6432c5e695ac0630695405cea05e28610/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/tovid')
-rw-r--r--package/tovid/Config.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/tovid/Config.in b/package/tovid/Config.in
index ccf031e8a6..79eaec49c6 100644
--- a/package/tovid/Config.in
+++ b/package/tovid/Config.in
@@ -5,8 +5,7 @@ config BR2_PACKAGE_TOVID
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR
depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305 # ffmpeg
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # ffmpeg
+ depends on !nios2 # ffmpeg
depends on BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS
# The below dependencies are runtime dependencies only
select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps_ng