aboutsummaryrefslogtreecommitdiff
path: root/package/transmission/transmission.mk
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <peter@korsgaard.com>2017-09-02 00:37:48 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2017-09-02 00:37:48 +0200
commita2935ee28886b5198093c824c4ee4892d02d10c6 (patch)
treef19fd76fe53252debce2ff386003aac6ac72cb69 /package/transmission/transmission.mk
parente67fbcfa94e58a4d04e081be5e318953233492c8 (diff)
downloadbuildroot-a2935ee28886b5198093c824c4ee4892d02d10c6.tar.gz
buildroot-a2935ee28886b5198093c824c4ee4892d02d10c6.tar.bz2
transmission: gtk option needs libgtk3
Fixes the following configure issue: checking for GTK... no configure: error: Package requirements (gtk+-3.0 >= 3.4.0 glib-2.0 >= 2.32.0 gio-2.0 >= 2.26.0, gmodule-2.0 >= 2.32.0 gthread-2.0 >= 2.32.0) were not met: libgtk2 support was dropped in commit cdd71c642724 ((trunk gtk) #4970 remove deprecated GTK+ API calls, raise GTK+ dependency to 3.2) which was part of transmission-2.61. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/transmission/transmission.mk')
-rw-r--r--package/transmission/transmission.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/transmission/transmission.mk b/package/transmission/transmission.mk
index f2333cb93e..7f4675302e 100644
--- a/package/transmission/transmission.mk
+++ b/package/transmission/transmission.mk
@@ -83,7 +83,7 @@ endif
ifeq ($(BR2_PACKAGE_TRANSMISSION_GTK),y)
TRANSMISSION_CONF_OPTS += --with-gtk
-TRANSMISSION_DEPENDENCIES += libgtk2
+TRANSMISSION_DEPENDENCIES += libgtk3
else
TRANSMISSION_CONF_OPTS += --without-gtk
endif