aboutsummaryrefslogtreecommitdiff
path: root/package/webkit/webkit.mk
diff options
context:
space:
mode:
authorGravatar Markos Chandras <markos.chandras@imgtec.com>2013-09-05 12:37:02 +0100
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2013-09-08 22:50:06 +0200
commit52fcc6a256bcfd541486257bfd05ff12d47aef75 (patch)
tree2314d214305822a55a554b0d967973283794024c /package/webkit/webkit.mk
parent62146ea3ad78b74d0c17c0fbeaffa2be51070424 (diff)
downloadbuildroot-52fcc6a256bcfd541486257bfd05ff12d47aef75.tar.gz
buildroot-52fcc6a256bcfd541486257bfd05ff12d47aef75.tar.bz2
webkit: Version bump to 1.11.5
Also apply the following patches: - upstream fix for 32-bit autotools - upstream fix for conditional gstreamer build of gtklauncher - upstream fix for detecting the latest harfbuzz - Update existing patch for disabling docs - Update existing patch for execinfo_h - upstream patch for the MIPS DFG support. This fixes compilation problems on MIPS. Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/webkit/webkit.mk')
-rw-r--r--package/webkit/webkit.mk20
1 files changed, 15 insertions, 5 deletions
diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index 116a5e79a7..99a90b982a 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -4,22 +4,32 @@
#
################################################################################
-WEBKIT_VERSION = 1.9.6
+WEBKIT_VERSION = 1.11.5
WEBKIT_SITE = http://www.webkitgtk.org/releases
-WEBKIT_SOURCE = webkit-$(WEBKIT_VERSION).tar.xz
+WEBKIT_SOURCE = webkitgtk-$(WEBKIT_VERSION).tar.xz
WEBKIT_INSTALL_STAGING = YES
-WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf icu libcurl \
- libxml2 libxslt libgtk2 sqlite enchant libsoup jpeg libgail
+WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf enchant harfbuzz \
+ icu jpeg libcurl libgail libsecret libsoup libxml2 libxslt libgtk2 sqlite webp
# webkit-disable-tests.patch changes configure.ac therefore autoreconf required
WEBKIT_AUTORECONF = YES
WEBKIT_AUTORECONF_OPT = -I $(@D)/Source/autotools
+# Does not build and it's disabled by default
+# in newer releases
+define DISABLE_INDEXED_DATABASE
+ $(SED) '/ENABLE_INDEXED_DATABASE/s:1:0:' \
+ $(@D)/Source/WebCore/GNUmakefile.features.am
+endef
+
+WEBKIT_PRE_CONFIGURE_HOOKS += DISABLE_INDEXED_DATABASE
+
# Give explicit path to icu-config, and silence gazillions of warnings
# with recent gcc versions.
WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align -Wno-sign-compare" \
- CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare"
+ CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare" \
+ AR_FLAGS="cru"
WEBKIT_CONF_OPT += \
--with-gtk=2.0 \