aboutsummaryrefslogtreecommitdiff
path: root/package/yaml-cpp/Config.in
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2018-06-09 12:46:37 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-06-10 14:16:35 +0200
commite5975c729e2ddb5321c48af23d9b5975d68165b0 (patch)
treedab1ed66966ffaa93c6002f2efc1ca6dfa10c191 /package/yaml-cpp/Config.in
parentcb67c1d55b7b58d542ec1c4d0311543f40d5d0a2 (diff)
downloadbuildroot-e5975c729e2ddb5321c48af23d9b5975d68165b0.tar.gz
buildroot-e5975c729e2ddb5321c48af23d9b5975d68165b0.tar.bz2
yaml-cpp: bump to version 0.6.2
- Remove boost dependency (not needed since 0.6) - Add C++11 dependency (needed since 0.6) - Add hash for license file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/yaml-cpp/Config.in')
-rw-r--r--package/yaml-cpp/Config.in8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/yaml-cpp/Config.in b/package/yaml-cpp/Config.in
index 6d34f4210e..e02b85df12 100644
--- a/package/yaml-cpp/Config.in
+++ b/package/yaml-cpp/Config.in
@@ -1,14 +1,12 @@
config BR2_PACKAGE_YAML_CPP
bool "yaml-cpp"
depends on BR2_INSTALL_LIBSTDCPP
- depends on BR2_TOOLCHAIN_HAS_THREADS # boost
- depends on BR2_USE_WCHAR # boost
- select BR2_PACKAGE_BOOST
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
help
yaml-cpp is a YAML parser and emitter in C++ matching
the YAML 1.2 spec.
https://github.com/jbeder/yaml-cpp
-comment "yaml-cpp needs a toolchain w/ C++, threads, wchar"
- depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+comment "yaml-cpp needs a toolchain w/ C++, gcc >= 4.7"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7