aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorGravatar Romain Naour <romain.naour@gmail.com>2016-12-21 23:07:07 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2016-12-22 10:36:20 +0100
commit282ffecbe3c6fa123979ad2beb0b8fe86ecf5192 (patch)
tree6bd0f9cc2c33b728cdceb3caad587ed9081a65bf /package
parent427c432821d2edc349328633af8df359b2a5e075 (diff)
downloadbuildroot-282ffecbe3c6fa123979ad2beb0b8fe86ecf5192.tar.gz
buildroot-282ffecbe3c6fa123979ad2beb0b8fe86ecf5192.tar.bz2
package/google-breakpad: really fix the C++11 dependency
The C++11 build issue is still here since the C++11 is not complete in gcc 4.7 [1]. So disable Google-breakpad for toolchains based on gcc <= 4.7. [1] https://gcc.gnu.org/gcc-4.7/cxx0x_status.html Fixes: http://autobuild.buildroot.net/results/c5e/c5e629f26bf6da369dff1e4588c16d2773173e9f Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/google-breakpad/Config.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/google-breakpad/Config.in b/package/google-breakpad/Config.in
index c6171afefd..e0e91068be 100644
--- a/package/google-breakpad/Config.in
+++ b/package/google-breakpad/Config.in
@@ -6,8 +6,8 @@ config BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS
config BR2_PACKAGE_GOOGLE_BREAKPAD
bool "google-breakpad"
depends on BR2_INSTALL_LIBSTDCPP
- depends on BR2_HOST_GCC_AT_LEAST_4_7 # C++11
- depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
+ depends on BR2_HOST_GCC_AT_LEAST_4_8 # C++11
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
depends on BR2_USE_WCHAR
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on (BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_UCLIBC)
@@ -34,9 +34,9 @@ config BR2_PACKAGE_GOOGLE_BREAKPAD
https://chromium.googlesource.com/breakpad/breakpad
-comment "google-breakpad requires a glibc or uClibc toolchain w/ wchar, thread, C++, gcc >= 4.7"
+comment "google-breakpad requires a glibc or uClibc toolchain w/ wchar, thread, C++, gcc >= 4.8"
depends on BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
!BR2_TOOLCHAIN_HAS_THREADS || \
!(BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_UCLIBC) || \
- !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 || !BR2_HOST_GCC_AT_LEAST_4_7
+ !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || !BR2_HOST_GCC_AT_LEAST_4_8