aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorGravatar Carlos Santos <casantos@datacom.com.br>2018-11-24 23:21:22 -0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-25 09:14:51 +0100
commit3940e27462ef28053b4c779643f18918812309d1 (patch)
tree519843de5a63f6689c22c9c4230d203fd656cfec /package
parent8cf118e406ae2809f61872dae31d7584d414ae09 (diff)
downloadbuildroot-3940e27462ef28053b4c779643f18918812309d1.tar.gz
buildroot-3940e27462ef28053b4c779643f18918812309d1.tar.bz2
qemu: enable seccomp if libseccomp is selected
It is required to use qemu with libvirt and allows us to resume working on the libvirt package (https://patchwork.ozlabs.org/patch/841613). Signed-off-by: Carlos Santos <casantos@datacom.com.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package')
-rw-r--r--package/qemu/qemu.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 5ee6abf731..66b74467b9 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -81,6 +81,13 @@ else
QEMU_OPTS += --disable-tools
endif
+ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
+QEMU_OPTS += --enable-seccomp
+QEMU_DEPENDENCIES += libseccomp
+else
+QEMU_OPTS += --disable-seccomp
+endif
+
ifeq ($(BR2_PACKAGE_LIBSSH2),y)
QEMU_OPTS += --enable-libssh2
QEMU_DEPENDENCIES += libssh2
@@ -121,7 +128,6 @@ define QEMU_CONFIGURE_CMDS
--disable-libiscsi \
--disable-usb-redir \
--disable-strip \
- --disable-seccomp \
--disable-sparse \
--disable-mpath \
--disable-sanitizers \