aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorGravatar Danomi Manchego <danomimanchego123@gmail.com>2018-04-18 05:03:39 -0400
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-04-19 23:37:28 +0200
commit4b948c2a32188ad38b820163b5b5f06ab15c8666 (patch)
tree35ffba723d3aab0743d58a1e67325a37386f1f96 /package
parent5301ddebb0e31edf804e434d6b900261504c6b6d (diff)
downloadbuildroot-4b948c2a32188ad38b820163b5b5f06ab15c8666.tar.gz
buildroot-4b948c2a32188ad38b820163b5b5f06ab15c8666.tar.bz2
prosody: add dependency on shared libraries
The prosody package uses several Lua packages that require shared libraries. Therefore, prosody must require shared libraries too. Fixes: http://autobuild.buildroot.net/results/b126bce0bbd111f021ed5be7c8773fef2a8f8579 Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package')
-rw-r--r--package/prosody/Config.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/prosody/Config.in b/package/prosody/Config.in
index ef26e2750b..133b0b1343 100644
--- a/package/prosody/Config.in
+++ b/package/prosody/Config.in
@@ -2,6 +2,7 @@ config BR2_PACKAGE_PROSODY
bool "prosody"
depends on BR2_USE_MMU # fork
depends on BR2_PACKAGE_HAS_LUAINTERPRETER
+ depends on !BR2_STATIC_LIBS # luaexpat, luasec, luasocket, luafilesystem
select BR2_PACKAGE_LUAEXPAT # runtime
select BR2_PACKAGE_LUASEC # runtime
select BR2_PACKAGE_LUASOCKET # runtime
@@ -15,6 +16,6 @@ config BR2_PACKAGE_PROSODY
https://prosody.im
-comment "prosody needs the lua interpreter"
- depends on !BR2_PACKAGE_HAS_LUAINTERPRETER
+comment "prosody needs the lua interpreter, dynamic library"
+ depends on !BR2_PACKAGE_HAS_LUAINTERPRETER || BR2_STATIC_LIBS
depends on BR2_USE_MMU