aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorGravatar Ricardo Martincoski <ricardo.martincoski@datacom.ind.br>2018-04-19 16:14:17 -0300
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-04-19 23:13:35 +0200
commit905f8d814ad21af9c3fd22ececce0824cb20db80 (patch)
treee7649f0b365c0c83817d356ca3fefc7c7b13818a /package
parente2b71e852dc4200ce48715a9e9b5ed44379bfec8 (diff)
downloadbuildroot-905f8d814ad21af9c3fd22ececce0824cb20db80.tar.gz
buildroot-905f8d814ad21af9c3fd22ececce0824cb20db80.tar.bz2
syslog-ng: bump version header in conf file to 3.10
Remove a runtime warning message about configuration file being too old. Do the same as commit 3dad25466d "syslog-ng: Bump version header in conf file to 3.9". Package version of syslog-ng is 3.10.1, so bump version number in syslog-ng.conf to 3.10. Also add a comment to avoid the same warning message reappears when the package is bumped. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@datacom.ind.br> Cc: Chris Packham <judge.packham@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package')
-rw-r--r--package/syslog-ng/syslog-ng.conf2
-rw-r--r--package/syslog-ng/syslog-ng.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/syslog-ng/syslog-ng.conf b/package/syslog-ng/syslog-ng.conf
index a3384eebc3..e767255d71 100644
--- a/package/syslog-ng/syslog-ng.conf
+++ b/package/syslog-ng/syslog-ng.conf
@@ -1,4 +1,4 @@
-@version: 3.9
+@version: 3.10
source s_sys {
file("/proc/kmsg" program_override("kernel"));
diff --git a/package/syslog-ng/syslog-ng.mk b/package/syslog-ng/syslog-ng.mk
index 325fac5842..2b6f2c09e9 100644
--- a/package/syslog-ng/syslog-ng.mk
+++ b/package/syslog-ng/syslog-ng.mk
@@ -4,6 +4,8 @@
#
################################################################################
+# When updating the version, please check at runtime if the version in
+# syslog-ng.conf header needs to be updated
SYSLOG_NG_VERSION = 3.10.1
SYSLOG_NG_SITE = https://github.com/balabit/syslog-ng/releases/download/syslog-ng-$(SYSLOG_NG_VERSION)
SYSLOG_NG_LICENSE = LGPL-2.1+ (syslog-ng core), GPL-2.0+ (modules)