aboutsummaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorGravatar Eric Le Bihan <eric.le.bihan.dev@free.fr>2014-03-31 11:44:18 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-03 20:20:23 +0200
commit6dc3b6dd09638d1966daef31e1a1ec5b09b69432 (patch)
treec1997fe96cdd676db01107b7b005c5b295eb98dd /system
parenta9bdd2292e4a1a5439e406d50bbef6dad5b86fb3 (diff)
downloadbuildroot-6dc3b6dd09638d1966daef31e1a1ec5b09b69432.tar.gz
buildroot-6dc3b6dd09638d1966daef31e1a1ec5b09b69432.tar.bz2
systemd: needs kernel headers >= 3.8
Systemd needs Linux headers >= 3.8 because it uses IFLA_GRE_FLOWINFO, IFLA_IPTUN_FLAGS from linux/if_tunnel.h. Fixes http://autobuild.buildroot.org/results/ad3/ad3b4003dc50582a493f1156234d83652104a6bf/ Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'system')
-rw-r--r--system/Config.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/system/Config.in b/system/Config.in
index 8ff8d49ac2..ba225cee18 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -96,12 +96,12 @@ config BR2_INIT_SYSTEMD
depends on BR2_TOOLCHAIN_HAS_SSP
depends on BR2_USE_MMU
depends on !BR2_PREFER_STATIC_LIB
- depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8
select BR2_PACKAGE_SYSTEMD
-comment 'systemd needs an (e)glibc toolchain, headers >= 3.0'
+comment 'systemd needs an (e)glibc toolchain, headers >= 3.8'
depends on !(BR2_TOOLCHAIN_USES_GLIBC \
- && BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0)
+ && BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8)
config BR2_INIT_NONE
bool "None"