aboutsummaryrefslogtreecommitdiff
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorGravatar Ulf Samuelsson <ulf.samuelsson@atmel.com>2007-08-01 06:17:34 +0000
committerGravatar Ulf Samuelsson <ulf.samuelsson@atmel.com>2007-08-01 06:17:34 +0000
commitf60c51c436501fe50b529e59e434feff750ae663 (patch)
tree57d9bb7d46fa3aae8764780c95acb24df1619a2b /toolchain/kernel-headers
parentf7e034d1b27acc0c27a01291314aeb843e551a99 (diff)
downloadbuildroot-f60c51c436501fe50b529e59e434feff750ae663.tar.gz
buildroot-f60c51c436501fe50b529e59e434feff750ae663.tar.bz2
Allow use of 2.6.22.1 kernel headers
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Config.in25
1 files changed, 15 insertions, 10 deletions
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 50a8756ee8..2fafc1d45c 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -13,45 +13,49 @@ choice
the kernel you intend to use on your target system.
config BR2_KERNEL_HEADERS_2_4_25
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.4.25 kernel headers"
config BR2_KERNEL_HEADERS_2_4_27
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.4.27 kernel headers"
config BR2_KERNEL_HEADERS_2_4_29
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.4.29 kernel headers"
config BR2_KERNEL_HEADERS_2_4_31
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.4.31 kernel headers"
config BR2_KERNEL_HEADERS_2_6_9
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "Linux 2.6.9 kernel headers"
config BR2_KERNEL_HEADERS_2_6_11
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "Linux 2.6.11 kernel headers"
config BR2_KERNEL_HEADERS_2_6_12
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.6.12 kernel headers"
config BR2_KERNEL_HEADERS_2_6_19_2
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.6.19.2 kernel headers"
config BR2_KERNEL_HEADERS_2_6_20
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "Linux 2.6.20 kernel headers"
config BR2_KERNEL_HEADERS_2_6_21
- depends !BR2_nios2
+ depends !BR2_avr32 && !BR2_nios2
bool "Linux 2.6.21.x kernel headers"
+ config BR2_KERNEL_HEADERS_2_6_22
+ depends !BR2_nios2
+ bool "Linux 2.6.22.x kernel headers"
+
endchoice
config BR2_DEFAULT_KERNEL_HEADERS
@@ -66,3 +70,4 @@ config BR2_DEFAULT_KERNEL_HEADERS
default "2.6.19.2" if BR2_KERNEL_HEADERS_2_6_19_2
default "2.6.20.4" if BR2_KERNEL_HEADERS_2_6_20
default "2.6.21.5" if BR2_KERNEL_HEADERS_2_6_21
+ default "2.6.22.1" if BR2_KERNEL_HEADERS_2_6_22