aboutsummaryrefslogtreecommitdiff
path: root/toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in
diff options
context:
space:
mode:
authorGravatar Paul Burton <paul.burton@mips.com>2018-11-30 16:55:22 +0000
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-01 21:41:59 +0100
commit38950668352df48349eab02da7d09a4d5cb99705 (patch)
tree21bc972f8c6bafda371379233475d7304ebb2580 /toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in
parent75f832d079d22641cd9c0258700767b656866549 (diff)
downloadbuildroot-38950668352df48349eab02da7d09a4d5cb99705.tar.gz
buildroot-38950668352df48349eab02da7d09a4d5cb99705.tar.bz2
toolchain/toolchain-external-codescape-mti-mips: bump to 2018.09-02
The 2016.05-06 toolchain we've had support for is pretty outdated at this point, so update to the latest 2018.09-02 version. Of note besides the typical component version bumps: - The toolchains are now provided by MIPS Tech LLC after its departure from Imagination Technologies. - The download site changed as a result of that. - The toolchains are now built targeting CentOS 6 rather than CentOS 5. Signed-off-by: Paul Burton <paul.burton@mips.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in')
-rw-r--r--toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in b/toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in
index 5d466a58f4..c07a1b88b5 100644
--- a/toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in
+++ b/toolchain/toolchain-external/toolchain-external-codescape-mti-mips/Config.in
@@ -1,20 +1,20 @@
config BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_MTI_MIPS
- bool "Codescape MTI GNU Linux Toolchain 2016.05"
+ bool "Codescape MTI GNU Linux Toolchain 2018.09"
depends on BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
- depends on !BR2_ARCH_NEEDS_GCC_AT_LEAST_5
+ depends on !BR2_ARCH_NEEDS_GCC_AT_LEAST_7
depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
depends on BR2_MIPS_CPU_MIPS32R2 || (BR2_MIPS_CPU_MIPS64R2 && !BR2_MIPS_SOFT_FLOAT) || \
BR2_MIPS_CPU_MIPS32R5 || (BR2_MIPS_CPU_MIPS64R5 && !BR2_MIPS_SOFT_FLOAT)
select BR2_TOOLCHAIN_EXTERNAL_GLIBC
select BR2_INSTALL_LIBSTDCPP
select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_7
- select BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
+ select BR2_TOOLCHAIN_GCC_AT_LEAST_6
select BR2_TOOLCHAIN_HAS_FORTRAN
help
- Codescape MTI GNU Linux Toolchain 2016.05 for the MIPS
- architecture, from Imagination Technologies. It uses gcc
- 4.9.2, binutils 2.24.90, glibc 2.20, gdb 7.9.1 and kernel
- headers 4.7. It has support for the following variants:
+ Codescape MTI GNU Linux Toolchain 2018.09 for the MIPS architecture,
+ from MIPS Tech LLC. It uses gcc 6.3.0, binutils 2.28.51, glibc 2.20,
+ gdb 7.9.1 and kernel headers 4.7. It has support for the following
+ variants:
- MIPS32r2 - Big-Endian, Hard-Float, Legacy NaN, o32 ABI
Select 'MIPS (big endian)' Target Architecture
Select 'mips 32r2' Target Architecture Variant