aboutsummaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorGravatar Ulf Samuelsson <ulf.samuelsson@atmel.com>2007-07-29 17:36:45 +0000
committerGravatar Ulf Samuelsson <ulf.samuelsson@atmel.com>2007-07-29 17:36:45 +0000
commit77ae73b45efdc2232fb775695340963a16529787 (patch)
tree0974673b4502b35c0644895ff7dedac7926cb4f3 /toolchain
parent6933f971de89acce11c60966237936b99af075cf (diff)
downloadbuildroot-77ae73b45efdc2232fb775695340963a16529787.tar.gz
buildroot-77ae73b45efdc2232fb775695340963a16529787.tar.bz2
gcc config for AVR32
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in52
1 files changed, 33 insertions, 19 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index fe95bce439..2c47f12582 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -9,58 +9,59 @@ choice
Select the version of gcc you wish to use.
config BR2_GCC_VERSION_3_3_5
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 3.3.5"
config BR2_GCC_VERSION_3_3_6
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 3.3.6"
config BR2_GCC_VERSION_3_4_2
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "gcc 3.4.2"
config BR2_GCC_VERSION_3_4_3
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "gcc 3.4.3"
config BR2_GCC_VERSION_3_4_4
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "gcc 3.4.4"
config BR2_GCC_VERSION_3_4_5
- depends BR2_DEPRECATED
+ depends !BR2_avr32 && BR2_DEPRECATED
bool "gcc 3.4.5"
config BR2_GCC_VERSION_3_4_6
+ depends on !BR2_avr32
bool "gcc 3.4.6"
config BR2_GCC_VERSION_4_0_0
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.0"
config BR2_GCC_VERSION_4_0_1
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.1"
config BR2_GCC_VERSION_4_0_2
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.2"
config BR2_GCC_VERSION_4_0_3
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.3"
config BR2_GCC_VERSION_4_0_4
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.0.4"
config BR2_GCC_VERSION_4_1_0
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.1.0"
config BR2_GCC_VERSION_4_1_1
- depends !BR2_nios2 && BR2_DEPRECATED
+ depends !BR2_avr32 && !BR2_nios2 && BR2_DEPRECATED
bool "gcc 4.1.1"
config BR2_GCC_VERSION_4_1_2
@@ -68,21 +69,22 @@ choice
bool "gcc 4.1.2"
config BR2_GCC_VERSION_4_2_0
- depends !BR2_nios2
+ depends !BR2_avr32 && !BR2_nios2
bool "gcc 4.2.0"
config BR2_GCC_VERSION_4_2_1
- depends !BR2_nios2
+ depends !BR2_avr32 && !BR2_nios2
bool "gcc 4.2.1"
# config BR2_GCC_VERSION_4_3
-# depends !BR2_nios2
+# depends !BR2_avr32 && !BR2_nios2
# select BR2_GCC_IS_SNAP
# bool "gcc 4.3"
endchoice
config BR2_GCC_IS_SNAP
+ depends !BR2_avr32
bool
default n
@@ -138,6 +140,16 @@ config BR2_GCC_USE_SJLJ_EXCEPTIONS
proper stack unwinding during exception handling. Most people
can leave this set to n.
+config BR2_GCC_AVR32_CONFIGURATION
+ bool "Enable default AVR32 GCC configuration"
+ default y
+ depends BR2_avr32
+ help
+ For the AVR32 platform there is some configuration which are not
+ supported.
+
+ Currently this will add "--disable-libmudflap" to configure.
+
config BR2_EXTRA_GCC_CONFIG_OPTIONS
string "Additional gcc options"
default ""
@@ -147,27 +159,29 @@ config BR2_EXTRA_GCC_CONFIG_OPTIONS
config BR2_INSTALL_LIBSTDCPP
bool "Build/install c++ compiler and libstdc++?"
default n
- # >= 4.2.0 work fine without LARGEFILE
- select BR2_LARGEFILE if BR2_GCC_VERSION_3_3_5 || BR2_GCC_VERSION_3_3_6 || BR2_GCC_VERSION_3_4_2 || BR2_GCC_VERSION_3_4_3 || BR2_GCC_VERSION_3_4_4 || BR2_GCC_VERSION_3_4_5 || BR2_GCC_VERSION_3_4_6 || BR2_GCC_VERSION_4_0_0 || BR2_GCC_VERSION_4_0_1 || BR2_GCC_VERSION_4_0_2 || BR2_GCC_VERSION_4_0_3 || BR2_GCC_VERSION_4_0_4 || BR2_GCC_VERSION_4_1_0 || BR2_GCC_VERSION_4_1_1 || BR2_GCC_VERSION_4_1_2
+ # huh? why so? select BR2_LARGEFILE
+ select BR2_LARGEFILE if !BR2_GCC_VERSION_4_2_0 && !BR2_GCC_VERSION_4_3
help
Build/install c++ compiler and libstdc++?
config BR2_INSTALL_LIBGCJ
bool "Build/install java compiler and libgcj?"
default n
- depends on BR2_INSTALL_LIBSTDCPP
+ depends on !BR2_avr32 && BR2_INSTALL_LIBSTDCPP
help
Build/install java compiler and libgcj?
config BR2_INSTALL_OBJC
bool "Build/install Objective-C compiler and runtime?"
default n
+ depends on !BR2_avr32
help
Build/install Objective-C compiler and runtime?
config BR2_INSTALL_FORTRAN
bool "Build/install Fortran compiler and runtime?"
default n
+ depends on !BR2_avr32
select BR2_PACKAGE_LIBMPFR
help
Build/install Fortran compiler and runtime?