aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Config.in.legacy24
-rw-r--r--package/lua/Config.in10
-rw-r--r--package/lua/lua.mk4
3 files changed, 31 insertions, 7 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 17ead9b9de..ce44d0f5cc 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -101,6 +101,30 @@ endif
###############################################################################
comment "Legacy options removed in 2014.05"
+config BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
+ bool "Lua command-line editing none has been renamed"
+ select BR2_LEGACY
+ help
+ The BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE option has been
+ renamed to BR2_PACKAGE_LUA_EDITING_NONE. You will have to select
+ it in the corresponding choice.
+
+config BR2_PACKAGE_LUA_INTERPRETER_READLINE
+ bool "Lua command-line editing using readline has been renamed"
+ select BR2_LEGACY
+ help
+ The BR2_PACKAGE_LUA_INTERPRETER_READLINE option has been
+ renamed to BR2_PACKAGE_LUA_READLINE. You will have to select
+ it in the corresponding choice.
+
+config BR2_PACKAGE_LUA_INTERPRETER_LINENOISE
+ bool "Lua command-line editing using linenoise has been renamed"
+ select BR2_LEGACY
+ help
+ The BR2_PACKAGE_LUA_INTERPRETER_LINENOISE option has been
+ renamed to BR2_PACKAGE_LUA_LINENOISE. You will have to select
+ it in the corresponding choice.
+
config BR2_PACKAGE_DVB_APPS_UTILS
bool "dvb-apps utilities now built by default"
select BR2_LEGACY
diff --git a/package/lua/Config.in b/package/lua/Config.in
index 2f1b25befd..0e318585cd 100644
--- a/package/lua/Config.in
+++ b/package/lua/Config.in
@@ -30,22 +30,22 @@ config BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION
default "5.2" if BR2_PACKAGE_LUA_5_2
choice
- prompt "Lua Interpreter command-line editing"
- default BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
+ prompt "Lua command-line editing"
+ default BR2_PACKAGE_LUA_EDITING_NONE
-config BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
+config BR2_PACKAGE_LUA_EDITING_NONE
bool "none"
help
None.
-config BR2_PACKAGE_LUA_INTERPRETER_READLINE
+config BR2_PACKAGE_LUA_READLINE
bool "readline support"
select BR2_PACKAGE_READLINE
select BR2_PACKAGE_NCURSES
help
Enables command-line editing in the Lua interpreter.
-config BR2_PACKAGE_LUA_INTERPRETER_LINENOISE
+config BR2_PACKAGE_LUA_LINENOISE
bool "linenoise support"
select BR2_PACKAGE_LINENOISE
help
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index bf68e654f2..bc8799a087 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -31,12 +31,12 @@ else
LUA_MYLIBS += -ldl
endif
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_READLINE),y)
+ifeq ($(BR2_PACKAGE_LUA_READLINE),y)
LUA_DEPENDENCIES = readline ncurses
LUA_MYLIBS += -lreadline -lhistory -lncurses
LUA_CFLAGS += -DLUA_USE_READLINE
else
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_LINENOISE),y)
+ifeq ($(BR2_PACKAGE_LUA_LINENOISE),y)
LUA_DEPENDENCIES = linenoise
LUA_MYLIBS += -llinenoise
LUA_CFLAGS += -DLUA_USE_LINENOISE