aboutsummaryrefslogtreecommitdiff
path: root/package/wireguard-linux-compat
diff options
context:
space:
mode:
Diffstat (limited to 'package/wireguard-linux-compat')
-rw-r--r--package/wireguard-linux-compat/Config.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/wireguard-linux-compat/Config.in b/package/wireguard-linux-compat/Config.in
index 4ee214be63..6e41a0951b 100644
--- a/package/wireguard-linux-compat/Config.in
+++ b/package/wireguard-linux-compat/Config.in
@@ -3,6 +3,8 @@ config BR2_PACKAGE_WIREGUARD_LINUX_COMPAT
depends on BR2_LINUX_KERNEL
# kernel module requires 3.10+
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
+ # kernel module incompatible with 5.6+
+ depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_6
help
WireGuard is an extremely simple yet fast and modern VPN
that utilizes state-of-the-art cryptography. It aims to be
@@ -20,4 +22,6 @@ config BR2_PACKAGE_WIREGUARD_LINUX_COMPAT
https://www.wireguard.com
comment "wireguard-linux-compat needs a toolchain w/ headers >= 3.10"
- depends on BR2_LINUX_KERNEL && !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
+ depends on BR2_LINUX_KERNEL
+ depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_6
+ depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10