aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* configs/arm_juno: use 4.6 mainline kernelGravatar Joao Pinto2016-06-091-5/+3
| | | | | | Signed-off-by: Joao Pinto <jpinto@synopsys.com> [Thomas: use BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_6.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs/arm_juno: add support for Juno r2Gravatar Joao Pinto2016-06-092-2/+17
| | | | | Signed-off-by: Joao Pinto <jpinto@synopsys.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/mpd: fetch upstream patch to fix GCC 6 issueGravatar Jörg Krause2016-06-092-0/+4
| | | | | | | | | | | | | | | | | | | | | | Fetch a patch from upstream to fix a build issue with GCC 6: ''' In file included from /home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/bits/stl_algo.h:59:0, from /home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/algorithm:62, from ./src/queue/IdTable.hxx:25, from ./src/queue/Queue.hxx:24, from src/queue/Playlist.hxx:23, from src/Partition.hxx:23, from src/Instance.cxx:22: /home/joerg/Development/git/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/include/c++/6.1.0/cstdlib:75:25: fatal error: stdlib.h: No such file or directory #include_next <stdlib.h> ''' Bug report: https://bugs.musicpd.org/view.php?id=4524 Fetch from: aa5d05eaa4d482aa8f8df954335d0aba151eeff9 Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* wiringpi: fix musl compileGravatar Peter Seiderer2016-06-091-0/+60
| | | | | | | | | | | | | | Fixes [1]: wiringPiSPI.c:89:35: error: '_IOC_SIZEBITS' undeclared (first use in this function) Patch from yocto meta-raspberrypi [2] adding include of asm/ioctl.h. [1] http://autobuild.buildroot.net/results/e9d/e9d680af7eea6d6c68c8e48248b5cc5b29389baa [2] https://github.com/agherzan/meta-raspberrypi/blob/master/recipes-devtools/wiringPi/wiringpi/0001-include-asm-ioctl.h-directly-for-_IOC_SIZEBITS.patch Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* e2fsprogs: fix build failure with old glibc versionsGravatar Gustavo Zacarias2016-06-092-2/+56
| | | | | | | | | In old (< 2.17) glibc versions clock_gettime() resides in librt, however there's no check for this, so add a patch to fix it. Fixes: http://autobuild.buildroot.net/results/25c/25c042d2862affebf552ed24bc2a58e0c484226f/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* e2fsprogs: bump to version 1.43.1Gravatar Gustavo Zacarias2016-06-092-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libcoap: new packageGravatar Joris Lijssens2016-06-095-0/+66
| | | | | | | | | | | | | Signed-off-by: Joris Lijssens <joris.lijssens@gmail.com> [Thomas: - Adjust license: it is "GPLv2+ or BSD-2c" and not "GPLv2, BSD-2c" - Add the COPYING file to the license files, since it indicates explictly that the license is GPLv2+ or BSD-2c. - Remove the --with-shared configure options, which doesn't exist. - Use LIBCOAP_AUTORECONF = YES instead of calling the autogen.sh script manually. - Add patch to fix build with old gcc versions.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* fetchmail: fix post install target hookGravatar Thomas Petazzoni2016-06-091-1/+1
| | | | | | | | | | | Due to a typo in commit a890032596aa5e6afbfdbcccc01fcb07c9a4ef8c ("package/fetchmail: fix *.pyc compilation with python-3"), the post install target hook was in fact not registered, and the build failure kept showing up. This commit fixes the typo. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/shairport-sync: bump to version 2.8.4Gravatar Jörg Krause2016-06-092-2/+2
| | | | | Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/luvi: bump to version 2.7.2Gravatar Jörg Krause2016-06-092-4/+2
| | | | | | | Version bump includes fetched patch from upstream, so remove it. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/luv: bump to version 1.9.0-3Gravatar Jörg Krause2016-06-092-2/+2
| | | | | Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libuv: bump to version 1.9.1Gravatar Jörg Krause2016-06-092-2/+2
| | | | | Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: remove icu support from 0.10.xGravatar Martin Bark2016-06-091-0/+3
| | | | | | | | | | | | | icu support was added to nodejs in commit 7d0702a, however, 0.10.x does not have support for icu. The 0.10.x configure script will error if it is passed the --with-intl option. This commit removes icu support from 0.10.x. Fixes: http://autobuild.buildroot.net/results/932e4ec24623592255f234a098f7a90ef2ad8063 Signed-off-by: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-u-msgpack: new packageGravatar Yegor Yefremov2016-06-094-0/+26
| | | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: add umsgpack.py as license file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-pathvalidate: new packageGravatar Yegor Yefremov2016-06-094-0/+27
| | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-dataproperty: new packageGravatar Yegor Yefremov2016-06-094-0/+28
| | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* pcre: add security patchesGravatar Gustavo Zacarias2016-06-092-0/+218
| | | | | | | | | | They address: CVE-2016-1283 - Heap Buffer Overflow Vulnerability. CVE-2016-3191 - workspace overflow for (*ACCEPT) with deeply nested parentheses. Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libiio: Fix pthread linking for iiodGravatar Matthew Fornero2016-06-091-0/+30
| | | | | | | | | | | | | | | Update the iiod CMake configuration to resolve pthread linking issues introduced with commit: 17ee15da70d23c314a3264c87a785101cbd9d85d ("libiio: Bump version to 0.6") Fixes: http://autobuild.buildroot.net/results/ffe/ffec14aa79833a6f0889a87b31dae464d083e6a8/ http://autobuild.buildroot.net/results/49f/49f249632ed021ebe73ee7fab1b55fb3bb4c08f8/ Signed-off-by: Matthew Fornero <mfornero@mathworks.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* binutils: enable as target package for aarch64Gravatar Erico Nunes2016-06-084-8/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | binutils got disabled as a target package for aarch64 back in Buildroot 2012.11 (commit 660d16f4). The default version 2.21.1 at the time didn't really support aarch64, as shown by the autobuilder error reference in that commit. binutils has now had support for aarch64 since 2.23, but was never re-enabled for aarch64. All of the binutils versions currently supported by Buildroot (oldest being 2.24) support aarch64, so we can now enable it without any restrictions. This same patch also touches the dropwatch, lightning and oprofile packages which all select binutils and had the 'depends on !aarch64' to keep Kconfig consistent. They are now re-enabled for aarch64 as well. They are changed in this same patch so that Kconfig is kept consistent and doesn't end up having them disabled in a commit which only has the binutils change applied. lightning has other explicit arch dependencies so it is not actually yet available in aarch64, but at least the dependency on !aarch64 because of binutils is not needed anymore. Everything has been build tested with Buildroot and external toolchains. binutils and dropwatch work fine in a qemu target. oprofile doesn't seem to be supported in the qemu aarch64 processor but builds fine and seems to have some level of aarch64 support in the source, so there doesn't seem to be a reason to keep it disabled in Kconfig. Signed-off-by: Erico Nunes <nunes.erico@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* glibc: remove eglibc hashesGravatar Thomas Petazzoni2016-06-081-5/+0
| | | | | | | | | In commit 500de2598a4902a0e9ec53f7b475046ff17c6681, support for eglibc was removed, but forgot to remove the corresponding hashes from the hash file. This commit fixes this mistake. Reported-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/net-tools: use TARGET_CONFIGURE_OPTS to provide AR, CC and LDFLAGSGravatar Romain Naour2016-06-081-2/+1
| | | | | | | | | | | | | As noticed by Peter [1], use TARGET_CONFIGURE_OPTS to provide AR, CC and LDFLAGS. Also remove TARGET_MAKE_ENV since it only contains PATH=$(BR_PATH) which is also provided by TARGET_CONFIGURE_OPTS. [1] http://lists.busybox.net/pipermail/buildroot/2016-May/162418.html Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs: new configuration for i.MX25 PDKGravatar Fabio Estevam2016-06-084-0/+145
| | | | | | | | Add support for i.MX25 PDK board using U-boot 2016.05 and kernel 4.6.1. Signed-off-by: Fabio Estevam <fabio.estevam@nxp.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs: new configuration for NXP i.MX51 EVKGravatar Fabio Estevam2016-06-085-0/+195
| | | | | | | | | | | | | Add a new configuration for NXP i.MX51 EVK based on U-boot 2016.05 and kernel 4.6.1. U-boot 2016.05 needs the patch c510f2e436008 ("video: ipu_common: fix build error") that is already in mainline to fix an IPU build error. We can remove this patch in the future when we switch to U-boot 2016.07. Signed-off-by: Fabio Estevam <festevam@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/openpowerlink: fix uClibc buildGravatar Romain Naour2016-06-081-0/+61
| | | | | | | | | | | | | In the demo application code, va_list type is used in eventlogstring.h so stdarg.h must be included to define it. This problem occurs with a uClibc-ng based toolchain. Fixes: http://autobuild.buildroot.net/results/a9e/a9e7615a19922706039bf97ccb94bcf5b99330b2 Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/openpowerlink: link demos applications with PCIe library interfaceGravatar Romain Naour2016-06-081-0/+3
| | | | | | | | | | | In commit f1bc98f396778c9fd8c884527787eb538212f398 the CFG_BUILD_KERNEL_STACK option wasn't set when the PCIe library interface is selected. The build fail since the default choice "Link to Application" (which require libpcap) is used. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/openpowerlink: fix sha256 hashGravatar Romain Naour2016-06-081-1/+1
| | | | | | | | While bumping to v2.4.0, the sha256 was commented by mistake and the hash was for v2.3.2 archive. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/fetchmail: fix *.pyc compilation with python-3Gravatar Samuel Martin2016-06-081-0/+10
| | | | | | | | | | | | | This change removes the fetchmailconf.py python module when the python interpreter is python-3, because this module is not yet python-3 compliant. Fixes: http://autobuild.buildroot.org/results/700/7009445dd116a1c02db82a351d38db44db8dad16/ ... Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-dateutil: new packageGravatar Yegor Yefremov2016-06-084-0/+26
| | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-pytz: new packageGravatar Yegor Yefremov2016-06-084-0/+25
| | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs/qemu: bump to latest versionGravatar Gustavo Zacarias2016-06-0848-199/+98
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Also bump the pc samples since they're tied to the (base) qemu config. Results table: Defconfig Kernel Qemu Network Status -------------------------------------------------------------- aarch64_virt 4.5.6 2.5.0 YES OK (4) arm_versatile 4.6.1 2.5.0 YES OK arm_vexpress 4.6.1 2.5.0 YES OK m68k_mcf5208 4.6.1 2.5.0 YES OK m68k_q800 4.6.1 q800-v2.4.0 NO (3) OK microblazebe 4.6.1 2.5.0 YES OK microblazeel 4.6.1 2.5.0 YES OK mips64el_malta 4.6.1 2.5.0 YES OK mips64_malta 4.6.1 2.5.0 YES OK mipsel_malta 4.6.1 2.5.0 YES OK mips_malta 4.6.1 2.5.0 YES OK ppc_g3beige 4.6.1 2.5.0 YES OK ppc_mpc8544ds 4.6.1 2.5.0 YES OK ppc_virtex_ml507 4.6.1 2.5.0 NO OK ppc64_pseries 4.6.1 2.5.0 YES OK sh4 4.6.1 2.5.0 YES OK sh4eb 4.6.1 2.5.0 NO (1) OK sparc_ss10 4.6.1 2.5.0 YES OK sparc64_sun4u 4.6.1 2.5.0 YES OK sparc_sun4u 4.6.1 2.5.0 YES OK x86 4.6.1 2.5.0 YES OK x86_64 4.6.1 2.5.0 YES OK xtensa_lx60 4.6.1 2.6.0 YES OK (2) xtensa_lx60_nommu 4.6.1 2.6.0 YES OK (2) (1) - Probably an endian issue with 8139 emulation/driver (2) - Linux 4.5/4.6 doesn't work with older Qemu versions (3) - There's a network interface, but enabling it in qemu fails (4) - Console looks dead in 4.6 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/lcdapi: add hashGravatar Bernd Kuhls2016-06-081-0/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/am335x-pru-package: add hashGravatar Bernd Kuhls2016-06-081-0/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/p7zip: add support for blackfinGravatar Bernd Kuhls2016-06-082-3/+19
| | | | | | | | | | Tested using this defconfig: BR2_bfin=y BR2_PACKAGE_P7ZIP=y Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* mosquitto: bump to version 1.4.9Gravatar Peter Korsgaard2016-06-082-3/+3
| | | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* nftables: bump to version 0.6Gravatar Gustavo Zacarias2016-06-082-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libnftnl: bump to version 1.0.6Gravatar Gustavo Zacarias2016-06-086-94/+186
| | | | | | | | It now requires 3.12.x series headers so adjust the dependencies to match. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* wireshark: security bump to version 2.0.4Gravatar Gustavo Zacarias2016-06-082-3/+3
| | | | | | | | | | | | | | | | Fixes: WNPA-SEC-2016-29 - The SPOOLS dissector could go into an infinite loop. WNPA-SEC-2016-30 - The IEEE 802.11 dissector could crash. WNPA-SEC-2016-31 - The IEEE 802.11 dissector could crash. WNPA-SEC-2016-32 - The UMTS FP dissector could crash. WNPA-SEC-2016-33 - Some USB dissectors could crash. WNPA-SEC-2016-34 - The Toshiba file parser could crash. WNPA-SEC-2016-35 - The CoSine file parser could crash. WNPA-SEC-2016-36 - The NetScreen file parser could crash. WNPA-SEC-2016-37 - The Ethernet dissector could crash. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* mesa3d: Add drm to EGL platforms for VC4Gravatar Akihiko Odaki2016-06-081-0/+2
| | | | | | | VC4 is a DRM driver. Signed-off-by: Akihiko Odaki <akihiko.odaki.4i@stu.hosei.ac.jp> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux: bump default to version 4.6.2Gravatar Gustavo Zacarias2016-06-081-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux-headers: bump 3.{18, 14}.x and 4.{1, 4, 5, 6}.x seriesGravatar Gustavo Zacarias2016-06-081-6/+6
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libftdi1: bump to version 1.3Gravatar Yegor Yefremov2016-06-082-2/+2
| | | | | Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* p7zip: new packageGravatar André Hentschel2016-06-084-0/+49
| | | | | | | | | | | | | Only enabled on a subset of known-working architectures. It fails to build on some archs, like blackfin. Signed-off-by: André Hentschel <nerv@dawncrow.de> [Thomas: - Add comment about the Blackfin exception. - Propagate the Blackfin exception to the Config.in comment. - Fix the license, it is the LGPLv2.1+ *with* the unRAR restriction. - Use $(INSTALL) -D -m 0755 to install the binary instead of cp.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/boost: Add Kconfig option for new module metaparseGravatar Bernd Kuhls2016-06-082-0/+4
| | | | | | | | The module description can be found in the release notes of v1.61.0: http://www.boost.org/users/history/version_1_61_0.html Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/boost: bump version to 1.61.0Gravatar Bernd Kuhls2016-06-087-177/+4
| | | | | | | removed patches applied upstream, renumbered remaining patches. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/rtl8821au: bump versionGravatar Bernd Kuhls2016-06-082-2/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* samba4: bump to version 4.4.4Gravatar Gustavo Zacarias2016-06-082-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/x11r7/xdriver_xf86-video-tdfx: disable DRI support when not availableGravatar Bernd Kuhls2016-06-071-0/+4
| | | | | | | | | Fixes http://autobuild.buildroot.net/results/304/304b68d14da026755d9d9323ed60f4f86adc7a96/ http://autobuild.buildroot.net/results/2b2/2b2558661850db295e670edfb5943973e93e01e4/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/x11r7/xdriver_xf86-video-tdfx: Re-wrap _DEPENDENCIESGravatar Bernd Kuhls2016-06-071-1/+10
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* zeromq: fix sparc32 compileGravatar Waldemar Brodkorb2016-06-071-0/+30
| | | | | | | | Code is otherwise compiled with sparcv9 optimization and cannot be run on sparc32 (sparcv8) machine. Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/rpi-userland: bump version, add hashGravatar Bernd Kuhls2016-06-072-1/+3
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>