aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* linux: bump default to version 4.17.15Gravatar Bernd Kuhls2018-08-161-1/+1
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux-headers: bump 4.{4, 9, 14, 17}.x seriesGravatar Bernd Kuhls2018-08-161-4/+4
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* boost: put back chrono select for coroutineGravatar Fabrice Fontaine2018-08-161-0/+1
| | | | | | | | | | | | | | coroutine module does use chrono directly: ./libs/coroutine/performance/asymmetric/segmented/Jamfile.v2: <library>/boost/chrono//boost_chrono ./libs/coroutine/performance/asymmetric/Jamfile.v2: <library>/boost/chrono//boost_chrono ./libs/coroutine/performance/symmetric/segmented/Jamfile.v2: <library>/boost/chrono//boost_chrono ./libs/coroutine/performance/symmetric/Jamfile.v2: <library>/boost/chrono//boost_chrono So put back select of chrono for coroutine Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* libselinux: add patch to fix build with gcc < 4.7Gravatar Thomas Petazzoni2018-08-161-0/+70
| | | | | | | | | | | This commit adds a patch from Hollis Blanchard on libselinux to fix build on host machines that have gcc < 4.7. Fixes: http://autobuild.buildroot.net/results/a82bb0c0b22ff24263ad7a7d165b21c0df7b3b1d/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* bzip2: change upstream siteGravatar Baruch Siach2018-08-162-3/+1
| | | | | | | | | | | | The bzip.org website is down. Use the Buildroot backup download site. Remove the website link as there is no clear alternative upstream at this point. https://lwn.net/Articles/762264/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* boost: thread needs chronoGravatar Fabrice Fontaine2018-08-151-4/+1
| | | | | | | | | | | | | | | | | chrono is selected by thread (see libs/thread/build/Jamfile.v2): rule usage-requirements ( properties * ) { [...] result += <library>/boost/chrono//boost_chrono ; } So add this select for BR2_PACKAGE_BOOST_THREAD and remove it from BR2_PACKAGE_BOOST_COROUTINE, BR2_PACKAGE_BOOST_LOG, BR2_PACKAGE_TYPE_ERASURE and BR2_PACKAGE_BOOST_WAVE Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* boost: locale needs thread with icuGravatar Fabrice Fontaine2018-08-151-0/+1
| | | | | | | | | | | | | | | | | | | | output/host/usr/bin/nios2-linux-readelf -d output/staging/usr/lib/libboost_locale.so Dynamic section at offset 0x125ec0 contains 36 entries: Tag Type Name/Value 0x00000001 (NEEDED) Shared library: [libboost_chrono.so.1.67.0] 0x00000001 (NEEDED) Shared library: [libboost_thread.so.1.67.0] 0x00000001 (NEEDED) Shared library: [libboost_system.so.1.67.0] 0x00000001 (NEEDED) Shared library: [librt.so.1] 0x00000001 (NEEDED) Shared library: [libicudata.so.60] 0x00000001 (NEEDED) Shared library: [libicui18n.so.60] 0x00000001 (NEEDED) Shared library: [libicuuc.so.60] Fixes: - http://autobuild.buildroot.net/results/57838f7cd84f37b66ab7007deaea847af8f54b72 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* domoticz: fix appversion.defaultGravatar Fabrice Fontaine2018-08-151-0/+20
| | | | | | | | | | | | Retrieve correct appversion.default (9700) from upstream Without this patch, the wrong version is displayed in the web ui and when the user checks for an update, domoticz wrongly says that a new version is available This issue was reported by an email from Eyal Eshed <eeshed@coldroll.ca> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/samba4: security bump to version 4.8.4Gravatar Bernd Kuhls2018-08-152-3/+3
| | | | | | | | | | | | | | | | | Release notes: https://www.samba.org/samba/history/samba-4.8.4.html Fixes o CVE-2018-1139 (Weak authentication protocol allowed.) o CVE-2018-1140 (Denial of Service Attack on DNS and LDAP server.) o CVE-2018-10858 (Insufficient input validation on client directory listing in libsmbclient.) o CVE-2018-10918 (Denial of Service Attack on AD DC DRSUAPI server.) o CVE-2018-10919 (Confidential attribute disclosure from the AD LDAP server.) Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/pkg-golang: post-pone evaluation of variablesGravatar Mirza Krak2018-08-151-3/+3
| | | | | | | | | | | | | | | | | | | As explained in pkg-generic.mk, all variable references inside the inner-xxx-package should use $$(...). Otherwise, they are evaluated too early, and will not contain the expected value. In the content of the pkg-golang infrastructure, the <pkg>_SRC_DOMAIN, <pkg>_SRC_VENDOR and <pkg>_SRC_SOFTWARE variables were not properly escaping their reference to the $$($(2)_SITE) variable. This was not visible until now, as only target Go packages were supported, where $(2)_SITE was always defined prior to this macro being expanded. With the upcoming support of host Go packages, we need to fix this, as $(2)_SITE may be defined later, inherited from $(3)_SITE. Signed-off-by: Mirza Krak <mirza.krak@northern.tech> [Thomas: rework commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* qt5serialbus: examples need qt5 widgets moduleGravatar Peter Seiderer2018-08-141-1/+1
| | | | | | | | | | | | | | | | Fixes [1]: make[2]: Entering directory '.../build/qt5serialbus-5.11.1/examples' Some of the required modules (qtHaveModule(widgets)) are not available. Skipped. [...] cp -dpfr .../host/mips64el-buildroot-linux-gnu/sysroot/usr/lib/qt/examples/serialbus .../target/usr/lib/qt/examples/ cp: cannot stat '.../host/mips64el-buildroot-linux-gnu/sysroot/usr/lib/qt/examples/serialbus': No such file or directory [1] http://autobuild.buildroot.net/results/147809b5f8758af935bee48c0fc83fd86a8509e9 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/lvm2: Fix runtime crash when using uclibcGravatar Marcin Niestroj2018-08-142-1/+279
| | | | | | | | | | | | | | | | | | | | When using uclibc libdevmapper.so was calling dm_task_get_info_base() function recursively, leading to segmentation fault. This was happening because uclibc linker loader just takes first existing 'dm_task_get_info' (which is 'dm_task_get_info_base') symbol in elf binary, instead of default version. Add upstreamable lvm2 patch [1], which introduces --enable-symvers[=STYLE] switch. Use that switch to disable symbol versions, as we do not plan to support binaries compiled against old libdevmapper library. Fixes bug #10781. [1] https://www.redhat.com/archives/dm-devel/2018-July/msg00187.html Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* lighttpd: Add systemd tmpfile to fix lighttpd systemd bootGravatar Laurent Hartanerot2018-08-142-0/+5
| | | | | | | | | | | | | | | | | | | | | Problem starting lighttpd application with systemd. /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf 2018-06-22 11:21:34: (server.c.733) opening errorlog '/var/log/lighttpd-error.log' failed: Permission denied 2018-06-22 11:21:34: (server.c.1420) Opening errorlog failed. Going down. Lighttpd can not write the 'lighttpd-access.log' and 'lighttpd-error.log' files to the directory '/var/log/'. When using systemd the directory '/var/log' does not allow the user www-data to write. To correct the problem, we add /usr/lib/tmpfiles.d/lighttpd.conf. This file create the 'lighttpd-access.log' and 'lighttpd-error.log' files with the permission Signed-off-by: Laurent Hartanerot <laurent.hartanerot@atos.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/aircrack-ng: powerpc arch requires altivecGravatar Matt Weber2018-08-141-0/+3
| | | | | | | | | | | | | | The powerpc support in this package currently requires an arch with altivec accelerator support. This is a bug and the the powerpc arch should have a non-simd option like ARM/x86. Upstream issue: https://github.com/aircrack-ng/aircrack-ng/issues/1941 Fixes http://autobuild.buildroot.net/results/87e82a5e8d0b1c1ff10ec3e59d25bcd56b329075 Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* qt5base: fix double-conversion compile for aarch64_beGravatar Peter Seiderer2018-08-141-0/+26
| | | | | | | | | | | | Fixes [1]: ../3rdparty/double-conversion/include/double-conversion/utils.h:81:2: error: #error Target architecture was not detected as supported by Double-Conversion. #error Target architecture was not detected as supported by Double-Conversion. [1] http://autobuild.buildroot.net/results/1fe2be0f26e5b92db57a5cfb5646dd253b731a5c Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* configs/arm_juno: bump ATF to v1.3Gravatar Thomas Petazzoni2018-08-121-1/+1
| | | | | | | | | | | | | | | | | | ATF in version 1.2 fails to build with: ./build/juno/release/bl1/context_mgmt.o: In function `cm_prepare_el3_exit': context_mgmt.c:(.text.cm_prepare_el3_exit+0x54): undefined reference to `cm_set_next_context' context_mgmt.c:(.text.cm_prepare_el3_exit+0x54): relocation truncated to fit: R_AARCH64_JUMP26 against undefined symbol `cm_set_next_context' This has been fixed in ATF v1.3. Even though there are even newer versions of ATF available, we take a conservative approach, and bump to the first version that has the build issue fixed. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/88314771 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* board/technologic/ts7680: fix bogus size in genimage.cfgGravatar Thomas Petazzoni2018-08-121-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | 512B is not a correct size to express "512 bytes", and causes a genimage failure: ERROR: Invalid size suffix 'B' in '512B' To express "512 bytes", using just "512" is sufficient. With this commit, genimage works fine, and we indeed have a 512 bytes unused partition: $ fdisk -l output/images/sdcard.img Disk output/images/sdcard.img: 60 MiB, 62915584 bytes, 122882 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0x00000000 Device Boot Start End Sectors Size Id Type output/images/sdcard.img1 1 1 1 512B 0 Empty output/images/sdcard.img2 2 524289 524288 256M 83 Linux Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/88314963 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* configs: add missing dependencies of Linux on host-opensslGravatar Thomas Petazzoni2018-08-124-0/+4
| | | | | | | | | | | | | | | | | | | | | Four defconfigs have Linux kernel configuration that need OpenSSL on the host, but forgot to express this dependency, causing build failures. This commit adjusts those defconfigs, fixing the following defconfig builds: imx6ulpico_defconfig https://gitlab.com/buildroot.org/buildroot/-/jobs/88314839 imx7dpico_defconfig https://gitlab.com/buildroot.org/buildroot/-/jobs/88314841 mx51evk_defconfig https://gitlab.com/buildroot.org/buildroot/-/jobs/88314847 orangepi_lite_defconfig https://gitlab.com/buildroot.org/buildroot/-/jobs/88314883 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* configs/snps_archs38_vdk: use post-build script instead of overlayGravatar Thomas Petazzoni2018-08-121-1/+1
| | | | | | | | | | | | | | | | | | | In commit 2cdfa6c84951b25e805d329cb7bae833d333538f ("synopsys/axs10x: Update /etc/inittab by post-build"), two Synopsys platforms were changed to use a post-build script adding an extra getty in the inittab instead of a rootfs overlay containing a custom inittab. However, in this commit, configs/snps_archs38_vdk_defconfig was not changed, even though it was using the same rootfs overlay. This commit therefore adjusts configs/snps_archs38_vdk_defconfig to also use the newly introduced post-build script, fixing the build of configs/snps_archs38_vdk_defconfig. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/88314952 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* configs/raspberrypi2: increase ext4 filesystem sizeGravatar Thomas Petazzoni2018-08-121-0/+1
| | | | | | | | | | | | | The default size of the ext4 filesystem is no longer sufficient to hold all the kernel modules built by the RPi Linux kernel configuration. Let's increase to 120 MB, like we did for raspberrypi3_defconfig. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/88314938 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* ncmpc: fix build with some old toolchainsGravatar Fabrice Fontaine2018-08-121-0/+54
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | With some "old" toolchains (glibc, uclibc in version 4.9.4, 5.3, 5.4, 5.5 ...), the following error is raised by the compiler: ../src/screen.cxx:60:29: required from here /usr/lfs/v0/rc-buildroot-test/scripts/instance-1/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/ext/new_allocator.h:120:4: error: no matching function for call to 'std::pair<const screen_functions* const, std::unique_ptr<Page> >::pair(const screen_functions*, Page*)' [...] /usr/lfs/v0/rc-buildroot-test/scripts/instance-1/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/stl_pair.h:112:26: note: candidate: constexpr std::pair<_T1, _T2>::pair(const _T1&, const _T2&) [with _T1 = const screen_functions* const; _T2 = std::unique_ptr<Page>] _GLIBCXX_CONSTEXPR pair(const _T1& __a, const _T2& __b) ^ /usr/lfs/v0/rc-buildroot-test/scripts/instance-1/output/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/stl_pair.h:112:26: note: no known conversion for argument 2 from 'Page*' to 'const std::unique_ptr<Page>&' This is due to the fact that init function of screen_functions structure returns Page* but PageMap wants a std::unique_ptr<Page> To fix this, cast raw pointer into a unique_ptr with an explicit cast Fixes: - http://autobuild.buildroot.net/results/d8a7339d8bdd5cdc6bd1716585d4bcf15a2e8015 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* mesa3d-headers: fix logic to generate the dri.pc fileGravatar Thomas Petazzoni2018-08-111-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | As noted by Arnout in [1], the logic in mesa3d-headers.mk generates a bogus dri.pc file, which looks like this: prefix=/usr exec_prefix=/usr libdir=/lib includedir=/include dridriverdir=/dri Indeed, the ${...} are expanded as shell variables when the sed command is executed, while the intention is that those ${...} should go in the .pc file. By escaping those using $${...}, we get the expected .pc file: prefix=/usr exec_prefix=/usr libdir=${exec_prefix}/lib includedir=${prefix}/include dridriverdir=${libdir}/dri This was detected by the not yet committed check-package improvement from Ricardo that detects bogus ${...} usage to reference make variables. [1] http://lists.busybox.net/pipermail/buildroot/2018-July/225402.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/vlc: needs speexdsp for optional speex supportGravatar Bernd Kuhls2018-08-111-2/+2
| | | | | | | | | | | | | | Fixes configure warning: checking for SPEEX... yes checking for SPEEXDSP... no configure: WARNING: Package speexdsp was not found in the pkg-config search path. Perhaps you should add the directory containing `speexdsp.pc' to the PKG_CONFIG_PATH environment variable Package 'speexdsp', required by 'world', not found. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/vlc: Remove warning from Config.inGravatar Bernd Kuhls2018-08-111-5/+0
| | | | | | | | | | | | | | Four years ago this warning was added to this package https://git.buildroot.net/buildroot/commit/package/vlc?id=e33019aaa0409e35b725dddffe09e3e2a42959d1 due to "autobuilder failures for vlc on many platforms". The last autobuilder failure occured May 1st, 2018 and was fixed by https://git.buildroot.net/buildroot/commit/package/vlc?id=9f115bfc2ac798c737d0c2a8ec8c96670e814a49 Therefore this warning is not needed anymore. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* mtd: backport upstream bug fixGravatar David Owens2018-08-101-0/+92
| | | | | | | | | | | | | | | A regression in the mtd package prevents non-consecutive ubi volume IDs from working properly. This change backported from upstream reverts the commit [0]. The issue was originally described on the mtd mailing list: http://lists.infradead.org/pipermail/linux-mtd/2018-June/081562.html [0] http://git.infradead.org/mtd-utils.git/commitdiff/dede98ffb706676309488d7cc660f569548d5930 Signed-off-by: David Owens <david.owens@rockwellcollins.com> Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* busybox: bump version to 1.29.2Gravatar Peter Korsgaard2018-08-102-3/+3
| | | | | | | | Includes fixes for fdisk (compat fixes, allow 2TB+ sizes), gzip (FEATURE_GZIP_LEVELS was producing badly-compressed .gz), hexedit (segfault fix). Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* uboot-tools: force host CFLAGSGravatar Baruch Siach2018-08-101-0/+1
| | | | | | | | | | | | | | | | | | | U-Boot now adds -std=gnu11 when building its build utilities, like fixdep. This option is only supported since gcc version 4.7. https://gcc.gnu.org/gcc-4.7/changes.html Force usage of Buildroot HOST_CFLAGS, like we do already for host-uboot-tools, to avoid the -std=gnu11 option. Fixes: http://autobuild.buildroot.net/results/ea0/ea09b614a3c10d494939d9551c0c3bfca4626ece/ http://autobuild.buildroot.net/results/f8e/f8efd9af4d86c51fe4f5afe44db9abf9adc5718f/ http://autobuild.buildroot.net/results/c0a/c0ab35c3cb46f84863fe20c0ee92ecc2379578b6/ Cc: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* support/testing: add test for file capabilitiesGravatar Ricardo Martincoski2018-08-104-0/+56
| | | | | Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* makedevs: allow leading whitespace for capabilitiesGravatar Ricardo Martincoski2018-08-101-1/+1
| | | | | | | | | | | | | | | | | | Currently makedevs silently ignores extended attributes with leading whitespace, for example those added to a <PACKAGE>_PERMISSIONS following the recommended style from check-package. Makedevs already ignores leading whitespace for normal entries (file permission changes and device files creation). Do the same for extended attributes. Fixes: #11191. Reported-by: Jean-pierre Cartal <jpcartal@free.fr> Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ncurses: disable terminfo database install for host-ncursesGravatar Peter Korsgaard2018-08-091-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Since commit b35ad5d0b45e (ncurses: make host-ncurses use host terminfo), we are now pointing host-ncurses to the host terminfo (typically) located in /usr/share/terminfo. With this change we are reusing the existing host terminfo database, so there is no point in trying to install our own on top. The user running buildroot typically will have no write access to /usr/share/terminfo, but tic in that case falls back to writing the database to $HOME/.terminfo. Neither of which are desirable. In case $HOME/.terminfo also isn't writable, tic fails, breaking the install step for host-ncurses: ** Building terminfo database, please wait... Running sh ./shlib tic to install /usr/share/terminfo ... You may see messages regarding extended capabilities, e.g., AX. These are extended terminal capabilities which are compiled using tic -x If you have ncurses 4.2 applications, you should read the INSTALL document, and install the terminfo without the -x option. "terminfo.tmp", line 21272, terminal 'v3220': /home/peko/.terminfo: permission denied (errno 30) To fix all of this, simply disable the terminfo database install. Suggested-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Acked-by: Hollis Blanchard <hollis_blanchard@mentor.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* chrony: backport upstream patch to fix blocking on getrandom() at startup ↵Gravatar Peter Korsgaard2018-08-091-0/+42
| | | | | | | | | | | | with recent kernels chrony calls getrandom() at startup if available, so it needs a workaround for the blocking behaviour on recent (4.14.39+), similar to what was done for util-linux in commit c4d86707cd6 (util-linux: add two upstream patches to fix blocking on getrandom() with recent kernels). Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/waylandpp: fix build error with gcc 4.4/4.9Gravatar Bernd Kuhls2018-08-091-0/+28
| | | | | | | | Fixes http://autobuild.buildroot.net/results/51a/51afcd6d3c3c4839d8216b7b0dba35c8e38211f4/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* linux: bump default to version 4.17.14Gravatar Bernd Kuhls2018-08-091-1/+1
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* linux-headers: bump 4.{4, 9, 14, 17}.x seriesGravatar Bernd Kuhls2018-08-091-4/+4
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/wpa_supplicant: add upstream security fixGravatar Bernd Kuhls2018-08-092-1/+4
| | | | | | | | | | Fixes CVE-2018-14526: http://w1.fi/security/2018-1/unauthenticated-eapol-key-decryption.txt Added license hash. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/x11r7/xserver_xorg-server: bump version to 1.20.1Gravatar Bernd Kuhls2018-08-096-7/+7
| | | | | | | | Release notes for this bugfix release: https://lists.x.org/archives/xorg-announce/2018-August/002912.html Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* wireshark: bump version to 2.2.16 (security)Gravatar André Hentschel2018-08-092-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Security fixes since 2.2.15: - wnpa-sec-2018-06 RPKI-Router infinite loop. Bug 14414. CVE-2018-7325. - wnpa-sec-2018-34 BGP dissector large loop. Bug 13741. CVE-2018-14342. - wnpa-sec-2018-35 ISMP dissector crash. Bug 14672. CVE-2018-14344. - wnpa-sec-2018-36 Multiple dissectors could crash. Bug 14675. CVE-2018-14340. - wnpa-sec-2018-37 ASN.1 BER dissector crash. Bug 14682. CVE-2018-14343. - wnpa-sec-2018-38 MMSE dissector infinite loop. Bug 14738. CVE-2018-14339. - wnpa-sec-2018-39 DICOM dissector crash. Bug 14742. CVE-2018-14341. - wnpa-sec-2018-40 Bazaar dissector infinite loop. Bug 14841. - wnpa-sec-2018-41 HTTP2 dissector crash. Bug 14869. Full release notes: https://www.wireshark.org/docs/relnotes/wireshark-2.2.16.html Signed-off-by: André Hentschel <nerv@dawncrow.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/samba4: disable build of manpages and documentationGravatar Bernd Kuhls2018-08-091-0/+116
| | | | | | | | | | Fixes http://autobuild.buildroot.net/results/3f214cbb1fe2dc2c2cbfb630032e13eba81c1b5a/ and many others Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Thomas: reformat patch as Git formatted] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/samba4: drop patch numbering in patch 0003Gravatar Thomas Petazzoni2018-08-091-1/+1
| | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/samba4: reformat patch 0002 as Git-formatted patchGravatar Thomas Petazzoni2018-08-091-5/+15
| | | | | | | | This commit reformats 0002-patch-source3__libads__kerberos_keytab.c.patch as a Git-formatted patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* uclibc: ldso/arc: fix LD_DEBUG segv when printing R_ARC_NONEGravatar Alexey Brodkin2018-08-081-0/+45
| | | | | | | | | | | | | Dynamic linker used to segfault on attempt to print info about R_ARC_NONE reloaction. The fix is already in upstream master [1], should be removed on uClibc version bump. [1] https://cgit.uclibc-ng.org/cgi/cgit/uclibc-ng.git/commit/?id=269a2a2a0f863e1b43dc02f2f4f0f3c50299456e Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* cryptsetup: fix build with old host kernel headersGravatar Baruch Siach2018-08-081-1/+2
| | | | | | | | | | | | | | | | | | | | By default cryptsetup configure fails when the if_alg.h kernel header is not available. Kernels older than 2.6.38, like the one in RHEL 6 hosts, do not provide this header. Since we don't need the kernel crypto feature for host tools, just disable this feature to allow successful completion of the configure script. While at it, fix a typo in the --with-crypto_backend option (hyphen -> underscore). Should fix: http://autobuild.buildroot.net/results/ffd/ffda2579b215b53161025b7bc703091cb30ef95d/ http://autobuild.buildroot.net/results/c48/c48015f76b13fec38f650f66824e7b986eb28572/ http://autobuild.buildroot.net/results/be6/be621f71bf9da8719bf7fc943eccc9b4dc2cc43e/ Cc: Martin Hicks <mort@bork.org> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* boot-wrapper-aarch64: use SPDX identifier for 3 clause BSDGravatar Peter Korsgaard2018-08-081-1/+1
| | | | | | | Use the correct SPDX identifier for the 3 clause BSD license, like we do elsewhere. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux: bump CIP to version v4.4.138-cip25Gravatar Angelo Compagnucci2018-08-081-2/+2
| | | | | | | This patch bumps the CIP Linux kernel to version v4.4.138-cip25 Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux: bump default to version 4.17.13Gravatar Bernd Kuhls2018-08-081-1/+1
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux-headers: bump 4.{4, 9, 14, 17}.x seriesGravatar Bernd Kuhls2018-08-081-4/+4
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libgit2: security bump to version 0.27.4Gravatar Baruch Siach2018-08-083-47/+2
| | | | | | | | | | | | | | | Fixes CVE-2018-10887 and CVE-2018-10888: out-of-bounds reads when reading objects from a packfile. Also fixes out-of-bounds reads when processing smart-protocol "ng" packets (no known CVE yet). Drop upstream patch. Cc: Nicolas Cavallari <nicolas.cavallari@green-communications.fr> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Reviewed-By: Nicolas Cavallari <nicolas.cavallari@green-communications.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libarchive: add upstream security patchesGravatar Baruch Siach2018-08-083-0/+144
| | | | | | | | | | | | | | | | | | Add patches for the following security issues: CVE-2017-14501 - An out-of-bounds read flaw exists in parse_file_info in archive_read_support_format_iso9660.c when extracting a specially crafted iso9660 iso file. CVE-2017-14502 - Off-by-one error for UTF-16 names in RAR archives, leading to an out-of-bounds read in archive_read_format_rar_read_header. CVE-2017-14503 - Out-of-bounds read within lha_read_data_none() in archive_read_support_format_lha.c when extracting a specially crafted lha archive. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* CHANGES: add 2018.08-rc1 release dateGravatar Peter Korsgaard2018-08-081-1/+1
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mono: remove target mips architectureGravatar Angelo Compagnucci2018-08-051-2/+2
| | | | | | | | | | | Current version of mono doesn't compile on mips due to a bug, so disabling the mips target architecture until the bug is fixed upstream. Fixes: http://autobuild.buildroot.net/results/b402af8cb7f00dc2e69c219926b474a8e0c8d372 and many others. Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>