aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* package/libpfm4: bump to version 4.6.0Gravatar Jörg Krause2015-08-182-3/+6
| | | | | | | | | Also use checksum from sourceforge. [Thomas: re-add strong SHA256 locally calculated hash.] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/rpi-userland: bump versionGravatar Benoît Thébaudeau2015-08-181-1/+1
| | | | | | | | | | | Changes since last version: - early frame sequential 3D support, - add exposure=off option, - khronos: merge with more recent header file, - vchiq: better error handling. Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs/raspberrypi2: bump kernel version to 4.1.5Gravatar Benoît Thébaudeau2015-08-181-5/+5
| | | | | Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs/raspberrypi: bump kernel version to 4.1.5Gravatar Benoît Thébaudeau2015-08-181-6/+5
| | | | | Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/rpi-firmware: bump versionGravatar Benoît Thébaudeau2015-08-181-1/+1
| | | | | | | | | | | | | Misc enhancements and fixes all over the place, most notably: - FW: better overclocking, add Mediatek mt7601u Wi-Fi driver, bump kernel version to 4.1.5... - DT: fix SPI, I²S, gpio-poweroff, add MCP7941X, uart1, Fen Logic VGA666 board, RPi Sense HAT... - video: add early frame sequential 3D support, YUV_UV destination format, qpu deinterlace... Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/rpi-firmware: bump marking script versionGravatar Benoît Thébaudeau2015-08-181-80/+152
| | | | | | | | | | | Changes since last version: - add support for lz4-compressed kernels, - add copyright and license banners, - enable warnings and fix a few uses of undefined variables, - update from the rpi-4.0.y kernel. Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* msmtp: bump to version 1.6.2Gravatar Viallard Anthony2015-08-182-4/+4
| | | | | Signed-off-by: Anthony Viallard <viallard@syscom-instruments.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux: bump default to version 4.1.5Gravatar Benoît Thébaudeau2015-08-181-2/+2
| | | | | Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux-headers: bump 3.{2, 10, 12, 14, 18}.x and 4.1.x seriesGravatar Benoît Thébaudeau2015-08-181-6/+6
| | | | | Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* evemu: bump version to 2.2.0Gravatar Peter Seiderer2015-08-182-3/+3
| | | | | | | | | See [1] for details. [1] http://lists.freedesktop.org/archives/input-tools/2015-August/001190.html Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/batctl: bump to version 2015.1Gravatar Alex Suykov2015-08-183-194/+4
| | | | | | | | | | musl fixes have been merged upstream, so the patch is no longer needed. [Thomas: re-add locally calculated sha256 hash.] Signed-off-by: Alex Suykov <alex.suykov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* rapidxml: new packageGravatar Jonathan Ben Avraham2015-08-174-0/+45
| | | | | | | | | | | | | | | | | | | [Thomas: - Rewrap Config.in help text - Indicate that the SHA256 hash has been locally calculated, and add the MD5 and SHA1 hashes from SourceForge. - Use downloads.sourceforge.net as the download site instead of garr.dl.sourceforge.net, in order to use the SourceForge mirrors properly, and be consistent with all other Buildroot packages downloading stuff from SourceForge. - Change the license from "MIT" to "Boost Software License 1.0 or MIT" as indicated by the license.txt file. - Change the <pkg>_EXTRACT_CMDS to remove the sub-directory created by the .zip file extraction, and simplify the staging installation step accordingly.] Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libidn: bump to version 1.32Gravatar Gustavo Zacarias2015-08-102-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* stunnel: bump to version 5.22Gravatar Gustavo Zacarias2015-08-102-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/poco: bump to version 1.6.1Gravatar Jörg Krause2015-08-109-171/+131
| | | | | | | | | | | | | | Also: * switch from sourceforge to github * remove hash (github-helper) * remove upstream applied patches * re-number remaining patches * add patch to fix build issue with `--bundled` config option [Thomas: really remove hash file, since we're fetching from Github.] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libglew: bump version to 1.12.0Gravatar Bernd Kuhls2015-08-102-2/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/tor: bump version to 0.2.6.10Gravatar Bernd Kuhls2015-08-102-2/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/softether: bump versionGravatar Bernd Kuhls2015-08-101-1/+1
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* jpeg-turbo: bump version from 1.4.0 to 1.4.1Gravatar Jonathan Ben Avraham2015-08-092-4/+6
| | | | | Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* squid: bump to version 3.5.7Gravatar Gustavo Zacarias2015-08-092-4/+4
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* glibc: add version 2.22Gravatar Gustavo Zacarias2015-08-095-294/+7
| | | | | | | Switch default to version 2.21 and drop 2.20. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* whois: bump to version 5.2.10Gravatar Gustavo Zacarias2015-08-092-4/+4
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* openvpn: bump to version 2.3.8Gravatar Gustavo Zacarias2015-08-092-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* znc: bump to version 1.6.1Gravatar Gustavo Zacarias2015-08-096-317/+223
| | | | | | | | | | | Bump to release tarball version. Add hash file. Update and rework time.h patch for upstream inclusion (hopefully) by splitting the CSocket patch out. (https://github.com/znc/znc/pull/1021) Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/uboot-tools: bump to version 2015.07Gravatar Jörg Krause2015-08-085-115/+24
| | | | | | | | | Also: - update patch #1 - remove patch #3 and #4 -> applied upstream Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Update for 2015.08-rc12015.08-rc1Gravatar Thomas Petazzoni2015-08-054-9/+20
| | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* CHANGES: update with resolved issuesGravatar Thomas Petazzoni2015-08-051-0/+26
| | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* CHANGES: update with recent changesGravatar Thomas Petazzoni2015-08-051-6/+196
| | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* mpd: update to use the gcc version dependency mechanismGravatar Thomas Petazzoni2015-08-051-6/+3
| | | | | | | | mpd requires at least gcc 4.6, so use the newly introduced gcc version dependency mechanism instead of open-coded toolchain dependencies. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* libupnpp: update to use the gcc version dependency mechanismGravatar Thomas Petazzoni2015-08-051-8/+3
| | | | | | | | | | This commit changes the libupnp Config.in to use the gcc version dependency mechanism. The only reverse dependency of libupnpp is upmpdcli, which has already been updated, and requires >= 4.6, while libupnpp only requires >= 4.5. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* zmqpp: use more logical way of expressing comment dependenciesGravatar Thomas Petazzoni2015-08-051-2/+2
| | | | | | | | | In most packages, we use 'depends on !A || !B || !C' and not 'depends on !(A && B && C)' to express the dependencies of comments on missing toolchain features. As suggested by Yann E. Morin, let's switch zmqpp to this convention. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* zmqpp: update to use the gcc version dependency mechanismGravatar Thomas Petazzoni2015-08-051-7/+4
| | | | | | | | | This commit updates the zmqpp Config.in file to use the newly introduced gcc version dependency mechanism to depend on gcc >= 4.6 instead of open-coding dependencies on specific toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* upmpdcli: update to use the gcc version dependency mechanismGravatar Thomas Petazzoni2015-08-051-12/+3
| | | | | | | | | This commit updates the upmpdcli Config.in file to use the newly introduced gcc version dependency mechanism to depend on gcc >= 4.6 instead of open-coding dependencies on specific toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* libsigrok: depends on gcc >= 4.7Gravatar Thomas Petazzoni2015-08-053-15/+11
| | | | | | | | | | | | | | | | | | | | | Until recently, only the C++ bindings of libsigrok needed a recent compiler because they are written in C++11. However, now, libsigrok itself is written in C11, which is only available since gcc 4.7. So, this commit replaces the CodeSourcery-specific exclusions by a proper dependency on gcc >= 4.7. The sigrok-cli and pulseview packages, which select libsigrok, are also updated accordingly. Fixes: http://autobuild.buildroot.org/results/1d7/1d75497009f1e3b06236b3409fd768dcf7956b87/ http://autobuild.buildroot.org/results/563/563378e3f6320980153c8c972ceba5e913fe933f/ [Thomas: add autobuilder references, as suggested by Yann E. Morin.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* docs/manual: document gcc version dependenciesGravatar Thomas Petazzoni2015-08-051-0/+6
| | | | | | | | | This commit updates the Buildroot manual to document how to detail the gcc version dependencies in Config.in comments of packages, like we do for kernel headers version. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* toolchain-external: add support for gcc version dependencyGravatar Thomas Petazzoni2015-08-053-0/+102
| | | | | | | | | | | | | | | | | | | | | This commit wires up the gcc version dependency mechanism in the external toolchain backend. To do so, it: * Changes the definition of all pre-defined external toolchain profiles to select the appropriate BR2_TOOLCHAIN_GCC_AT_LEAST_* option. * For custom external toolchains, provides a visible Config.in "choice" to select the gcc version used in the external toolchain. * Adds a new check_gcc_version function, that verifies that the real gcc version found in the external toolchain matches the one declared in the Buildroot configuration. [Thomas: use better sed expression proposed by Yann E. Morin, which works with more cases.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* gcc: select the appropriate BR2_TOOLCHAIN_GCC_AT_LEAST_* optionGravatar Thomas Petazzoni2015-08-051-0/+7
| | | | | | | | | | This commit wires up the gcc version dependency mechanism in the internal toolchain backend by making the gcc version choice in the gcc package Config.in.host select the appropriate BR2_TOOLCHAIN_GCC_AT_LEAST_* option. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* toolchain: add common gcc version hidden config optionsGravatar Thomas Petazzoni2015-08-051-0/+44
| | | | | | | | | | | | This commit adds a number of hidden Config.in options, that will be used to handle dependencies on the gcc version. We mimic the model that was used for the kernel headers dependency mechanism. These hidden options will be selected by the internal and external toolchain backend logic respectively, in follow-up commits. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* binutils: fix building of Linux kernel for ARCv2 ISAGravatar Alexey Brodkin2015-08-041-0/+132
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | With the fix for missing .tdata/.tbss sections we unintentionally introduced a regression for ARCv2 ISA (read ARC HS38) kernel building. That's what we got on attempt to build kernel: ----------------------------------->8-------------------------------------- LD drivers/video/fbdev/built-in.o arc-linux-ld: ERROR: Attempting to link drivers/video/fbdev/omap2/built-in.o with a binary drivers/video/fbdev/built-in.o of different architecture arc-linux-ld: failed to merge target specific data of file drivers/video/fbdev/omap2/built-in.o scripts/Makefile.build:337: recipe for target 'drivers/video/fbdev/built-in.o' failed make[3]: *** [drivers/video/fbdev/built-in.o] Error 1 scripts/Makefile.build:403: recipe for target 'drivers/video/fbdev' failed make[2]: *** [drivers/video/fbdev] Error 2 scripts/Makefile.build:403: recipe for target 'drivers/video' failed make[1]: *** [drivers/video] Error 2 Makefile:944: recipe for target 'drivers' failed make: *** [drivers] Error 2 ----------------------------------->8-------------------------------------- The reason was empty .tdata and .tbss sections in empty archives. And later empty archives were linked in built-in.o with default architecture (in our case ARCv1 ISA, read for ARC 700) and then expected failure happened when objets for different architectures were attempted to link together. Now we have a fix for that issue, see https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/commit/a65b844aed9153789356e098984452df2f5d9058 This fix is in arc-2.23-dev branch and will be a part of the next release of ARC tools, so then this patch must be removed from buildroot. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* board: add support for ARC AXS101 and AXS103 Software Development PlatformsGravatar Alexey Brodkin2015-08-043-0/+93
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The AXS10x Platform consists of a DesignWare AXC001 CPU Card (with ARC 770D core) in case of AXS101 or AXC003 CPU Card (typically with ARC HS38 core) in case of AXS103 mounted on an ARC Software Development Platform Mainboard with DesignWare peripherals: * SD/MMC contoller * Gigabit network contoller * Serial ports (8250-compatible) * USB 2.0 * SPI * I2C It also houses HDMI output for external monitor connection. For stand-alone usage of the board (with only keyboard, mouse and montor attached) kernel console and getty made available on tty0 as well as on serial port (ttyS3). Note there're 2 prerequisites: [1] u-boot: 2015.07 - fix creation of .config http://patchwork.ozlabs.org/patch/502558/ [2] binutils: fix buildng of Linux kernel for ARCv2 ISA http://patchwork.ozlabs.org/patch/503550/ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* webkitgtk24: depend on x11 backend for gtk3Gravatar Gustavo Zacarias2015-08-041-1/+1
| | | | | | | | | The other rendering backends aren't supported right now, so depend on the X11 one to avoid build breakage. Fixes: http://autobuild.buildroot.net/results/1b3/1b372dd04eaccd8a9d24390d509b0a49f692746c/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* mtd: bump to version 1.5.2Gravatar Gustavo Zacarias2015-08-047-246/+3
| | | | | | | Patches upstream so drop them. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux: bump default to version 4.1.4Gravatar Gustavo Zacarias2015-08-041-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux-headers: bump 3.{10, 12, 14}.x and 4.1.x seriesGravatar Gustavo Zacarias2015-08-041-4/+4
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* zeromq: bump to version 4.1.2Gravatar Jonathan Ben Avraham2015-08-046-95/+5
| | | | | | | | | | | | | | | | In the upstream git://github.com/zeromq/libzmq.git: commit 6fdafc458a776e063511bb83dc7791aabea00b05 obviated the need for 0001-tests-disable-test_fork-if-fork-is-not-available.patch . commit c8ee16940fff19ae3c12b4596c4bd131b2c71996 obviated the need for 0004-allow-without-libsodium.patch . Fixed AUTORECONF comment in zeromq.mk to refer to the correct patch, 0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* dawgdic: new packageGravatar Jonathan Ben Avraham2015-08-043-0/+32
| | | | | | | | | | | | | | | | | | | The dawgdic package provides object files and utilities for building and accessing directed acyclical word graph (DAWG) dictionaries. This version of the patch uses the updated GitHub dawgdic repo instead of the Google Code repo used in the previous version of this patch. [Thomas: - use the github macro for <pkg>_SITE - remove <pkg>_SITE_METHOD, useless once you use the github macro for <pkg>_SITE - fix the license, it is BSD-3c and not GPLv3 - remove commented <pkg>_SITE in the .mk file - add missing dependency on C++.] Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: disable for static buildGravatar Jörg Krause2015-08-031-2/+5
| | | | | | | | | | | | | | nodejs requires dlopen(), etc. Fixes: http://autobuild.buildroot.net/results/87d/87dab0186abd7b2737a56b2f939f3aba294e8772/ http://autobuild.buildroot.net/results/be1/be1010a3a31642d49ec3a118858c77fed2f762b8/ [Thomas: add comment explaining that we could support static linking on ARMv5, but we don't do it since it's too much of a corner case.] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/ifplugd: add patch to fix musl build errorGravatar Jörg Krause2015-08-031-0/+24
| | | | | | | | The musl C library does not define type names such as `__uint32_t`. Instead we use the integer types declared in the ISO C standard header file <stdint.h>. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libatomic_ops: fix compilation fail on sparcGravatar Brendan Heading2015-08-031-0/+4
| | | | | | | | | | | | | | | | | | | Fixes http://autobuild.buildroot.net/results/6d8/6d83fa5d69572cec5c96be4b7651f9b113a1a19c/ libatomic_ops by default requires SPARC v9. buildroot's two supported sparc arches (SPARCv8, and leon3) are both SPARCv8-based. Unfortunately libatomic_ops's support for SPARCv8 is incomplete. The library includes fallbacks but these must expressly be enabled by defining a macro, enabled by this patch. Note that I'm testing for the SPARC variants rather than BR2_sparc, in case someone implements SPARCv9 support in the future. Discussion of this workaround described by the maintainer here : https://github.com/ivmai/libatomic_ops/issues/9 Signed-off-by: Brendan Heading <brendanheading@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/arptables: fix musl compilation issuesGravatar Brendan Heading2015-08-032-0/+198
| | | | | | | | | | | Fixes http://autobuild.buildroot.net/results/841/841129b8f49df205e1dabc2c2a5be70fa266768b/ Backported two patches from upstream which had solved this problem. Please note that 0002-src-Use-stdint-types.patch is modified to apply cleanly - details in the patch file. Signed-off-by: Brendan Heading <brendanheading@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>