aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* libmhash: new packageGravatar Gustavo Zacarias2013-01-133-0/+24
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* mtd: add options to build flash_otp_unlock and flash_otp_writeGravatar Arnout Vandecappelle (Essensium/Mind)2013-01-132-0/+8
| | | | | Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* barebox: add 2013.01.0, remove 2012.09Gravatar Fabio Porcedda2013-01-131-5/+5
| | | | | Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* barebox: needs host-lzopGravatar Fabio Porcedda2013-01-131-4/+5
| | | | | | | | | Add host-lzop dependency. Use $(TARGET_MAKE_ENV) when calling $(MAKE) to able to use binaries built for host. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* lzop: add host buildGravatar Fabio Porcedda2013-01-131-0/+1
| | | | | | | Barebox needs host-lzop. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* dvbsnoop: new package dvbsnoopGravatar Carsten Schoenert2013-01-133-0/+38
| | | | | | | | | | | | | | | | | dvbsnoop is a DVB/MPEG stream analyzer. It's designed to debug, dump or view the digital stream info available via satellite -> DVB-S, DVB-S2 cable -> DVB-C, DVB-C2 terrestrial -> DVB-T, DVB-T2 dvbsnoop can be used on any digital settopbox that running on linux and provides the DVB APIv3. It's also usable on classical PCs that contains a DVB hardware (PCI Card or USB Plug). [Peter: needs largefile, fix help text] Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* package/dvb-apps: bump versionGravatar Yann E. MORIN2013-01-131-1/+1
| | | | | | | The new version has new transponders data for CZ. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* package/dvb-apps: fix licensing terms when utils are enabledGravatar Yann E. MORIN2013-01-131-0/+3
| | | | | | | | | When the dvb-apps utilities are selected, the license is clearly a mix of GPLv2, GPLv2+ and LGPLv2.1+; this, in addition to the initial unknown license for the transponders data. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* New package : GNU SASL Library - libgsaslGravatar Sagaert Johan2013-01-133-0/+26
| | | | | | | | | | | | | GNU SASL is an implementation of the Simple Authentication and Security Layer framework and a few common SASL mechanisms. SASL is used by network servers (e.g., IMAP, SMTP) to request authentication from clients, and in clients to authenticate against servers. libgsasl will be used in future versions of libesmtp. [Peter: Misc minor fixes] Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* linux, uboot, mxs-bootlets, barebox: avoid double slash in CUSTOM_TARBALLGravatar Arnout Vandecappelle (Essensium/Mind)2013-01-134-4/+4
| | | | | | | | | | | | | | | Closes #5846 The $(dir ...) function leaves a slash at the end, so that the LINUX_SITE variable for a custom tarball ends in a slash. The DOWNLOAD macro adds another slash between SITE and SOURCE, which results in a double slash in the download URL. Fix this by stripping off the final slash from the _SITE in all packages that have a custom tarball. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* hiawatha: needs threadsGravatar Gustavo Zacarias2013-01-131-0/+4
| | | | | | | | Fixes http://autobuild.buildroot.net/results/9bb3bdb9de43fc6bab119674885df2a28e5559ee/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* cairo: bump version to 1.12.8Gravatar Sagaert Johan2013-01-133-38/+33
| | | | | | | | Directfb patch no longer needed. [Peter: Add options for script/xml backends, support for Xrender backend] Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* ofono: bump versionGravatar Sagaert Johan2013-01-131-1/+1
| | | | | Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* pixman: bump versionGravatar Sagaert Johan2013-01-131-1/+1
| | | | | Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt: bump version to latest 4.8.4Gravatar Sagaert Johan2013-01-131-1/+1
| | | | | Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qextserialport: bump versionGravatar Sagaert Johan2013-01-131-1/+1
| | | | | Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* webkit: remove X.org server dependencyGravatar Thomas Petazzoni2013-01-121-1/+1
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xvkbd: remove version from the patch file nameGravatar Thomas Petazzoni2013-01-121-0/+0
| | | | | | | | | The version in xvkbd patch file name doesn't patch the version of the package, so use the new convention that consists in not having the package version in the patch file names. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xvkbd: turn into a generic-packageGravatar Thomas Petazzoni2013-01-122-8/+11
| | | | | | | | | | | | | xvkbd was integrated has an autotools package, but it does not have a ./configure script. And to avoid executing the ./configure, the xvkbd-2.8-makefile.patch was creating a dummy .stamp_configured stamp file... Ugly. So, make xvkbd a normal generic package, with BUILD_CMDS and INSTALL_TARGET_CMDS, and get rid of the crappy part of the patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xvkbd: fix X.org dependenciesGravatar Thomas Petazzoni2013-01-122-1/+17
| | | | | | | | | xvkbd is a X.org client application, so there is no reason to depend on the X.org server. Instead, depend on the X.org client libraries that xvkbd actually links against. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* torsmo: fix X.org dependencyGravatar Thomas Petazzoni2013-01-122-1/+3
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* rubix: fix X.org dependencyGravatar Thomas Petazzoni2013-01-122-1/+2
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* metacity: fix X.org dependenciesGravatar Thomas Petazzoni2013-01-122-1/+21
| | | | | | | | | | | | | | | Metacity is a X client application, so there is no reason to depend on the X.org server. Instead, depend on the appropriate X libraries. In addition to the X.org related dependencies, we also add the host-libxml-parser-perl dependency, otherwise: checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool make[1]: *** [/home/test/outputs/xorg/build/metacity-2.25.1/.stamp_configured] Error 1 make: *** [all] Error 2 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* pango: fix X.org dependenciesGravatar Thomas Petazzoni2013-01-122-2/+14
| | | | | | | | | pango is a X client library, so it does not need to depend on the X.org server. So, we replace the server dependency by dependencies on the appropriate libraries. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* atk: remove unused host variantGravatar Thomas Petazzoni2013-01-121-4/+0
| | | | | | | | | | | | | | | | | | The atk package is used as a dependency in the libglade and libgtk2 packages. The libglade package has no host variant, and does not depend on host-atk. The libgtk2 package depends on atk, and has a host variant, but the host variant of libgtk2 overrides HOST_LIBGTK2_DEPENDENCIES to limit the number of dependencies, and host-atk is not amongst those dependencies. Therefore, host-atk is useless and can be removed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* atk: remove useless configuration optionsGravatar Thomas Petazzoni2013-01-121-8/+0
| | | | | | | | | | | ATK is not directly related to X11, and the --with-x, --x-includes, --x-libraries and --without-x options do not exist. The --disable-glibtest was duplicated, and is therefore still passed to the configuration options. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libgtk2: add support for some optional X dependenciesGravatar Thomas Petazzoni2013-01-121-0/+35
| | | | | | | | | | | | | libgtk2 can optionally use a number of features from additional X extensions, so we add support for those, to ensure that Gtk gets built after those extensions if they have been enabled in the Buildroot configuration. The extensions are Xinerama, Xinput, Xrandr, Xcursor, Xfixes, Xcomposite and Xdamage. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libgtk2: replace dependency on X.org server by dependency on librariesGravatar Thomas Petazzoni2013-01-122-1/+6
| | | | | | | | | | | | | | libgtk2 is a X client library, so it doesn't make sense for it to depend on the X.org server. Instead, it should depend on the X client libraries. This patch therefore replaces the dependency on the X server by a dependency on libX11, libXext, libXrender and fontconfig, that are the mandatory requirements to build the X backend of Gtk. [Peter: don't add an empty line before gtk demo help text] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* fltk: replace dependency on X.org server with dependency on librariesGravatar Thomas Petazzoni2013-01-122-1/+3
| | | | | | | | | fltk is a X client library, so it doesn't make sense for it to depend on the X.org server. Instead, it depends on libX11, libXext and libXt, so we use those libraries as fltk dependencies. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* docker: depend on xlib_libX11 and not the X.org serverGravatar Thomas Petazzoni2013-01-122-1/+2
| | | | | | | | | | docker is a X client application, so it doesn't make sense to depend on the X.org server. An inspection of docker Makefile and source code shows that it only needs the libX11 library, so we replace the X.org server dependency by a libX11 dependency. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* cairo: always enable XCB support when X backend is enabledGravatar Thomas Petazzoni2013-01-121-2/+2
| | | | | | | | cairo depends on xlib_libX11 for its Xlib backend. But xlib_libX11 depends on XCB, so the XCB support can always be built into Cairo. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* cairo: do not depend on xserver-xorg_server, but on the right libraryGravatar Thomas Petazzoni2013-01-122-1/+2
| | | | | | | | | cairo is a X client library, so there is no reason for it to build depend on the X.org server. What Cairo needs is the xlib_libX11 library. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xserver_xorg-server: provide more options for SHA1 libraryGravatar Thomas Petazzoni2013-01-122-2/+15
| | | | | | | | | | | | | | | | | Until now, the X.org server was forcefully selecting OpenSSL, just to have a SHA1 implementation. However, in fact, the X.org server is capable of using a SHA1 implementation from multiple libraries: OpenSSL, libgcrypt and libsha1 amongst others. So, this patch changes the X.org server package so that we use the SHA1 functions from OpenSSL is OpenSSL is already available, or the SHA1 functions from libgcrypt is libgcrypt is already available, or if neither OpenSSL nor libgcrypt are enabled in the configuration, we select the much smaller libsha1, that has been specifically written to fulfill the X.org server requirements. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libsha1: new packageGravatar Thomas Petazzoni2013-01-123-0/+25
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xlib_libX11: split the DEPENDENCIES variable on multiple linesGravatar Thomas Petazzoni2013-01-121-1/+13
| | | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xlib_libX11: do not depend on bigreqsproto nor xcmiscprotoGravatar Thomas Petazzoni2013-01-122-3/+1
| | | | | | | | | | | | | | | The BR2_PACKAGE_XPROTO_BIGREQSPROTO option was selected by xlib_libX11, but xlib_libX11 does not have this protocol package in its DEPENDENCIES. In some builds, it leads to xproto_bigreqsproto to be built as the last package, with no other package depending on it, which doesn't make sense. xproto_xcmiscproto was selected and part of DEPENDENCIES, but an inspection of libX11 configure.ac and libX11 source code shows that it does not depend on xcmiscproto at all. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* x11r7: do not globally select librariesGravatar Thomas Petazzoni2013-01-121-4/+0
| | | | | | | | | | | | | | It doesn't make sense for BR2_PACKAGE_XORG7 to globally select libraries such as libpng, zlib, expat or fontconfig. For example, if you do a build with just xlib_libX11, then libpng gets built as the last package, without anybody actually depending on it, even if it was selected by BR2_PACKAGE_XORG7. The individual x11r7 packages should select the libraries they need, and add them in their DEPENDENCIES variable. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xserver_xorg-server: add more explanations about the two variantsGravatar Thomas Petazzoni2013-01-121-1/+12
| | | | | | | [Peter: adjust help text according to Arnout's comments] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* toolchain/crosstool-ng: be more explicit in the config file helpGravatar Yann E. MORIN2013-01-121-4/+6
| | | | | | | | | | | | | Some users seem to interpret: make ctng-menuconfig as being a value that can be fit for the ct-ng config file. Clarify that it is a command to run, not a possible value. Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libnl: bump to version 3.2.18Gravatar Gustavo Zacarias2013-01-121-1/+2
| | | | | | | | Bump to version 3.2.18, fixing: http://autobuild.buildroot.org/results/28f23910e2c2090e6f37e8d6a26cdb5adf9615c2 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qemu: bump to version 1.3.0Gravatar Francois Perrad2013-01-121-2/+2
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* python3: uses fork(), only available on MMU platformsGravatar Maxime Ripard2013-01-121-0/+2
| | | | | Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* hiawatha: bump to version 8.7Gravatar Gustavo Zacarias2013-01-121-1/+1
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* arptables: bump to version 0.0.4Gravatar Gustavo Zacarias2013-01-121-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* empty: needs MMUGravatar Simon Dawson2013-01-121-0/+1
| | | | | | | | | | | The empty package uses the fork() system call, and so requires MMU. Fixed autobuilder failures such as the following. http://autobuild.buildroot.net/results/4ad23e07b1bfe7bfd622aed8d54fa243b72eed59/build-end.log Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libelementary: depends on libethumbGravatar Arnout Vandecappelle (Essensium/Mind)2013-01-121-0/+7
| | | | | | | | | | This was exposed because I still had an old libethumb in my staging directory so it was detected by configure, but because of the missing dependency it was still the (incompatible) version from before the 1.7.4 bump. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* website: Announce the upcoming Buildroot Developers MeetingGravatar Thomas Petazzoni2013-01-121-0/+18
| | | | | | [Peter: fix typo] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* package/dvb-apps: requires iconvGravatar Yann E. MORIN2013-01-122-1/+10
| | | | | | | | | | | Use libiconv if the toolchain does not have locales. Fixes (for example): http://autobuild.buildroot.net/results/c5776c95ac128f7c7eadc2fe746ad89f8c1ef49a [Peter: fixup LDFLAGS for BR2_ENABLE_LOCALE=y builds] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* linux: bump 3.7.x stable versionGravatar Gustavo Zacarias2013-01-121-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* kernel-headers: bump 3.{0, 4, 7}.x stable versionsGravatar Gustavo Zacarias2013-01-122-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>