aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* libnftnl: add patch to fix libnftnl.pc for static linkingGravatar Thomas Petazzoni2014-12-301-0/+49
| | | | | | | | | | | | | This commit adds a patch to libnftnl to add the Libs.private field in the pkg-config file, which is needed for proper static linking of applications using libnftnl. Fixes the build of programs such as nftables on Blackfin: http://autobuild.buildroot.org/results/061/06166344cc8e162d3f901c70ee31ce07e481053e/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libnftnl: rename patch to new convention, use Git formatted patchGravatar Thomas Petazzoni2014-12-301-106/+151
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* imagemagick: bump to version 6.9.0-2Gravatar Jerzy Grzegorek2014-12-302-2/+2
| | | | | | [Peter: use correct sha256sum] Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mke2img: always create sparse filesGravatar Yann E. MORIN2014-12-291-1/+1
| | | | | | | | | | | | | | | | | | | | | | | When the user specifies a number of blocks (and we do not auto-compute them), the generated filesystem can be quite large with large zones with only zeroes in them. Thus, always create the filesystem as a sparse file. Sparse files behave the same as normal files, except those long runs of zeroes do not actually use space on the (host) filesystem. Also, this should not break current behaviour, as neither cp nor dd nor cat preserve sparseness by default. So users relying on the zeroed parts to actually be written won;t see a change. Users that were expressly using cp or dd to copy files to a sparse destination will however see a little bit of improvements, as the zeroed out parts won't even be read from disk. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Tested-by: Karoly Kasza <kaszak@gmail.com> Reviewed-by: Karoly Kasza <kaszak@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* freerdp: pass appropriate ARM ABI flagsGravatar Thomas Petazzoni2014-12-291-0/+4
| | | | | | | | | | | | | | | | | In the line of commit 530693787b3 ("package/freerdp: do not use Neon extensions when not available") done by Yann E. Morin, freerdp also passes an explicit -mfloat-abi= flag, and defaults to softfp. This obviously breaks badly when building an EABIhf system. This commit therefore fixes freerdp.mk to pass the appropriate ARM_FP_ABI value to freerdp's build system. Fixes: http://autobuild.buildroot.org/results/6ca/6ca9de1a11c675533baa68f7a6bf7b6af7cb4345/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gdb: bump to 7.8.1Gravatar Thomas Petazzoni2014-12-292-2/+4
| | | | | | | | This commit bumps to 7.8.1, and updates the logic to use .tar.xz tarballs so that it applies to all 7.8.x versions. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* busybox: bump to version 1.23.0Gravatar Gustavo Zacarias2014-12-2911-187/+73
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* chrony: bump versionGravatar Peter Korsgaard2014-12-292-1/+4
| | | | | | And add hash file. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gst1-libav: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gst1-plugins-ugly: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gst1-plugins-bad: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gst1-plugins-good: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gst1-plugins-base: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gstreamer1: bump versionGravatar Peter Korsgaard2014-12-292-3/+3
| | | | Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* toolchain-external: add hashes for Blackfin toolchainsGravatar Thomas Petazzoni2014-12-281-0/+9
| | | | | | | | | | | | | | | | Those toolchains are downloaded from Sourceforge, and are therefore affected by the Sourcefoge download issues. Therefore, this commit adds the hashes for those toolchain tarballs. Fixes: http://autobuild.buildroot.org/results/fa5/fa5e38246dddd661f1d674f3521d21297796bce3/ (and other similar issues) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: add hashes for SourceForge-hosted packagesGravatar Yann E. MORIN2014-12-28141-0/+283
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Since SourceForge sometimes serves us faulty tarballs, we can tons of autobuild failures: http://autobuild.buildroot.org/results/9fb/9fba5bf086a4e7a29e5f7156ec43847db7aacfc4/ http://autobuild.buildroot.org/results/6c8/6c837b244c45ac3b3a887734a371cd6d226cf216/ ... Fix that by adding hash files for all SourceForge-hosted packages (thos etht did not already have it). We normally prefer to use hashes published by upstream, but hunting them all one by one is a tedious task, so those hashes were all locally computed with a script that searched for SF-hosted packages, downloades the associated tarball, computed the hash, and stored it in the corresponding .hash file. Also, SF publishes sha1 hashes, while I used the stronger sha256, since sha1 is now considered to be relatively weak. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Cc: Richard Braun <rbraun@sceen.net> Cc: Nathaniel Roach <nroach44@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/lm-sensors: disable static library for shared-only buildGravatar Romain Naour2014-12-281-0/+6
| | | | | Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi: fix leftover instance of 'xbmc'Gravatar Yann E. MORIN2014-12-282-10/+12
| | | | | | | | | | | | During the XBMC -> Kodi rename, some instance of 'xbmc' were left out, which meant our startup script would not run Kodi, and that Kodi would create its /.kodi directory. This patch renames the missing bits. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* configs/qemu: update to the latest kernel/headers versionsGravatar Gustavo Zacarias2014-12-2820-39/+39
| | | | | | | | Used to test the new default binutils 2.24 (all passed). Also update the virtex readme since the dtb is in output/images as well. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* whois: bump to version 5.2.3Gravatar Gustavo Zacarias2014-12-282-4/+4
| | | | | | | With support for new gTLDs and updated TLDs. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* dillo: bump to version 3.0.4.1Gravatar Gustavo Zacarias2014-12-283-3/+4
| | | | | | | Also add hash file. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* links: bump to version 2.8Gravatar Gustavo Zacarias2014-12-285-40/+29
| | | | | | | Also add hash file. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/mke2img: do not overshoot user-specified sizeGravatar Yann E. MORIN2014-12-281-4/+6
| | | | | | | | | | | | | | | | | | Currently, we forcibly expand the generated filesystem by 1300 blocks (i.e. a bit more than 1MiB) when we need to generate an ext3 or ext4 filesystem, even if the user already supplied us with the size it wants the filesystem to be. In that case, we overshoot what the user requested, which is bad because the filesystem may no longer fit in the partition it is supposed to be written into. Only add extra blocks when we do compute the required size, not when the user specifies the size. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* sdparm: bump to version 1.09Gravatar Gustavo Zacarias2014-12-282-2/+10
| | | | | | | | Also add hash file. And make the libsgutils2 support (from sg3_utils) deterministic. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* binutils: default to 2.24Gravatar Peter Korsgaard2014-12-281-2/+1
| | | | | | | | 2.22 is getting quite old (Nov 2011) and we've recently added 2.25. 2.24 has been used for the "new" architectures for a while and there's no known issues going to 2.24 for the rest, so bump the default version. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* iproute2: bump to version 3.18.0Gravatar Gustavo Zacarias2014-12-284-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/tmux: remove unsafe headers pathGravatar Romain Naour2014-12-272-0/+38
| | | | | Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/lftp: don't use host's pathGravatar Romain Naour2014-12-271-0/+46
| | | | | | | | | | | lftp try to link with -L/usr/lib/lftp/$(LFTP_VERSION) if DESTDIR is not set. Remove useless -L option which point to a location where no libraries are installed. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libdrm: fix support for xserver with Vivante driversGravatar Jérôme Pouiller2014-12-271-0/+37
| | | | | | | [Thomas: fix minor typo in patch description.] Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* gpu-viv-bin-mx6q: fix GLESv2 supportGravatar Jérôme Pouiller2014-12-271-3/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Tested with: QMX6 board + BR2_TOOLCHAIN_EXTERNAL=y BR2_TARGET_GENERIC_GETTY_PORT="ttymxc1" BR2_LINUX_KERNEL=y BR2_LINUX_KERNEL_CUSTOM_GIT=y BR2_LINUX_KERNEL_CUSTOM_REPO_URL="https://git.congatec.com/arm/qmx6_kernel.git" BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="9bafbcba67f7bb2a48a5e05998cecb1165aa444f" BR2_LINUX_KERNEL_DEFCONFIG="qmx6" BR2_LINUX_KERNEL_APPENDED_UIMAGE=y BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x10008000" BR2_LINUX_KERNEL_INTREE_DTS_NAME="imx6q-qmx6" BR2_PACKAGE_QT5=y BR2_PACKAGE_QT5BASE_LICENSE_APPROVED=y BR2_PACKAGE_QT5BASE_EXAMPLES=y BR2_PACKAGE_QT5BASE_OPENGL_LIB=y BR2_PACKAGE_QT5BASE_EGLFS=y BR2_PACKAGE_QT5BASE_DEFAULT_QPA="eglfs" BR2_PACKAGE_QT5BASE_GIF=y BR2_PACKAGE_QT5BASE_JPEG=y BR2_PACKAGE_QT5BASE_PNG=y BR2_PACKAGE_QT5QUICKCONTROLS=y BR2_PACKAGE_FREESCALE_IMX=y BR2_PACKAGE_FREESCALE_IMX_PLATFORM_IMX6Q=y BR2_PACKAGE_GPU_VIV_BIN_MX6Q=y BR2_PACKAGE_GPU_VIV_BIN_MX6Q_EXAMPLES=y Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libvncserver: add config option for tightpng encoding supportGravatar Floris Bos2014-12-272-0/+20
| | | | | | | | | | | TightPNG encoding speeds up HTML5 based VNC clients like noVNC. libvncserver enables this encoding if both libpng and jpeg libraries are available. [Thomas: rewrap Config.in help text.] Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* gpu-viv-bin-mx6q: use self-extractible helperGravatar Jérôme Pouiller2014-12-271-13/+2
| | | | | Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/freerdp: do not use SSE2 extensions when not availableGravatar Yann E. MORIN2014-12-271-0/+6
| | | | | | | | | | | | | | | Do not let FreeRDP decide whether it can use SE2 opcodes, it may well fail to do so, because the heuristic is not working for cross-compilation. Also, we do have a Kconfig option stating whether we have SSE2 or not, so reuse that. Similar to the recent ARM+Neon fix. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/freerdp: do not use Neon extensions when not availableGravatar Yann E. MORIN2014-12-271-0/+6
| | | | | | | | | | | | | | | | | | | | | | FreeRDP mis-detects the CPU, and may enable Neon extensions when it should not. Not all ARM processors have Neon extensions. Heck, what's more, none non-ARM processor has Neon extensions! The regexp to detect the CPU is borked: 'arm*' will also match 'arc' as well as 'arm'. Do not let FreeRDP try to decide if it can use Neon extensions, we have a Kconfig option for that, that we can use to force FreeRDP to use it or not. Should fix: http://autobuild.buildroot.org/results/d4a/d4a61e686cf11d993d02ece0c4e2835a926603c2/ http://autobuild.buildroot.org/results/234/2349d40ef8d658ab1cd7332eb1b42a75afcd423f/ ... Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/ffmpeg: update hashGravatar Yann E. MORIN2014-12-271-1/+1
| | | | | | | | Last bump (dd3a2d6) forgot to update the hash for the new version. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/ffmpeg: Add Kodi patchsetGravatar Thomas Petazzoni2014-12-2713-0/+695
| | | | | | | | | | | | | | | In the past xbmc delivered its own ffmpeg source code with specific patches to address bugs found during the use of xbmc. For Helix the ffmpeg source code was removed, Helix uses a vanilla ffmpeg source tarball and applies this patchset on top of it. Downloaded from https://github.com/xbmc/FFmpeg/compare/FFmpeg:release/2.5...release/2.5-xbmc.patch [Thomas: use individual patches instead.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-audioencoder-wav: New packageGravatar Bernd Kuhls2014-12-273-0/+22
| | | | | | | | | [Thomas: removed dependency on BR2_PACKAGE_KODI_OPTICALDRIVE from the package Config.in, since it is already only included if BR2_PACKAGE_KODI_OPTICALDRIVE is enabled.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-audioencoder-vorbis: New packageGravatar Bernd Kuhls2014-12-273-0/+27
| | | | | | | | | [Thomas: removed dependency on BR2_PACKAGE_KODI_OPTICALDRIVE from the package Config.in, since it is already only included if BR2_PACKAGE_KODI_OPTICALDRIVE is enabled.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-audioencoder-lame: New packageGravatar Bernd Kuhls2014-12-273-0/+24
| | | | | | | | | [Thomas: removed dependency on BR2_PACKAGE_KODI_OPTICALDRIVE from the package Config.in, since it is already only included if BR2_PACKAGE_KODI_OPTICALDRIVE is enabled.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-audioencoder-flac: New packageGravatar Bernd Kuhls2014-12-273-1/+34
| | | | | | | | | [Thomas: removed dependency on BR2_PACKAGE_KODI_OPTICALDRIVE from the package Config.in, since it is already only included if BR2_PACKAGE_KODI_OPTICALDRIVE is enabled.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi: Enable install to STAGING_DIR, needed for audioencoder addonsGravatar Bernd Kuhls2014-12-271-0/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi: New option to enable support for optical drivesGravatar Bernd Kuhls2014-12-272-1/+11
| | | | | | | This also enables dvdcss support, provided by an internal library. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-addon-xvdr: Bump version for Helix-compatibilityGravatar Bernd Kuhls2014-12-272-2/+21
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/xbmc-addon-xvdr: rename to kodi-addon-xvdrGravatar Bernd Kuhls2014-12-274-15/+22
| | | | | | | | | Following the rename of the XBMC project to Kodi, this commit renames the xbmc-addon-xvdr package to kodi-addon-xvdr, and adds the appropriate Config.in.legacy handling. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-addons: Bump version for Helix-compatibilityGravatar Bernd Kuhls2014-12-271-11/+4
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/xbmc-pvr-addons: rename to 'kodi-pvr-addons'Gravatar Bernd Kuhls2014-12-276-41/+48
| | | | | | | | | Following the rename of the XBMC project to Kodi, this commit renames the xbmc-pvr-addons package to kodi-pvr-addons, and adds the appropriate Config.in.legacy handling. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi: Bump version to 14.0-HelixGravatar Bernd Kuhls2014-12-274-281/+8
| | | | | | | | | | - delete 0002-mathutil.patch, committed upstream - delete 0003-dbus.patch, committed upstream - add dependency to ffmpeg, xbmc does not deliver its own ffmpeg anymore - remove dependency to flac & lame, audio encoders have been seperated from kodi Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/xbmc: rename to 'kodi', the new upstream project nameGravatar Bernd Kuhls2014-12-2713-330/+450
| | | | | | | | | | | | | Background information: http://xbmc.org/introducing-kodi-14. In a first step to bump version to 14.0-Helix, we move the xbmc package to a new directory called kodi. Appropriate Config.in.legacy variables are added. [Thomas: rename patches to the new convention.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libvncserver: disable libva supportGravatar Floris Bos2014-12-271-0/+4
| | | | | | | | | | | | | | | | | | | | | The libvncclient library (part of libvncserver) has optional support for HW accelerated H264 video playback using libva However there are currently two problems with it: 1) it only supports libva compiled with X11 support enabled, but it does not verify that is the case, resulting in compile errors. 2) it only supports the libva 1.0.x API, and not newer libva versions, like 1.4.x we include with buildroot. https://github.com/LibVNC/libvncserver/issues/11 Disabling libva support for now. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* xerces: make sure to use the cross-compiled curlGravatar Thomas Petazzoni2014-12-271-1/+1
| | | | | | | | | | | | | | | | | | When curl support is enabled in xerces, and a host curl is available on the system, it might try to use it, so this patch adds --with-curl= to the configure options to explicitly indicate where is the curl library to use. Should fix: http://autobuild.buildroot.org/results/c3c/c3c6be45d0f764fb931a46dbf1509ccf2916ecbf/ (We were not able to reproduce specifically this problem, but another similar problem, where curl was detected, but considered as non-working because of the compilation failure of a test program.) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>