aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Makefile: exclude BR2_DL_DIR from savedefconfigHEADmasterGravatar Sven Oliver Moll20 hours1-1/+3
| | | | | | | | | Running "make savedefconfig" with BR2_DL_DIR set also saves that variable, which is only useful in local context. Signed-off-by: Sven Oliver Moll <buildroot@svol.li> [yann.morin.1998@free.fr: wrap line] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/libqrencode: bump to version 4.1.1Gravatar Fabrice Fontaine21 hours2-4/+4
| | | | | | | | | Update indentation in hash file (two spaces) https://fukuchi.org/works/qrencode/#news Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/binutils: build host binutils w/o debuginfodGravatar Alexander Egorenkov3 days1-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Since version 2.34 binutils enables debuginfod support by default if the debuginfod library is found to be available at build time. On Fedora 32, libdebuginfod may be present on the system, and the dependency chain of interest is then: libdebuginfod.so -> libcurl.so -> libk5crypto.so -> libcrypto.so If the Buildroot configuration ever needs to build host-openssl, which may happen when building the kernel to sign modules for example, this leads to an inconsistency between the system-provided libcrypto and ours, leading to missing symbols: $ make defconfig $ make host-binutils $ ./output/host/bin/i686-buildroot-linux-uclibc-objdump --help [--snip some help text--] $ make host-openssl $ ./output/host/bin/i686-buildroot-linux-uclibc-objdump --help ./output/host/bin/i686-buildroot-linux-uclibc-objdump: symbol lookup error: /lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b EVP_KDF_ctrl comes from libcrypto: $ nm -D /usr/lib64/libcrypto.so.1.1 |grep EVP_KDF_ctrl 0000000000176000 T EVP_KDF_ctrl $ nm -D output/host/lib/libcrypto.so.1.1 |grep EVP_KDF_ctrl [--empty--] So, if host-binutils tools, like objdump et al., are called after our host-openssl is built, then when run, the system-provided libk5crypto.so is used, but our libcrypto.so is used, because of the RPATH we set on our host tools. And boom. Note that there is also a latent similar issue if we were to build our host-libcurl too... Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com> [yann.morin.1998@free.fr: rewrite commit log with a bit more info] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* configs/qemu_s390x_defconfig: use linux headers same as kernel series 5.8Gravatar Alexander Egorenkov3 days1-0/+3
| | | | | | | Broke since introduction of linux kernel series 5.9. Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/gstreamer1/gstreamer1-editing-services: fix static buildGravatar Fabrice Fontaine4 days1-0/+74
| | | | | | | | | | | Fix static build with gstreamer1-editing-services in version 1.17.1 and above Fixes: - http://autobuild.buildroot.org/results/2a528a1185644f5b23d26eb3f2b342e99aa1e493 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/opencv3: fix typo in OPENCV_WARNINGS_ARE_ERRORSGravatar Fabrice Fontaine4 days1-1/+1
| | | | | | | | OPENCV3_WARNINGS_ARE_ERRORS option does not exist so rename it to OPENCV_WARNINGS_ARE_ERRORS (even if it is already disabled by default) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/opencv3: add webp supportGravatar Fabrice Fontaine4 days2-1/+15
| | | | | | | | webp support is available since version 3.0.0 and https://github.com/opencv/opencv/commit/500b7318beee639d8c341e9ea63ac7610ca225f4 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/libapparmor: fix build with muslGravatar Fabrice Fontaine4 days1-0/+33
| | | | | | | | | | Fix build of apparmor 3.0.0 with musl Fixes: - http://autobuild.buildroot.org/results/ccbee89030308cf1e4bfce89635d40676c7c63a0 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/transmission: fix build with UTPGravatar Fabrice Fontaine4 days1-11/+11
| | | | | | | | | | | | | | | | | | | | | Update first patch to fix build of transmission 3.00 with UTP. Since upstream commit f27596238d37 (Include stdbool.h unconditionally), upstream no longer ever defines HAVE_STDBOOL_H, so we always fallback to manually defining 'bool' which conflicts with the type used elsewhere in the code. Drop our workaround, to always include stdbool.h unconditionally. Fixes: - http://autobuild.buildroot.org/results/bbfb61cf911fb29dcc02626f6eb47fff9e5e64f5 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: - expand commit log - drop commented-out code - restore CR-LF line endings in replacement code, as used by upstream ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/mksh: fix legal-infoGravatar Fabrice Fontaine4 days1-1/+1
| | | | | | | | | | | | | | | | Commit b6b5981f704f (package/mksh: update to R59b) forgot to update the hash of mksh.1 which is used as the license file. Although the manpage has changed to accomodate changes in mksh, the licensing blurb has not changed. Fixes: - http://autobuild.buildroot.org/results/1291917e4b17e087455a6698c4b82e4ff783600d Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: - expand commit log to state the license has not changed ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/freeswitch: add opencv3 optional dependencyGravatar Fabrice Fontaine4 days3-0/+52
| | | | | | | | opencv3 is an optional dependency since version 1.8.1 and https://github.com/signalwire/freeswitch/commit/6483ab8b65886465863584e8dcfee57084030b9c Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/pistache: fix static buildGravatar Fabrice Fontaine4 days1-0/+95
| | | | | | | | | | | | | | | | | Don't build shared library with BR2_SHARED_LIBS=OFF to avoid the following build failure: [100%] Linking CXX shared library libpistache.so make[3]: Leaving directory `/home/buildroot/autobuild/run/instance-1/output-1/build/pistache-f2f5a50fbfb5b8ef6cf1d3d2a9d442a8270e375d' [100%] Built target pistache_static /home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/x86_64-buildroot-linux-musl/8.3.0/../../../../x86_64-buildroot-linux-musl/bin/ld: /home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/x86_64-buildroot-linux-musl/8.3.0/crtbeginT.o: relocation R_X86_64_32 against hidden symbol `__TMC_END__' can not be used when making a shared object Fixes: - http://autobuild.buildroot.org/results/6cc/6cc76b3e76defa9b8154568a6ebcd6bf4cadd334/build-end.log Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: update upstream status now they merged it] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/transmission: drop second patchGravatar Fabrice Fontaine5 days2-36/+0
| | | | | | | | | transmission in version 3.00 is building fine on musl and upstream thinks that this patch is not needed anymore: https://github.com/transmission/transmission/pull/1156 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/netsnmp: silence warning when running without IPv6Gravatar Peter Korsgaard5 days1-0/+30
| | | | | | | | | | | | | | | | snmpd loudly complains every 3 seconds about a failure reading /proc/net/if_inet6 if the system does not have IPv6 support: Jan 1 00:00:12 buildroot daemon.err snmpd[92]: ipaddress_linux: could not open /proc/net/if_inet6: No such file or directory Jan 1 00:00:15 buildroot daemon.err snmpd[92]: ipaddress_linux: could not open /proc/net/if_inet6: No such file or directory Jan 1 00:00:18 buildroot daemon.err snmpd[92]: ipaddress_linux: could not open /proc/net/if_inet6: No such file or directory Jan 1 00:00:21 buildroot daemon.err snmpd[92]: ipaddress_linux: could not open /proc/net/if_inet6: No such file or directory Add an upstream patch to only print this warning once, rather than on every poll iteration. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/opencv3: link with libatomic if neededGravatar Fabrice Fontaine5 days1-0/+5
| | | | | | | | | | | | Restore the atomic workaround that was wrongly removed when bumping to version 3.4.9 in commit f6fb2cae0691d25b034b12a16261ee26096db7d1 as it seems that opencv3 still needs help to detect atomic library Fixes: - http://autobuild.buildroot.org/results/9162b29725f8d9b891eb74fcb8078f211140a841 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/kismet: link with libatomic if neededGravatar Fabrice Fontaine5 days1-0/+4
| | | | | | | | | | Fix build of kismet-2020-09-R3 with riscv64 Fixes: - http://autobuild.buildroot.org/results/9c3d56ef837c7c5bfbb34a0ec51b349108e201b1 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/linux-firmware: add rpi settings filesGravatar Frank Hunleth5 days1-1/+4
| | | | | | | | | | | | | The brcmfmac drivers now load settings files for BCM434xx devices and fail if they're missing on the Raspberry Pi: brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2 This commit copies the missing settings files over to the firmware directory with the other files. Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/gstreamer1/gst1-libav: fix licenseGravatar Fabrice Fontaine5 days2-2/+2
| | | | | | | | | | | | | | | | Commit 15dc48ca9becafec6ba11b08af18453bc0e40c9e forgot to change the license which is LGPL-2.0+ since version 1.17.1 and https://gitlab.freedesktop.org/gstreamer/gst-libav/-/commit/c437e175ad9c82732ac46e36ccc398ad041bf13b It should be noted that even if the commit states LGPL-2.1+, the license is LGPL-2.0+: https://gitlab.freedesktop.org/gstreamer/gst-libav/-/issues/83 Fixes: - http://autobuild.buildroot.org/results/848d7c49a01f719397cb2e8a8f8e3bd73bd03df4 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/opencv3: bump to version 3.4.12Gravatar Fabrice Fontaine5 days4-93/+3
| | | | | | | | | | | | - Drop patches (already in version) - Update LICENSE hash, update in year: https://github.com/opencv/opencv/commit/039f5ca42e32dd11605d81e909c3bdad16c4cdbc - Update indentation in hash file (two spaces) https://github.com/opencv/opencv/wiki/ChangeLog#version3412 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/python-pyqt5: QtSvg needs QtWidgetsGravatar Fabrice Fontaine5 days1-5/+6
| | | | | | | | | | | | | | | | Building QtSvg without QtWidgets results in the following build failure: /tmp/instance-0/output-1/host/bin/powerpc64le-linux-g++ -c -pipe -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os --sysroot=/tmp/instance-0/output-1/host/powerpc64le-buildroot-linux-gnu/sysroot -fno-exceptions -Wall -Wextra -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SVG_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -I. -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/python3.8 -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5 -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtSvg -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtGui -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtCore -I. -I../../../host/mkspecs/devices/linux-buildroot-g++ -o sipQtSvgcmodule.o sipQtSvgcmodule.cpp sip/QtWidgets/qwidget.sip:28:10: fatal error: qwidget.h: No such file or directory compilation terminated. sip/QtWidgets/qgraphicsitem.sip:26:10: fatal error: qgraphicsitem.h: No such file or directory compilation terminated. Fixes: - http://autobuild.buildroot.org/results/26f55a1fa9f6520ce449b98b40d98f984cec07b3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/python-argon2-cffi: use system libargon2Gravatar James Hilliard5 days2-3/+7
| | | | | | | | The python-argon2-cffi package can be used with the system libargon2, we should use that instead of the embedded version. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/samba4: fix uclibc build with openldapGravatar Fabrice Fontaine5 days1-0/+40
| | | | | | | | Fixes: - http://autobuild.buildroot.org/results/09e84d15efe755bdefa9f8c6b8355c49ddbc2f65 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* support/scripts/apply-patches.sh: manage uncompressionGravatar Fabrice Fontaine5 days1-2/+2
| | | | | | | | | | | | | | | Extract from bug report: "Code line 120 to line 128 is to check whether the patch containing "rename from" and "rename to". But it directly use grep to find, ignoring the patch may be a tar file or else. It can only work on patch of textfile form." Fixes: - https://bugs.buildroot.org/show_bug.cgi?id=11931 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mpdecimal: add optional C++ dependencyGravatar Fabrice Fontaine5 days2-0/+52
| | | | | | | | | | | | | Version 2.5.0 enables the new libmpdec++ library by default: http://www.bytereef.org/mpdecimal/changelog.html#version-2-5-0 Adapt the existing patch, to allow static build of this C++ library. Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: - meld the C++-enabling and the static-patch commits into one ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/linux-firmware: add options for Broadcom BCM4366Gravatar Rafał Miłecki5 days2-0/+24
| | | | | | | | | There are two groups of chipsets in the BCM4366 family requiring two different firmware files. Each is quite big (over 1 MiB) so use separated options for them. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/transmission: bump version to 3.00Gravatar Bernd Kuhls5 days4-165/+3
| | | | | | | | | | Removed patched applied upstream, reformatted hashes. Updated license hash due to copyright update to 2020: https://github.com/transmission/transmission/commit/2d940e5cafe01a6ea9285b7d39ccada6e90afab1 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/zxing-cpp: add opencv3 optional dependencyGravatar Fabrice Fontaine5 days1-0/+3
| | | | | | Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: split to a separate condition] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/gstreamer1/gst1-devtools: install to stagingGravatar Fabrice Fontaine5 days1-0/+1
| | | | | | | | | | | | | | | | | This will fix the following build failure with gstreamer1-editing-services which optionally depends on gst1-devtools since commit 08a213c1a532de783a7cedaa29088ffb736827bd: Run-time dependency gst-validate-1.0 found: NO (tried pkgconfig and cmake) Looking for a fallback subproject for the dependency gst-validate-1.0 ../output-1/build/gstreamer1-editing-services-1.18.0/meson.build:101:0: ERROR: Subproject directory not found and gst-devtools.wrap file not found Fixes: - http://autobuild.buildroot.org/results/e9d96a63861737d82734559db5e5ffbf5996ffde Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/kernel-module-imx-gpu-viv: fix disabling kernel optionGravatar Yann E. MORIN5 days1-1/+1
| | | | | | | | | | | | Commit 391c448acbb9 (package/kernel-module-imx-gpu-viv: bear the kernel options munging) improperly named the macro, including a superfluous 'MODULE' in the middle of the macro name, which meant it was totally unused. Fix that. Reported-by: Heiko Thiery <heiko.thiery@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/libcroco: drop packageGravatar Fabrice Fontaine6 days5-47/+8
| | | | | | | | | | Drop libcrococo as it is affected by several security issues such as CVE-2020-12825 which will never be fixed as this project has been archived: https://gitlab.gnome.org/Archive/libcroco/-/issues/8 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mksh: update to R59bGravatar Waldemar Brodkorb6 days2-2/+2
| | | | | Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/uclibc-ng-test: update to latest git versionGravatar Waldemar Brodkorb6 days5-179/+1
| | | | | | | All patches are upstream. Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mpdecimal: bump to version 2.5.0Gravatar James Hilliard6 days3-4/+4
| | | | | | | | | | | | | | | Update license hash due to date update. Tweak patch so that it applies still. This update is needed following the bump of python3 to 3.9.0 in commit f26ce577605e843ebf0f5583242ee9ff3cd08ac3. Fixes: http://autobuild.buildroot.net/results/b73/b7384312567825e6f4ddbd7c08c1b8e44c7f1f9b Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* DEVELOPERS: add mksh/ruby to Waldemar BrodkorbGravatar Waldemar Brodkorb7 days1-0/+2
| | | | | Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mongrel2: bump to version 1.12.2Gravatar Fabrice Fontaine7 days7-83/+143
| | | | | | | | | | | | - Refresh second patch - Drop third patch (already in version) - An external mbedtls can be used since version 1.12.0 and https://github.com/mongrel2/mongrel2/commit/5be7fc9c90fd5c8caa233770b7e2cdff67b4bae2 so use it with an upstream patch and drop MONGREL2_POST_CONFIGURE_HOOKS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mrp: add init script and systemd unit fileGravatar Horatiu Vultur7 days3-0/+75
| | | | | | | Add init script and systemd unit for MRP because it is using a daemon. Signed-off-by: Horatiu Vultur <horatiu.vultur@microchip.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/ipcalc: new packageGravatar Derrick Lyndon Pallas7 days8-0/+111
| | | | | | | | | | | ipcalc is an ancient and venerable tool for manipulating IP addresses, networks, & interfaces from shell scripts. There is a subtool in busybox, but it does not support everything the upstream tool [1] supports. [1] https://gitlab.com/ipcalc/ipcalc Signed-off-by: Derrick Lyndon Pallas <derrick@meter.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst1-libav: bump version to 1.18.0 and convert to mesonGravatar Peter Seiderer7 days3-35/+8
| | | | | | | | | | | | | | | | - change home page url to https - convert to meson build - drop all libav extra options as the internal libav is gone since commit [1] - meson options: add doc=disabled [1] https://gitlab.freedesktop.org/gstreamer/gst-libav/-/commit/ca478e7546c059574e0f134125deb38c8cbc9111 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/bellagio: drop packageGravatar Peter Seiderer7 days11-220/+7
| | | | | | | | | | Drop bellagio support as the project is no longer maintained (no update since 2011, see [1]) and the last reference (from gst-omx) is gone. [1] http://omxil.sourceforge.net Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst-omx: bump version to 1.18.0 and convert to mesonGravatar Peter Seiderer7 days3-21/+14
| | | | | | | | | | | | - change home page url to https - drop bellagio support (as the project is no longer maintained no update since 2011, see [1]) [1] http://omxil.sourceforge.net Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gstreamer1-editing-services: bump version to 1.18.0 and convert to mesonGravatar Peter Seiderer7 days3-25/+21
| | | | | | | | | | | | | | | | | | | - change home page url to https - change download url to https - download source renamed from gstreamer-editing-services to gst-editing-services - convert to meson build - use BR2_PACKAGE_GST1_DEVTOOLS/gst1-devtools instead of legacy BR2_PACKAGE_GST1_VALIDATE/gst1-validate - drop examples support Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* board/hardkernel/odruidc2: remove rootfs size limitGravatar Dagg Stompler7 days1-1/+0
| | | | | | | | | As resizing the rootfs partition using a partition manager can result in a non booting image due to the firmware's location, removal of the size limit for the rootfs allows better match size-wise. Signed-off-by: Dagg Stompler <daggs@gmx.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/dvb-apps: fix build failure with glibc 2.31Gravatar Dagg Stompler7 days1-0/+21
| | | | | | | | | | | | | | | | | | | | dvb-apps fails to build with glibc 2.31 with the following error: | dvbdate.c: In function set_time: | dvbdate.c:312:6: warning: implicit declaration of function stime; did you mean ctime? [-Wimplicit-function-declaration] | 312 | if (stime(new_time)) { | | ^~~~~ | | ctime Fixes: http://autobuild.buildroot.net/results/95f30c5e6af2274418bb44a20da7caac69f1dd68/ references: 1. https://gitweb.gentoo.org/repo/gentoo.git/commit/media-tv/linuxtv-dvb-apps/files/linuxtv-dvb-apps-glibc-2.31.patch?id=eb705f892eae45b93306c1de1407c1c22ac23956 2. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=964223 Signed-off-by: Dagg Stompler <daggs@gmx.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/kismet: add python tools supportGravatar Fabrice Fontaine7 days2-1/+38
| | | | | Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/kismet: bump to version 2020-09-R3Gravatar Fabrice Fontaine7 days9-233/+83
| | | | | | | | | | | | | | | | | | - Drop all patches (not needed anymore) - Update help message of Config.in: kismet does not support only WiFi but also Bluetooth, SDR ... - Remove ncurses dependency - libnl is now optional - Drop --with-netlink-version (not available anymore) - Add protobuf, protobuf-c, sqlite and zlib mandatory dependencies - kismet_client and kismet_drone have been dropped since version 2019-04-R1 - Select libmicrohttpd for kismet_server - Add optional libusb and lm-sensors dependencies - Use --{enable,disable}-{libcap,pcre} options - Use the new LICENSE file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libblockdev: fs needs libmountGravatar Fabrice Fontaine7 days2-1/+3
| | | | | | | | Fixes: - http://autobuild.buildroot.org/results/1f83436a84046da753a2ebf2aac7c0f0cc188fe0 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* DEVELOPERS: remove several packages from Adam DuskettGravatar Adam Duskett7 days1-50/+0
| | | | | Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/{mesa3d, mesa3d-headers}: bump version to 20.1.10Gravatar Bernd Kuhls7 days3-5/+5
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/oniguruma: fix CVE-2020-26159Gravatar Fabrice Fontaine7 days2-0/+28
| | | | | | | | | Fix CVE-2020-26159: In Oniguruma 6.9.5_rev1, an attacker able to supply a regular expression for compilation may be able to overflow a buffer by one byte in concat_opt_exact_str in src/regcomp.c. Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/duktape: bump to version 2.6.0Gravatar Fabrice Fontaine7 days2-4/+6
| | | | | | | | - Use official tarball instead of github helper - Update indentation in hash file (two spaces) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>