aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
Commit message (Collapse)AuthorAgeFilesLines
* package/dovecot: Remove bzip2 and zlib optionsGravatar Bernd Kuhls2016-02-161-0/+14
| | | | | | | | | | The next patch of this series will add optional xz and lz4 support, to avoid adding new options for these compression packages simplify the configuration of dovecot by removing the options handling optional compression support. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* e2fsprogs: remove findfs optionGravatar James Knight2016-02-141-0/+9
| | | | | | | | | | | | | | | | | | | | | The e2fsprogs package's findfs option provides no capabilities. When the option is selected, a symbolic link is generated from findfs to e2label; however, e2label will not handle findfs since the respective code is explicitly disabled when `--disable-libblkid` is passed in. At this time, the e2fsprogs package only supports findfs capabilities when building its "private blkid library". Note that the `--disable-libblkid` configuration argument must remain to prevent conflicts with util-linux's libblkid and an e2fsprogs- generated variant (see e1ffc2f791b336339909c90559b7db40b455f172). Since e2fsprogs cannot provide findfs capabilities, the option is being removed in this change. A following change will be introduced to include util-linux's findfs utility. Signed-off-by: James Knight <james.knight@rockwellcollins.com> Cc: Zheng Yi <yzheng@techyauld.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: remove version choiceGravatar Martin Bark2016-02-071-3/+5
| | | | | | | | | | | | | | | Remove the choice of nodejs version. Now automatically pick nodejs 0.10.x for armv5 architectures only and the latest nodejs for all other supported architectures. Note that the removal of BR2_PACKAGE_NODEJS_5_X is not handled in Config.in.legacy because buildroot has never been released with this option included. Signed-off-by: Martin Bark <martin@barkynet.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/openpowerlink: bump to v2.2.2Gravatar Romain Naour2016-02-071-0/+24
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | From [1]: With version 2.0, the source code has been cleanly split into an application-oriented user library and a time-critical stack driver. The latter may be moved to a dedicated communication processor or into a kernel module to deliver enhanced performance while still keeping the API in user space. This new version break the API used in the v1.x but this is a complete rewrite of the Powerlink EPSG DS 301 implementation. The v1.x is deprecated anyway. The new build system has been split in several CMake projects which makes it difficult to package with the Buildroot CMake infra. So add a top level CMakeLists.txt to build each openpowerlink component without having to package each of them in a separate Buildroot packages. Also we need to fix the build system to support the top level CMake build. [1] http://sourceforge.net/projects/openpowerlink/ Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: - rename patches to not contain the [FIX] part in their title. - rewrap Config.in help text - rename "openPOWERLINK stack type" to "stack type" - rename ""openpowerlink demos" to "demos"] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux: drop the option to use the same version as that of the headersGravatar Yann E. MORIN2016-02-061-0/+10
| | | | | | | | | | | | | | It is no longer meaningful, now that we have the option to use the kernel version for the linux headers, as it is more logical and more versatile. Add it to legacy. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/cups: Un-deprecate, and update CUPS to 2.1.2Gravatar Olivier Schonken2016-01-211-0/+7
| | | | | | | | | | | | | | | | | | | | - Remove 0001-fix-static.patch - Fixed upstream - Remove 0002-fix-stack-protector-check.patch - Fixed upstream - Remove 0003-mantohtml.patch - Replaced by 0001-Remove-man-from-BUILDDIRS-in- configure.patch - Add 0002-Do-not-use-genstrings.patch - Add CUPS_PDFTOPS option to Config.in.legacy - This support was moved to the cups-filters package. Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com> [Thomas: - rewrap patch description in patch 0001 - adjust patch 0002 to completely remove the call to genstrings instead of commenting it, and remove the potentially confusing 'echo' above it - add a third patch that sanitizes the installation process to avoid non-working stripping, owernship changes, etc.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux-headers: remove deprecated version 3.16.xGravatar Gustavo Zacarias2016-01-201-0/+10
| | | | | | | | Remove for the upcoming 2016.02 release, it's been deprecated for a year now. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-pyxml: remove obsolete packageGravatar Yegor Yefremov2016-01-011-0/+7
| | | | | | | | | | | PyXML is bitrotten and obsolete. You'll find the functionality it previously provided is now included in the Python standard library. So no need to keep this package in Buildroot anymore. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* toolchain: granular choice for stack protectorGravatar Steven Noonan2015-12-271-0/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, we only support two levels of stach-smashing protection: - entirely disabled, - protect _all_ functions with -fstack-protector-all. -fstack-protector-all tends to be far too aggressive and impacts performance too much to be worth on a real product. Add a choice that allows us to select between different levels of stack-smashing protection: - none - basic (NEW) - strong (NEW) - all The differences are documented in the GCC online documentation: https://gcc.gnu.org/onlinedocs/gcc-4.9.2/gcc/Optimize-Options.html Signed-off-by: Steven Noonan <steven@uplinklabs.net> [yann.morin.1998@free.fr: - rebase - add legacy handling - SSP-strong depends on gcc >= 4.9 - slightly simple ifeq-block in package/Makefile.in - keep the comment in the choice; add a comment shen strong is not available - drop the defaults (only keep the legacy) - update commit log ] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> [Thomas: - only show the choice if the toolchain has SSP support - add details for the BR2_SSP_ALL option that it has a significant performance impact.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: correct 0.10.x option nameGravatar Martin Bark2015-12-251-0/+8
| | | | | | | | The nodejs options incorrectly started BR2_BR2_xxx. This change corrects the name for 0.10.x releases to BR2_PACKAGE_NODEJS_0_10_X Signed-off-by: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: removed version 0.12.9Gravatar Martin Bark2015-12-231-0/+9
| | | | | | | | | Remove 0.12.9 to rationalise the number of nodejs releases supported by buildroot. Going forward buildroot will only support the latest release of nodejs and the 0.10.x branch for armv5 support. Signed-off-by: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/nodejs: bump version to 5.3.0Gravatar Martin Bark2015-12-231-0/+9
| | | | | | | | | | | | | | Replace 4.2.3 with 5.3.0. 5.3.0 is the current Stable release. See https://nodejs.org/en/blog/release/v5.3.0 for details on the release. Copied 4.2.3 patched to 5.3.0 with the following exceptions: - Removed 0004-fix-arm-vfpv2.patch, committed upstream and included in 5.3.0. See https://github.com/nodejs/node/commit/84dea1bd0c - Added 0004-Fix-va_list-not-declared.patch, fix for a new bug. This has already been fixed upstream but is not in 5.3.0 Signed-off-by: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* directfb/legacy: add that it was removedGravatar Gustavo Zacarias2015-12-211-2/+2
| | | | | | | | As pointed by Yann. Signed-off-by: Gustavo Zacarias <gustavo.zacarisa@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl: rename libefl to eflGravatar Romain Naour2015-12-201-10/+10
| | | | | | | | | | | | | This allow to keep backward compatibility with older defconfig files that used BR2_PACKAGE_EFL. Don't add Config.in.legacy entry for libefl since it's not part of any Buildroot release. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/elementary: rename libelementary to elementaryGravatar Romain Naour2015-12-201-0/+8
| | | | | | | | | | | | The upstream name is elementary so use it. Even if this package provide libelementary.so, it also provide elementary_codegen, elementary_run and elm_prefs_cc tools. Add a legacy entry. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* directfb: remove cle266 and unichrome supportGravatar Gustavo Zacarias2015-12-201-0/+16
| | | | | | | | | | | | | | | | | They're broken for the latest version and directfb upstream is gone. cle266 is an old chipset for AMD K7 (32 bit) athlons with integrated graphics - very odd hardware. unichrome is another VIA graphics standalone chip/chipset used for some odd video cards and VIA CPUs (x86-based: C7, Nano and so on). Add options to legacy as well. Fixes: http://autobuild.buildroot.net/results/ab9/ab9a6dd044b5f3e8e42629a2aaf598fd0e0357ed/ Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: document how to handle renaming choice optionsGravatar Arnout Vandecappelle2015-12-191-18/+56
| | | | | | | | | | | | | When a choice option is renamed, it is not possible to select the new option. Instead, the default for the new option should be set in the choice itself. So let's document this. While we're at it, also reformat the whitespace in the example so a tab is used at the appropriate place. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Cc: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libeina: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libeina is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libeet: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libeet is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libevas: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libevas is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libecore: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libecore is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libedbus: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libedbus is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libefreet: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libefreet is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libeio: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libeio is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libembryo: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libembryo is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libedje: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libedje is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/efl/libethumb: remove packageGravatar Romain Naour2015-12-181-0/+7
| | | | | | | | Libethumb is now available in efl package. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* infozip: rename to zipGravatar Luca Ceresoli2015-11-281-0/+12
| | | | | | | | | | | | | | We currently have a package named "infozip" for Info-Zip's Zip. With the upcoming addition of a package the Info-Zip's UnZip the name is becoming ambiguous. Rename it to the more specific name "zip". Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Cc: Romain Naour <romain.naour@openwide.fr> Cc: Jan Pedersen <jp@jp-embedded.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* gst1-plugins-bad: update configure optionsGravatar Peter Seiderer2015-10-211-0/+7
| | | | | | | | | | | | | | | | | | | - add new onvif option - add new dtls option - add new openh264 option - add new x265 option - removed real plugin option - add new rtp option - remove always disabled legacy options: directdraw, osx_video, quicktime and mythtv - add '--disable-bs2b' and '--disable-libde265' to options which require currently unpackaged libraries - add '--disable-gtk3' and '--disable-qt' [Thomas: improve wording of Config.in.legacy option.] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: remove empty lineGravatar Bernd Kuhls2015-10-181-1/+0
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* media-ctl: remove packageGravatar Peter Seiderer2015-10-101-0/+10
| | | | | | | | | Package media-ctl is out-dated, source (and developement) have been moved to v4l-utils since June 2014. Up-to-date version is available in the libv4l package (BR2_PACKAGE_LIBV4L/BR2_PACKAGE_LIBV4L_UTILS). Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: remove incorrect BR2_LEGACY selectsGravatar Thomas Petazzoni2015-10-091-5/+0
| | | | | | We shouldn't select BR2_LEGACY for string options. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: add missing select BR2_LEGACYGravatar Peter Seiderer2015-10-091-0/+40
| | | | | | Signed-off-by: Peter Seiderer <ps.report@gmx.net> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* util-linux: update tool select optionsGravatar Danomi Manchego2015-10-041-0/+13
| | | | | | | | | | | | | | | Add missing app config options: - line - tunelp Drop app config options no longer supported by util-linux: - arch - ddate Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/schifra: remove packageGravatar Romain Naour2015-10-041-0/+6
| | | | | | | Signed-off-by: Romain Naour <romain.naour@openwide.fr> Cc: Arnaud RĂ©billout <rebillout@syscom.ch> Cc: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* zxing-cpp: new package, replacing zxingGravatar Maxime Hadjinlian2015-10-041-0/+8
| | | | | | | | | | | | | | | | | | | | | | | | | ZXing was hosted on Google Code, which is a closing. The current link was already redirecting to the github repo. But upstream is no longer supporting the cpp bindings, it's now a Java library/application. A fork has been created from the latest cpp source of the original upstream. So this commit creates a new package, zxing-cpp, and adds Config.in.legacy handling for the old zxing pakcage that is removed. [Thomas: - add a patch that improves the CMakeLists.txt file to add installation rules. This allows to remove the manual installation logic from zxing-cpp.mk. - make libiconv a normal optional dependency. No need to involve BR2_ENABLE_LOCALE in the condition, since libiconv can only be enabled when !BR2_ENABLE_LOCALE. - bump to the latest upstream version. - add hash file.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/freerdp: prepare for adding another clientGravatar Yann E. MORIN2015-10-031-0/+7
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, the only client we can build is the X11 client. FreeRDP now has support for building a wayland client. However, that means we need to rethink the way we build FreeRDP, because of some "inconsistencies" in its build system. This is because FreeRDP's buildsystem does not have orthogonal options; some of the options can be used for different components. For example, the set of X11 libraries needed to build the server is a superset of the X11 libraries needed to build the X11 client. So, whenever the server is enabled, it means the X11 libraries required to build the X11 client are available. Now, if the user also wants to build the waland client (but not the X11 client), there is no way to tell FreeRDP not to build the X11 client, because there is a single option, WITH_CLIENT, to drive whether any of the clients is built. The decision is made on the availability of the required libraries. And since the server is enabled, the X11 libs required to build the X11 client are available. So, we end up with the X11 client, even though it is not wanted. And conversely with wayland... So, we redesign the way we build FreeRDP. WE do not care what is actually built; we just build whatever is buildable with the current set of enabled libraries. But at install time (both in staging/ and target/) we remove whatever the user does not want. We also take the opportunity to rename the X11 client option, so it is coherent with the soon-to-be-introduced wayland client. Note: since FreeRDP has gained new dependencies, we can not just introduce the legacy option as-is, otherwise we run the risk that it selects the new option even though the new FreeRDP dependencies are not enabled, spitting out the infamous 'unmet direct dependencies" kconfig error. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* kobs-ng: remove obsolete packageGravatar Gary Bisson2015-09-301-0/+8
| | | | | | | In favor of imx-kobs maintained by Freescale. Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* blackbox: remove deprecated packageGravatar Gustavo Zacarias2015-09-131-0/+7
| | | | | | | | | Also update legacy as well. And remove the BR2_DEPRECATED_SINCE_2014_08 symbol since it's unused now. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux-headers: remove deprecated versions 3.{0, 11, 13, 15}Gravatar Gustavo Zacarias2015-09-131-8/+48
| | | | | | | | | | Remove for the upcoming 2015.11 release, they've been deprecated for a year now. Also remove some previously forgotten selection removals in legacy. [Peter: drop 3.0.x kernel patch] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* directfb-examples: remove options for each exampleGravatar Thomas Petazzoni2015-09-101-0/+209
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | For some historical reasons, the directfb-examples package has one sub-option for each example, and the .mk files go through some great lengths to install only the needed data files for each example. This is a bit silly for several reasons: * In no other Buildroot package we do offer such a fine-grained selection of what the package installs; * directfb-examples are examples, they are therefore typically not meant to be used on a final production system, but more during development or for demonstration. Those are situations where size generally isn't that critical (all installed, the package takes 2.4 MB on the rootfs); * Those options and the .mk file logic has to be updated whenever the package is bumped; * Users can always use a post-build script to keep only the examples they are interested in. All the options are moved to Config.in.legacy. However, we could debate on whether this is actually useful, since the main option BR2_PACKAGE_DIRECTFB_EXAMPLES will now install a superset of whatever was selected before through sub-options. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* sawman: remove packageGravatar Thomas Petazzoni2015-09-101-0/+10
| | | | | | | | This commit removes the sawman package, since the corresponding functionality has been merged in DirectFB itself since 1.7.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* divine: remove packageGravatar Thomas Petazzoni2015-09-101-0/+13
| | | | | | | | This commit removes the divine package, since the corresponding functionality has been merged in DirectFB itself since 1.7.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/opencv: re-introduce opencv for opencv-2.4Gravatar Samuel Martin2015-08-251-32/+0
| | | | | | | | | | | | | | | | | | | | | | | | As Jonathan noticed in [1], users' applications may depend on opencv-2.4 APIs removed in opencv-3.0. So, re-introduce opencv package as it was right before the bump to opencv-3.0 (i.e.: commit bf00b5a9ea1ab4189fe5c7dea05f40d0bbbf2082). We do not support both OpenCV-2.4 and OpenCV-3 at the same time, so make OpenCV-3 depend on !OpenCV-2.4. [1] http://lists.busybox.net/pipermail/buildroot/2015-August/135270.html Cc: Jonathan Ben Avraham <yba@tkos.co.il> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Samuel Martin <s.martin49@gmail.com> [yann.morin.1998@free.fr: - remove legacy symbols, now - make opencv3 depends on !opencv, not the other way around - slitghly reword the commit log (opencv/opencv3 dependency) ] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-wmc: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h instead of client.cpp - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-vuplus: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h instead of client.cpp - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-vdr-vnsi: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-vbox: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h instead of client.cpp - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-stalker: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h instead of client.cpp - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-pvr-pctv: new packageGravatar Bernd Kuhls2015-07-301-0/+1
| | | | | | | | | [Thomas: - use a shorter file as the license file, client.h instead of client.cpp - do not pass -DCMAKE_MODULE_PATH, no longer needed.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>