aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
Commit message (Collapse)AuthorAgeFilesLines
* legacy: update the BR2_PREFER_STATIC_LIB optionGravatar Samuel Martin2014-12-141-1/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Since the refactoring of the type of libraries in the target filesystem, these options belong to a choice, and the default is "shared only". The former option BR2_PREFER_STATIC_LIB has been moved in the legacy menu, and only selects the BR2_STATIC_LIBS ("static only") option. However, because BR2_STATIC_LIBS belongs to a choice, when BR2_PREFER_STATIC_LIB is selected, it does not affect the choice. So, existing Buildroot configurations, which have BR2_PREFER_STATIC_LIB set, will silently end with BR2_SHARED_LIBS ("shared only") enabled. So, the backward compatibility is not kept. Besides, the legacy BR2_PREFER_STATIC_LIB option does not select BR2_LEGACY, so the user is not notified of this legacy option, and the build silently continues with some undesired changes. This patch removes the inefficient BR2_STATIC_LIBS selection, correctly selects the BR2_LEGACY option and extend the help message so the user can easily know how to update his/her Buildroot configuration. Signed-off-by: Samuel Martin <s.martin49@gmail.com> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBSGravatar Thomas Petazzoni2014-12-111-0/+12
| | | | | | | | | | | | | | | | | | | | | | | Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* Config.in.legacy: fix typoGravatar Baruch Siach2014-11-091-1/+1
| | | | | Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: add legacy handling for the recently removed ↵Gravatar Peter Korsgaard2014-11-091-0/+7
| | | | | | | | | BR2_x86_generic option Buildroot automatically falls back to a sensible CPU variant, but inform the user of the change anyway so they are aware of it. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gcc: remove version 4.4.xGravatar Andreas Larsson2014-10-301-0/+7
| | | | | | | | | | That gcc series is old and is not used as the default version for any of the architectures we support, so this commit gets rid of it. [Thomas: move the Config.in.legacy option at the right location.] Signed-off-by: Andreas Larsson <andreas@gaisler.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* arch: sparc: Add leon3 cpu type and remove sparc{s,h}fleon{,v8}Gravatar Andreas Larsson2014-10-301-0/+32
| | | | | | | | | | | There is support for -mcpu=leon3 from gcc 4.8.3. Use this for LEON systems instead of the non-mainline targets sparcsfleon, sparchfleon, sparcsfleonv8, and sparchfleonv8. [Thomas: add Config.in.legacy handling for the removed options.] Signed-off-by: Andreas Larsson <andreas@gaisler.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* xlib_libpciaccess: Rename package to libpciaccessGravatar Bernd Kuhls2014-10-191-0/+9
| | | | | | | | | While libpciaccess is part of the X libraries, it does not depend upon X11 or any other X library. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/linux-firmware: install Xceive/Cresta xc4000 and xc5000cGravatar Yann E. MORIN2014-09-211-0/+8
| | | | | | | | Tweak the prompt, because Xceive is now part of Cresta, so the new xc5000c-based devices might be branded under either name. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/linux-firmware: add option for Chelsio cxgb4 T5Gravatar Yann E. MORIN2014-09-211-0/+8
| | | | | Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/linux-firmware: prepare new firmware and new revision for iwlwifiGravatar Yann E. MORIN2014-09-211-0/+23
| | | | | | | | | | There is an upcoming new firmware file for a new chipset supported by iwlwifi, as well as a new revision of the iwlwifi firmware. The patch only prepares the iwlwifi entries so it is easier to add them. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libelf: Removes the packageGravatar Gregory CLEMENT2014-09-141-0/+9
| | | | | | | | | | | | The elfutils package provides a more recent version of the libelf. Some packages such as ltrace need this more recent version. Having two packages providing the same library leads to some conflicts or dependency problems. For instance at the end we had only one libelf.a when the 2 packages were selected. Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* busybox: support only one versionGravatar Thomas Petazzoni2014-07-101-0/+24
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit removes the version selection for the busybox package. Busybox is very well maintained, and bugs are typically fixed in a timely fashion. Moreover, regressions are fairly unlikely in this very stable and well-tested tool. Therefore, there isn't a very compelling reason to have a version selection for Busybox since we don't accept such a version selection for the vast majority of other packages, unless there is a strong reason to do so. Consequently, this commit: * Removes the 1.19.4, 1.20.2 and 1.21.1 Busybox versions, patches and default configuration file. * Moves the 1.22.1 patches from package/busybox/1.22.1 to just package/busybox/ like all other packages. * Renames the default 1.22.1 configuration file to just busybox.config. * Adapts the busybox.mk makefile to encode the current version to use. * Adds appropriate options to Config.in.legacy. However, even though the BR2_BUSYBOX_VERSION_1_22_X is removed, we don't add a Config.in.legacy option for it, since it would cause a legacy warning for virtually *all* users as most people are currently using 1.22.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gdb: remove versions 7.4 and 7.5Gravatar Thomas Petazzoni2014-07-101-2/+16
| | | | | | | | | We already default to 7.6 for all architectures (except AVR32, ARC and Microblaze that have their specific versions), and we have added 7.7 recently. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gcc: remove versions 4.3.x and 4.6.xGravatar Thomas Petazzoni2014-07-101-0/+14
| | | | | | | | | | | | | | | | | | | | | | | | Those gcc series are old and are not used as the default versions for any of the architectures we support, so this commit gets rid of them. The gcc 4.3.x series technically remains used by the LPC32xx defconfigs we have: configs/ea3250_defconfig:BR2_GCC_VERSION_4_3_X=y configs/fdi3250_defconfig:BR2_GCC_VERSION_4_3_X=y configs/phy3250_defconfig:BR2_GCC_VERSION_4_3_X=y Back when those defconfigs were introduced, gcc 4.3 was chosen because it was the only one capable of building a fully working kernel for those ARM-based platforms. However, the original submitter, Alexandre Belloni, no longer has access to the hardware platforms, so he is unable to test if newer gcc versions have fixed the problem. It certainly doesn't make sense to keep gcc 4.3.x just for those three boards, so we'll wait for someone actually using those defconfigs to complain. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* uclibc: remove version 0.9.32.1Gravatar Thomas Petazzoni2014-07-101-0/+7
| | | | | | | | | This commit removes the 0.9.32.1 version of uClibc, which is very old, and does not bring any specific advantage over 0.9.33, which has been around for more than two years now. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* binutils: remove 2.20.1, 2.21 and 2.23.1Gravatar Thomas Petazzoni2014-07-101-0/+21
| | | | | | | | | | | | | | - The 2.20.x series is old, it no longer makes sense to support it. - In the 2.21.x series, we still have 2.21.1, so keeping 2.21 doesn't make much sense, so this patch removes it. - Similarly for the 2.23.x series, having both 2.23.1 and 2.23.2 doesn't make much sense, so this patch removes 2.23.1 and keeps 2.23.2. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libv4l: Bump version to 1.0.1Gravatar Ezequiel García2014-07-101-0/+40
| | | | | | | | | | | | | | | Quite some work has been done from 0.8.3 to 1.0.1, and as a result this commit is very intrusive. The biggest change is the move to an autotools package. Then, the options that enable utilities individually have been deprecated and moved to Config.in.legacy. Instead, we introduce new option to select either all the utilities. This change loses granularity in favor of maintainability. [Peter: needs host-pkgconf. Select and use argp-standalone on uClibc] Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* kernel headers: remove deprecated version 3.8Gravatar Thomas De Schampheleire2014-06-131-3/+13
| | | | | | | | | | | | | | | Kernel headers version 3.8.x has been deprecated since 2013.08 and thus can be removed in 2014.08. An automatic selection of 3.9.x headers is performed in the legacy menu. Existing automatic selections of 3.8.x headers are modified to select 3.9.x. As this patch removes the last occurrence of BR2_DEPRECATED_SINCE_2013_08, the symbol is removed too. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gettext: remove support for gettext-tools on targetGravatar Thomas Petazzoni2014-06-091-0/+10
| | | | | | | | | | | | | | | This commit removes the BR2_PACKAGE_GETTEXT_TOOLS option, which could be used to install gettext tools on the target. This is not needed, because Buildroot is not designed to provide a full development environment on the target, and gettext translation files should be processed on the build machine, using the host gettext tools. Remove this option will allow to optimize the build time of gettext on the target, by only building the gettext runtime libraries. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Andrew Ruder <andrew.ruder@elecsyscorp.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* package/procps: bump version and rename to procps-ngGravatar Yann E. MORIN2014-06-021-0/+10
| | | | | | | | | | | | | | | | procps is getting replaced by procps-ng, and there are new versions available! procps-ng is now an autotools package, so get rid of our custom build/install rules. Remove most patches, except for one that still half-applies, so update and rename it. procps is dead, long live procps-ng! Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* evtest: bump version to 1.31Gravatar Peter Seiderer2014-05-031-0/+8
| | | | | | | | | | | - update version to 1.31 - correct license to GPLv2+ - change download url to official repository - remove evtest-capture support (dropped since 1.31) - change broken project URL to official repository Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* kernel headers: remove deprecated versions 3.6 and 3.7Gravatar Thomas De Schampheleire2014-05-011-2/+22
| | | | | | | | | | | | | | Kernel headers versions 3.6.x and 3.7.x have been deprecated since 2013.05 and thus can be removed in 2014.05. An automatic selection of 3.8.x headers is performed in the legacy menu. An existing automatic selection of 3.6.x headers is modified to select 3.8.x. As this patch removes the last occurrances of BR2_DEPRECATED_SINCE_2013_05, the symbol is removed too. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* vala: remove deprecated target packageGravatar Thomas De Schampheleire2014-05-011-0/+8
| | | | | | | | The vala target package has been deprecated since 2013.05 and thus can be removed in 2014.05. The host vala support is left untouched. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* system: make the zoneinfo list a system optionGravatar Yann E. MORIN2014-04-081-0/+15
| | | | | | | [Peter: move legacy options under 2014.05] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lua: rename config optionsGravatar Yann E. MORIN2014-04-051-0/+24
| | | | | | | | | | | | | | | | | | | Package's options should be named after the package. Lua is an interpreter, but the package is named 'lua'. So we want to name the config option with '_LUA_', not with '_LUA_INTERPRETER_' Besides, naming them with '_LUA_INTERPRETER_' might be confusing, since there is a package named 'luainterpreter'. Since the renamed options are part of a choice, we can't use the legacy options to select the new ones. So we instead instruct the user to go select the appropriate option in the choice. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Francois Perrad <fperrad@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/dvb-apps: bump revisionGravatar Yann E. MORIN2014-03-291-0/+7
| | | | | | | | | | | | | | | | | | | In this new revision, there is no longer transponders data, so dvb-apps now only installs the dvb-apps utilities. Packages that needs the transponders data have now all been switched to use dtv-scan-tables instead, so we don't need a legacy option for the transponders data. However, we add a legacy option for the utilities option, just to inform the user of the new behaviour. Sadly, a user that had dvb-apps selected just to get the transponders data will now get the full dvb-apps package installed. There's nothing we can really do about this. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* xlib_libpthread-stubs: Rename package to libpthread-stubsGravatar Bernd Kuhls2014-03-021-3/+11
| | | | | | | | Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com> Signed-Off-By: Paul Cercueil <paul@crapouillou.net> Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/linux-headers: remove 2.6 snapshotGravatar Yann E. MORIN2014-03-011-0/+7
| | | | | | | | | | | | | As Thomas states: It is completely weird to ask the tarball to be named exactly linux-2.6.tar.bz2. IMO, we should simply get rid of this feature. Make it so! ;-) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* systemd: bump to v207Gravatar eric.le.bihan.dev@free.fr2014-02-121-16/+25
| | | | | | | | | | | | | | | | | | | | | | | | | | This patch bumps systemd to v207 but also declares it as a provider for the udev virtual package. Starting with systemd 183, udev has been merged into systemd. The udev daemon is now installed as /lib/systemd/systemd-udevd. This means that /dev management using udev is only available if systemd is chosen as init system. When configuring systemd, the following options are available: - activation of systemd-journal-gatewayd, to access the journal via HTTP. - activation of extra features like journal compression and sealing. Support for uClibc has also been removed because: - upstream has no interest in supporting uClibc. - using a shrinked libc brings no advantage, given the size of all the programs included in Systemd. So using glibc does not matter. Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* udev: convert to virtual packageGravatar eric.le.bihan.dev@free.fr2014-02-121-0/+58
| | | | | | | | | | | | | | | This patch converts udev to a virtual package. For the moment, there is only one provider for the udev features: eudev. Packages meant to provide udev-like features must select the symbol BR2_PACKAGE_HAS_UDEV. Packages depending on BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV or BR2_PACKAGE_UDEV have been converted to use the new symbol. [Peter: move legacy symbols under 2014.05] Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* kernel-headers: remove deprecated versions 3.1, 3.3, 3.5Gravatar Thomas De Schampheleire2014-02-081-0/+30
| | | | | | | | | | | | | The Linux kernel headers versions 3.1, 3.3, and 3.5 have been deprecated since 2013.02 and thus can be removed in 2014.02. For legacy handling, we automatically select versions 3.2, 3.4, and 3.6, respectively. Additionally, this patch removes the now unused symbol BR2_DEPRECATED_SINCE_2013_02. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gdb: remove deprecated versions 7.2.x and 7.3.xGravatar Thomas De Schampheleire2014-02-081-0/+18
| | | | | | | | | Gdb versions 7.2.x and 7.3.x have been deprecated since 2013.02 and thus can be removed in 2014.02. For legacy handling, version 7.5.x is automatically selected. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ccache: remove deprecated target packageGravatar Thomas De Schampheleire2014-02-081-0/+8
| | | | | | | | | The ccache target package has been deprecated since 2013.02 and thus can be removed in 2014.02. This does not change anything about host ccache (used for speeding up builds). Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: remove support for documentation on targetGravatar Thomas De Schampheleire2014-02-081-0/+7
| | | | | | | | This patch removes deprecated symbol BR2_HAVE_DOCUMENTATION and all its usage. Additionally, it removes the now unused BR2_DEPRECATED_SINCE_2012_11. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* automake: remove deprecated target packageGravatar Thomas De Schampheleire2014-02-081-0/+8
| | | | | | | | | The automake support on target has been deprecated for more than four buildroot releases and thus can be removed. This doesn't change anything about the host automake support. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* autoconf: remove deprecated target packageGravatar Thomas De Schampheleire2014-02-081-0/+8
| | | | | | | | | The autoconf support on target has been deprecated for more than four buildroot releases and thus can be removed. This doesn't change anything about the host autoconf support. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* xstroke: remove deprecated packageGravatar Thomas De Schampheleire2014-02-081-0/+7
| | | | | | | | xstroke has been deprecated since 2013.02 and thus can be removed in 2014.02. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* arch: remove sh2, sh3 and sh3eb supportGravatar Thomas Petazzoni2014-02-051-0/+18
| | | | | | | | | | | | This patch removes the sh2, sh3 and sh3eb support, because the user base is inexistent, and the Linux support for these architectures is poor. The sh2a support is preserved, because at least one user expressed interest in this architecture, and is actually using it: http://lists.busybox.net/pipermail/buildroot/2013-April/070399.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Rename MySQL client packageGravatar Marcelo Gutiérrez(UTN/FRH)2014-01-211-0/+7
| | | | | | | | | MySQL client package has been renamed to MySQL. [Peter: fixup help text] Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: fix misc. problems with libnfc-llcp removalGravatar Thomas De Schampheleire2014-01-211-5/+4
| | | | | | | | | | | | | | | | | The Config.in.legacy entry associated with the replacement of libnfc-llcp was broken in multiple ways: - it was not correctly added within the section for 2014.02 deprecation (recently fixed by Yann E. Morin with commit f169e5e1055600fda1b3ff0c852ee84d2ec80460) - it still had select/depend statements from the original symbol, which should not be added in Config.in.legacy. - it did not select the replacement symbol as to make the transition for users more convenient. - indentation of the help text was not tab+2spaces. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lzma: remove deprecated target packageGravatar Thomas De Schampheleire2014-01-211-0/+8
| | | | | | | | | The on-target lzma package has been deprecated for a long time, so remove it. This does not remove the support for generating lzma-compressed rootfs images. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ttcp: remove deprecated packageGravatar Thomas De Schampheleire2014-01-211-0/+7
| | | | | | | | Since this is the only package depending on BR2_DEPRECATED_SINCE_2012_05, remove that symbol as well. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* legacy: move 2014.02 headerGravatar Yann E. MORIN2014-01-201-3/+2
| | | | | | | Legacy LIBNFC_LLCP belongs to the 2014.02 cycle. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* luasql-sqlite3: renamed like with LuaRocksGravatar Francois Perrad2014-01-131-0/+7
| | | | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> [yann.morin.1998@free.fr: select BR2_PACKAGE_SQLITE] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua-cjson: restore official nameGravatar Francois Perrad2014-01-131-0/+7
| | | | | | | | | (need by LuaRocks) Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libnfc-llcp: rename to libllcp and bump versionGravatar Vicente Olivert Riera2014-01-131-0/+11
| | | | | | | | | | This package has been renamed upstream to libllcp. Also, the current package we have in Buildroot fails to compile due to a version bump of it's main dependence, libnfc. A version bump is required because this package has been adapted upstream to work with libnfc-1.7.0-rc6. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* squashfs3: remove deprecated package/rootfsGravatar Thomas De Schampheleire2014-01-101-0/+17
| | | | | | | [Peter: remove now unused BR2_DEPRECATED_SINCE_2010_05 symbol] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Remove deprecated package netkitbase and netkittelnetGravatar Arnaud Aujon2013-12-151-0/+20
| | | | | | [Peter: fixup Config.in.legacy indentation] Signed-off-by: Arnaud Aujon <arnaud.aujon@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lvm2: replace !BR2_PACKAGE_LVM2_DMSETUP_ONLY by ↵Gravatar Arnout Vandecappelle2013-11-281-0/+12
| | | | | | | | | | | | | | | | | | | BR2_PACKAGE_LVM2_STANDARD_INSTALL BR2_PACKAGE_LVM2_DMSETUP_ONLY is a "negative" option that disables build and install of part of the suite. This option cannot be unselected by other config options, which gives a problem for BR2_PACKAGE_UDISKS_LVM2: it needs BR2_PACKAGE_LVM2_APP_LIBRARY, which requires the full suite. Therefore, replace the negative BR2_PACKAGE_LVM2_DMSETUP_ONLY by a positive BR2_PACKAGE_LVM2_STANDARD_INSTALL. To make sure that existing defconfigs keep working, the new option defaults to y unless the legacy BR2_PACKAGE_LVM2_DMSETUP_ONLY was selected. Fixes http://autobuild.buildroot.net/results/ea4627cae45e972ebba5b33a2b2871ce7f46fedc/ Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: select BR2_LEGACY for module-init-tools legacy optionGravatar Thomas Petazzoni2013-11-101-0/+1
| | | | | | | | | | | | | | | | Commit 94c72087f3 ("module-init-tools: remove package") removed the module-init-tools package and therefore added the corresponding config option in Config.in.legacy. However, the commit forgot to add the "select BR2_LEGACY" that ensures the build cannot proceed until the user has acknowledged the change (i.e kmod replacing module-init-tools). This commit adds this missing "select BR2_LEGACY". Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>