aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
Commit message (Collapse)AuthorAgeFilesLines
* package/x11r7/xserver_xorg-server: bump version to 1.20.0Gravatar Bernd Kuhls2018-07-281-0/+7
| | | | | | | | | | | | | Rebased patch 0001 after upstream commit: https://cgit.freedesktop.org/xorg/xserver/commit/configure.ac?id=e0748b10a8621066b404d713a76826907da777b9 Removed patch 0004, applied upstream: https://cgit.freedesktop.org/xorg/xserver/commit/glx/glxscreens.c?id=d16133e3e293fe16b291114d344fbd5a61d5ed65 Added legacy handling for internal version option. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/x11r7/xproto_*: mass removalGravatar Bernd Kuhls2018-07-281-0/+241
| | | | | | | | | | | | The new package xorgproto will combine and replace all current xproto_* packages. For details read https://lists.x.org/archives/xorg-announce/2018-February/002835.html After switching to xorgproto the old xproto_* packages are removed. Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* gst1-plugins-${base, good, bad, ugly}: bump to 1.14.1Gravatar Adam Duskett2018-06-261-0/+80
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | These are grouped together because several plugins have been re-arranged and there is no way to individually update each plugin package. Changes: Add the following to gst1-plugins-base and remove them from plugins-bad: - opengl - gles2 - glx - egl - x11 - dispmanx - audiomixer Add the following to plugins-good and remove them from plugins-ugly: - lame - mpg123 moved --disable-qt from plugins-bad to plugins-good Delete upstream patch from gst1-plugins-ugly ([1]) - 0001-x264enc-fix-build-with-newer-x264-with-support-for-m.patch Also add hashes for the license files. [1] https://cgit.freedesktop.org/gstreamer/gst-plugins-ugly/commit/?id=83c38dc44622611c1f67dd26e4cb383c5aef90f6 Signed-off-by: Adam Duskett <aduskett@gmail.com> [Upate to 1.14.1] [Removed legacy lame/mpg123 option, add Config.in.legacy handling] [remove leftover audiomixer handling from gst1-plugins-bad.mk] [remove upstream patch from gst1-plugins-ugly] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gdb: remove 7.11Gravatar Romain Naour2018-06-241-0/+7
| | | | | | | | | Now that 8.1 has been added and 8.0 is the default version, let's remove the old 7.11 release. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gdb: remove 7.10Gravatar Romain Naour2018-06-241-0/+10
| | | | | | | | | Now that 8.1 has been added and 8.0 is the default version, let's remove the old 7.10 release. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/ti-sgx-km: properly handle legacy for renamed optionsGravatar Yann E. MORIN2018-06-171-0/+8
| | | | | | | | | | | | | Commit b54c5464cc (ti-sgx-km: rename options to have proper prefix) forgot to add defaults from legacy options, and notices in Config.in.legacy that legacy options are still referenced in the package itself. Reported-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* libmediaart: rename options to have proper prefixGravatar Petr Vorel2018-05-211-0/+24
| | | | | | | | | | | | | | | | | | | | | | Options should be prefixed by BR2_PACKAGE_LIBMEDIAART and not BR2_PACKAGE_MEDIAART, but package was using both prefixes. This was found as default symbol was defined as BR2_PACKAGE_LIBMEDIAART_BACKEND_NONE (correct prefix), but symbol was actually BR2_PACKAGE_MEDIAART_BACKEND_NONE). This commit therefore renames the incorrectly named options, and adds Config.in.legacy handling. Since the options are part of a choice, the legacy handling cannot select the new options, and is only here to inform the user. Fixes: c443830a57 libmediaart: new package Signed-off-by: Petr Vorel <petr.vorel@gmail.com> [Thomas: improve commit log, add Config.in.legacy handling] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ti-sgx-km: rename options to have proper prefixGravatar Thomas Petazzoni2018-05-211-0/+32
| | | | | | | | | | | | | | | The sub-options of the ti-sgx-km package had their name option prefixed by BR2_PACKAGE_TI_SGX, while the prefix should be BR2_PACKAGE_TI_SGX_KM. This commit fixes that, and adds the necessary Config.in.legacy handling. Since those options are part of a choice, the legacy handling cannot select the new name of the options, so the legacy handling only informs the user of the rename. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* janus-gateway: rename options to have proper prefixGravatar Thomas Petazzoni2018-05-211-0/+117
| | | | | | | | | | | The sub-options of the janus-gateway package had their name option prefixed by BR2_PACKAGE_JANUS, while the prefix should be BR2_PACKAGE_JANUS_GATEWAY. This commit fixes that, and adds the necessary Config.in.legacy handling. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ipsec-tools: rename options to have proper prefixGravatar Thomas Petazzoni2018-05-211-0/+24
| | | | | | | | | | | | | | | A number of options in the ipsec-tools package had their Config.in option prefixed by BR2_PACKAGE_IPSEC, while the prefix should be BR2_PACKAGE_IPSEC_TOOLS. This commit fixes that, and adds the necessary Config.in.legacy handling. Since those options are part of a choice, the legacy handling cannot select the new name of the options, so the legacy handling only informs the user of the rename. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libftdi: rename option to have proper prefixGravatar Thomas Petazzoni2018-05-211-0/+9
| | | | | | | | | | The option name BR2_PACKAGE_LIBTFDI_CPP obviously had a typo: it should have been named BR2_PACKAGE_LIBFTDI_CPP, and add the necessary Config.in.legacy handling. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* jquery-ui-themes: rename options to have proper prefixGravatar Thomas Petazzoni2018-05-211-0/+216
| | | | | | | | | | | | | | The choice options to select the specific jquery-ui theme to install had a prefix of BR2_PACKAGE_JQUERY_UI_THEME_ instead of BR2_PACKAGE_JQUERY_UI_THEMES_. This commit fixes that, and adds Config.in.legacy handling. It's worth mentioning that since those options are part of a choice, the legacy handling cannot select the new name of the option: we can simply inform the user about the renaming. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* bluez5_utils: rename options to have the proper suffixGravatar Thomas Petazzoni2018-05-211-0/+45
| | | | | | | | | | | The bluez5_utils Config.in options had a bogus prefix: BR2_PACKAGE_BLUEZ5 instead of the expected BR2_PACKAGE_BLUEZ5_UTILS. This commit fixes that, and adds the appropriate Config.in.legacy handling. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/transmission: remove BR2_PACKAGE_TRANSMISSION_REMOTEGravatar Bernd Kuhls2018-05-201-0/+11
| | | | | | | | | | | | | | | | | | | Commit 6e223241e1bb58a27eb890291f9f5c1fcc6a0818 ("Add Transmission package"), which added the transmission package, introduced a BR2_PACKAGE_TRANSMISSION_REMOTE Config.in option, supposedly matching the --enable-remote/--disable-remote transmission option. However, transmission as of version 2.33 packaged by this initial commit, did not have a --enable-remote/--disable-remote option, and it was apparently never part of transmission. Therefore, this commit removes this useless option. Since the transmission-remote tool is automatically built when the daemon is enabled, the Config.in.legacy handling selects BR2_PACKAGE_TRANSMISSION_DAEMON. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mplayer: remove packageGravatar Bernd Kuhls2018-05-091-0/+18
| | | | | | | | | | | | This package causes numerous build errors. During the last hackaton it was decided to remove this package: http://lists.busybox.net/pipermail/buildroot/2018-April/217514.html Fixes http://autobuild.buildroot.net/results/bda/bda461391c9e02e313fda887b75099e619527a7a/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libplayer: remove mplayer supportGravatar Bernd Kuhls2018-05-081-0/+6
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* libkcapi: split BR2_PACKAGE_LIBKCAPI_APPSGravatar Fabrice Fontaine2018-05-081-0/+11
| | | | | | | | | | | | | | | | | | | Since commit https://github.com/smuellerDD/libkcapi/commit/af313accf18887b4f6dbd7306c2389ddf271c9b7, hasher test application depends on dlfcn.h. To avoid putting all apps under !BR2_STATIC_LIBS dependency, split BR2_PACKAGE_LIBKCAPI_APPS into several variables. Moreover, BR2_USE_MMU is only a dependency of BR2_PACKAGE_LIBKCAPI_TEST as other applications don't use fork. Finally, enc or dgst applications could be enabled in a next patch if needed. Fixes: - http://autobuild.buildroot.net/results/7c57f3025030eff41a5cde52759821249859caf1 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* legacy: remove options made legacy 5 years agoGravatar Yann E. MORIN2018-04-161-17/+0
| | | | | | Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch: drop BR2_BINFMT_FLAT_SEP_DATA supportGravatar Thomas Petazzoni2018-04-151-0/+7
| | | | | | This was only used by Blackfin, so there's no good reason to keep it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch: remove Blackfin architectureGravatar Thomas Petazzoni2018-04-151-0/+8
| | | | | | | | | | | | | | | | | The Blackfin architecture has for a long time been complicated to maintain, with poor support in upstream binutils/gcc. As of April 2018, the Blackfin architecture has been dropped from the upstream Linux kernel. Also, the Analog Device engineer who used to be in touch with the Buildroot community also privately said we should drop the support for this architecture, which Analog Devices is no longer using, promoting and maintaining. The BR2_BINFMT_FLAT_SEP_DATA option becomes unselectable, it will be removed in a future commit. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* iqvlinux: remove packageGravatar Thomas Petazzoni2018-04-061-0/+17
| | | | | | | | | | | | | | | | | | | | | | This package contains a kernel module from Intel, which could only be used together with Intel userspace tools provided under NDA, which also come with the same kernel module. The copy of the kernel module available on SourceForge is only provided to comply with the GPLv2 requirement. Intel engineers were even surprised it even built and were not willing to make any effort to fix their tarball naming to contain a version number. Therefore, it does not make sense for Buildroot to provide such a package. See https://sourceforge.net/p/e1000/bugs/589/ for the discussion. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Acked-by: Carlos Santos <casantos@datacom.ind.br> Acked-by: Romain Naour <romain.naour@gmail.com> [Thomas: - remove double "only" noticed by Carlos - fix typo packaged -> package noticed by Romain - fix check-package warning noticed by Ricardo] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/kodi-adsp-*: remove packagesGravatar Bernd Kuhls2018-04-011-0/+15
| | | | | | | | Those packages are unmaintained and not in a working state, for details see https://github.com/xbmc/xbmc/pull/13723 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* Config.in*: re-wrap help textGravatar Ricardo Martincoski2018-04-011-127/+162
| | | | | | | ... to follow the convention <tab><2 spaces><62 chars>. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* Config.in*: fix attributes orderGravatar Ricardo Martincoski2018-04-011-1/+1
| | | | | | | ... to follow the convention: type, default, depends on, select, help. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* */Config.in*: remove consecutive empty linesGravatar Ricardo Martincoski2018-04-011-1/+0
| | | | | Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* linux-headers: drop old unsupported 3.x versionsGravatar Peter Korsgaard2018-02-041-0/+30
| | | | | | | | These versions are very old and no longer supported according to https://www.kernel.org/category/releases.html, so drop them and add legacy entries. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/binutils: remove support for 2.27Gravatar Romain Naour2018-01-301-0/+8
| | | | | | | | | | | Now that binutils 2.30 has been introduced, and we have moved to 2.29.1 as the default version, it is time to drop support for binutils 2.27. Also use xz-compressed tarball for all official supported version. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* cups-filters: new packageGravatar Olivier Schonken2018-01-081-0/+1
| | | | | | | | | | Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com> [Thomas: - add missing select BR2_PACKAGE_JPEG - use jpeg instead of libjpeg - sort selects alphabetically - fix Config.in comment dependencies.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* imx-gpu-viv: bump to version 6.2.2.p0Gravatar Gary Bisson2018-01-071-0/+14
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | New features: - Added mutex protection for referencing gctSIGNAL in gckOS_MapSignal to fix a MT race issue. - Streamlined GPU address calculation base on MC20 (0/1) and MMU (0/1) combinations. - Fixed multiple Android HWC 2.0 rendering issues. Refined HWC 2.0 driver implementation. - Improved HWC2.0 composition performance by composing damaged regions only. - Enabled offline/online compiler IR assembly dump function for users. - Implemented the direct rendering support (no-resolve) for Wayland platform. - Added EGL_EXT_buffer_age extension for Wayland and fbdev platforms. - Updated wayland-viv protocol to support tile status sync from client to server. - Improved OpenCL 1.2 builtin function support with native GPU instructions. - Enabled OpenCL 1.2 API trace dump function controlled by VIV_TRACE environment variable. - Support for OpenGL4.0 - Cleaned up driver code issues reported by Klocwork and Coverity. Full changelog: http://git.freescale.com/git/cgit.cgi/imx/fsl-arm-yocto-bsp.git/tree/GraphicsChangeLogv6?h=imx-morty Note that the apitrace tool and the G2D libraries are not part of the package any longer, so the corresponding options are removed. The G2D libraries are now provided by a separate package. This package has been tested with both X11 and Framebuffer backends: # cd /usr/share/examples/viv_samples/vdk/ # ./tutorial7 # gmem_info ... display memory use per PID ... Also update packages that depended on g2d libraries to match new package name. Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* eeprog: remove packageGravatar Baruch Siach2018-01-021-0/+8
| | | | | | | | The i2c-tools package has adopted the code of eeprog. Cc: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: update comment that old entries have been removedGravatar Yann E. MORIN2017-12-281-4/+4
| | | | | | Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: drop 2013.02 entriesGravatar Yann E. MORIN2017-12-281-67/+0
| | | | | | | | When we release 2018.02 at the end of this cycle, those entries will have been removed for more than five years, so we can drop them now. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: drop 2012.11 entriesGravatar Yann E. MORIN2017-12-281-36/+0
| | | | | | | Those entries are older than 5 years, we can drop them now. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Config.in.legacy: drop 2012.08 entriesGravatar Yann E. MORIN2017-12-281-35/+0
| | | | | | | Those entries are older than 5 years, we can drop them now. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Revert "package/qt5webkit-examples: remove obsolete package"Gravatar Gaël PORTAY2017-11-291-7/+0
| | | | | | | | | | | | | | | | This reverts commit 940bfe2f4336a3fea1ec6805db1f90ce83bd4a78 with the following changes: - new hashes for 5.6.3 and 5.9.1 (there is no 5.9.2). - BR2_PACKAGE_QT5BASE_LICENSE_APPROVED has been removed - add GPL-3 to licences - uses SPDX identifier for licences - add missing dependencies (qt5base, qt5webkit, qt5declarative) - removes /usr when qmake host-tools is invoked at configure Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com> [Thomas: add entry in the DEVELOPERS file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* gnupg2: don't preserve the old gpg2 executable nameGravatar Baruch Siach2017-11-271-0/+11
| | | | | | | | | | | | | | | Commit e82fadab236a (gnupg2: bump to version 2.2.0) added a configure option to keep the old 'gpg2' executable name to avoid conflict with the gnupg package. It turns out that gnupg depends on !BR2_PACKAGE_GNUPG2 since commit 2cadb26e6d4 (gnupg: make gnupg and gnupg2 mutually exclusive). Drop this configure option. Rename the config option that controls the removal of gpgv2, now gpgv, to match the new name. Add legacy config symbol handling. Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* rfkill: remove packageGravatar Carlos Santos2017-11-031-0/+8
| | | | | | | | | | | The rfkill program has been incorporated to the util-linux package. The new implementation is based upon, and backward compatible with, the original rfkill from Johannes Berg and Marcel Holtmann. Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* util-linux: security bump to version 2.31Gravatar Carlos Santos2017-10-311-0/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | Fix CVE-2016-2779: runuser in util-linux allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer. The new experimental "su --pty" feature has been implemented to fix this issue. The feature is not enabled by default and the new command line option --pty is necessary. Add rfkill, a command for enabling and disabling wireless devices. This implementation is based upon, and backward compatible with, the original rfkill from Johannes Berg and Marcel Holtmann, currently provided by the standalone "rfkill" package. Add uuidparse, a command to analyze and print information about UUID's. The "reset" script is not part of utill-linux anymore. Add a legacy config telling the user to use either BusyBox or the ncurses program. Drop the ncursesw patch, allready applied upstream. AUTORECONF is not required anymore. Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* policycoreutils: split packages and bump to 2.7Gravatar Adam Duskett2017-10-181-0/+29
| | | | | | | | | | | | | | | | | | | | | | | Policycoreutils was broken up into several packages, as such several changes needed to happen for this patch to work: - Remove patches 3, 4, and 5 as they no longer apply. - Refresh patches 1 and 2 to work with version 2.7 - Remove semodule_${deps,expand,link,package} and sestatus from the makedirs in the mk file. - Remove restorecond from the make and config file. (Seperate package) - Remove Audit2allow from the make and config file. (In a different package) - Remove the package sepolgen - Add the package selinux-python - Add the package restorecond - Add the package semodule-utils - Add the relevant Config.in.legacy options into the menu. Because these are utilities that work on top of python, the older versions of these utilites still work, and as such this should be a single patch. Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/openobex: bump version to 1.7.2Gravatar Bernd Kuhls2017-09-241-0/+40
| | | | | | | | | | | | | | | | | | Package switched to cmake without providing most of the autoconf options previously available. Therefore we move all suboptions to Config.in.legacy. All patches are removed, the files to be patched do not exist anymore. OPENOBEX_EXTRACT_CMDS is not needed anymore, upstream provides the source as .tar.gz now. Version 1.6 added support for libusb-1.x and udev. The current version also supports bluez5_utils, not only bluez_utils. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Arnout: add help text to legacy options] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* boot/grub: removeGravatar Yann E. MORIN2017-09-231-0/+9
| | | | | | | | | | | | | | | | | | | | | | grub is no longer maintained: it is stuck at version 0.97 with huge patches that have no opportunity to be applied upstream, as upstream has even renamed it grub-legacy. Besides, it no longer builds correctly with recent binutils versions, and even the huge patches we could grab from Debian do not help the slightest. Since upstream really considers it dead, and there are at least two alternatives (grub2 and syslinux), just remove grub. Add a legacy entry. Remove the test cases as well. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Ricardo Martincoski <ricardo.martincoski@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* aiccu: remove packageGravatar Alexander Mukhin2017-09-111-0/+9
| | | | | | | | As the SixXS project has ceased its operation on 2017-06-06, the aiccu utility has been removed. Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* util-linux: add menu items for login utilitiesGravatar Carlos Santos2017-09-021-0/+15
| | | | | | | | | | | | | | This change extends to the login utilities the current policy of having a selection item in the configuration menu for each utility that has an --enable/--disable knob in the "configure" script: - add selection items for login, runuser, su and sulogin (there was already an item for "last") - move "login utilities" to Config.in.legacy - make "login utilities" select last, login, runuser, su and sulogin Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/simicsfs: remove packageGravatar Bin Meng2017-08-301-0/+13
| | | | | | | | | | | | | | | Buildroot currently packages version 1.18 of simics, which is quite out of date, and does not compile with Linux 4.12+. The latest package v1.22 supports recent kernels, however that is not publicly available anymore like the older versions. In fact Simics is now moving away from the simicsfs kernel module, as the kernel module has required too much maintenance work. Users should move to the new user mode Simics agent instead. Therefore, we drop the corresponding package from Buildroot. Signed-off-by: Bin Meng <bmeng.cn@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* binutils: remove support for 2.26Gravatar Thomas Petazzoni2017-08-011-0/+8
| | | | | | | | Now that binutils 2.29 has been introduced, and we have moved to 2.28.1 as the default version, it is time to drop support for binutils 2.26.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/kodi-inputstream-rtmp: new packageGravatar Bernd Kuhls2017-07-221-0/+1
| | | | | | | | Select the new package by the legacy option for easier update. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Thomas: use SPDX license code.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* arch/xtensa: allow specifying path to tarball fileGravatar Yann E. MORIN2017-07-091-3/+15
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | currently, specifying a custom Xtrensa core is done with two variables: - the core name - the directory containing the overlay tarball However, the core name only serves to construct the tarball name, and is not used whatsoever to configure any of the toolchain components (binutils, gcc or gdb), except through the files that are overlayed in their respective source trees. This has two main drawbacks: - the overlay file must be named after the core, - the tarball can not be compressed. Furthermore, it also makes it extremely complex to implement a download of that tarball. So, those two variables can be squeezed into a single variable, that is the complete path of the overlay tarball. Update the qemu-xtensa defconfig accordingly. Note: we do not add a legacy entry for BR2_XTENSA_CORE_NAME, since it was previously a blind option in the last release, and there's been no release since we removed BR2_XTENSA_CUSTOM_NAME. So, we just update the legacy comments for BR2_XTENSA_CUSTOM_NAME, since that's all the user could have seen in any of our releases so far. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* arch/xtensa: get rid of an intermediate blind kconfig optionGravatar Yann E. MORIN2017-07-091-0/+11
| | | | | | | | | | | | | | | | | It is not needed to have an intermediate blind option, we can just hide the prompt behind the same dependency as the non-blind symbol. Update our qemu-xtensa defconfig acordingly (note: it was using different values for both options, which is not possible; the blind option was just set to the non-blind one in the .config). Also remove an unneeded empty default for the BR2_XTENSA_OVERLAY_DIR string option (strings are empty by default). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* fs/ext2: rename BR2_TARGET_ROOTFS_EXT2_BLOCKS to BR2_TARGET_ROOTFS_EXT2_SIZEGravatar Samuel Martin2017-07-091-0/+17
| | | | | | | | | | | | | | This change deprecates the ext2/3/4 rootfs size in blocks symbol in favor of one that mimic the fs-size argument behavior of mkfs (i.e. size in a human readable format accepting k, m, g or t suffix or their upper-case variants). This change also updates the defconfigs that used to set BR2_TARGET_ROOTFS_EXT2_BLOCKS symbol. Signed-off-by: Samuel Martin <s.martin49@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/mke2img: remove packageGravatar Sébastien Szymanski2017-07-051-0/+7
| | | | | | | | | | | Now that we use mkfs to generate ext2/3/4 filesystem image by calling mkfs directly from fs/ext2/ext2.mk, we can remove this package. Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com> Signed-off-by: Samuel Martin <s.martin49@gmail.com> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>