aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
Commit message (Collapse)AuthorAgeFilesLines
* Config.in.legacy: fix small typoGravatar Fabrice Fontaine2019-11-101-1/+1
| | | | | | | Fix small typo: oenvmtools -> openvmtools Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* legacy: add missing entry for openvmtools' procps removalGravatar Yann E. MORIN2019-11-101-0/+6
| | | | | | | Commit 2be4232d98 removed the config option for openvmtools' procps support, but forgot to add it to the legacy menu. Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/alljoyn*: Remove the Alljoyn framework packagesGravatar Titouan Christophe2019-10-311-0/+42
| | | | | | | | | | | The upstream Alljoyn project is dead since the AllSeen Alliance merged with the Open Connectivity Foundation back in 2016. No other package depends on Alljoyn, so it can be removed. Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu> [Peter: fixup legacy option text] Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* toolchain: expose BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS for all toolchain typesGravatar Matt Weber2019-10-281-0/+11
| | | | | | | | | | | | | | | | | | This patch extends the "copy extra GCC libraries to target" feature to also work for internal toolchains. The variable has been renamed to be BR2_TOOLCHAIN_EXTRA_LIBS and the configuration option moved under the generic toolchain package. For external toolchains, the step that does the copy is still in the copy_toolchain_lib_root() helper which copies from the sysroot to the target. For the internal toolchain, the host gcc-final package does a post install hook to copy the libraries from the toolchain build folders to both the sysroot and target(!static). Examples where this can be useful is for adding debug libraries to the target like the GCC libsanitizer (libasan/liblsan/...). Cc: Markus Mayer <mmayer@broadcom.com> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/python-pysnmp-apps: remove packageGravatar Asaf Kahlon2019-10-221-0/+9
| | | | | | | The package was renamed to snmpclitools and is no longer maintained. Signed-off-by: Asaf Kahlon <asafka7@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/linux-headers: drop support for 5.2.x headersGravatar Bernd Kuhls2019-10-181-0/+7
| | | | | | | | The 5.2.x series is now EOL so remove the option and add legacy handling for it. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* boot/riscv-pk: Remove obselete bootloaderGravatar Alistair Francis2019-10-111-0/+7
| | | | | | | | | The RISCV Proxy Kernel (AKA BBL) isn't being used by most distros so has very limited testing. It has been replaced by OpenSBI and been deprecated for awhile, so let's just remove it. Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/sqlite: bump version to 3.30.0Gravatar Bernd Kuhls2019-10-071-0/+6
| | | | | | | | | | | | | | | | Release notes: https://www.sqlite.org/releaselog/3_30_0.html Changed Config.in option from stat3 to stat4 https://www.sqlite.org/compile.html#enable_stat3 "This option used to cause the ANALYZE command to collect index histogram data in the sqlite_stat3 table. But that functionality was superceded by SQLITE_ENABLE_STAT4 as of SQLite version 3.8.1 (2013-10-17). The SQLITE_ENABLE_STAT3 compile-time option continued to be supported through version 3.29.0 (2019-07-10) but has now become a no-op." Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/linux-headers: drop support for 5.1.x headersGravatar Peter Korsgaard2019-10-021-0/+7
| | | | | | | The 5.1.x series is now EOL and 5.3.x has been added, so remove the option and add legacy handling for it. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/devmem2: remove packageGravatar Carlos Santos2019-09-231-0/+7
| | | | | | | | | | | | | | | | | It was here just for backwards compatibility and is not used by any package or board after commits 59856480b6 packages/devmem2: remove from all board configurations 2f6e3eae55 package/ti-gfx: do not use devmem2 in script There are address casting issues with 32bit access on a 64bit bus (like on the SoC FPGA ARM processors) with this tool. The Busybox version of devmem is the most up to date and supports quadword access. Fixes: https://bugs.busybox.net/show_bug.cgi?id=10171 Signed-off-by: Carlos Santos <unixmania@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/ustr: remove packageGravatar Thomas Petazzoni2019-09-221-0/+8
| | | | | | | | This package was only used by libsemanage, but it is no longer used since SELinux 2.7, so drop it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/kodi-screensaver-planestate: remove packageGravatar Bernd Kuhls2019-09-211-0/+6
| | | | | | | | | | | | | This package is incompatible with Kodi 18.x, configure is broken: CMake Error at output/host/x86_64-buildroot-linux-uclibc/sysroot/usr/share/kodi/cmake/AddonHelpers.cmake:197 (message): "@ADDON_DEPENDS@" not found in addon.xml.in. This package is also not part of the upstream binary repo: https://github.com/xbmc/repo-binary-addons Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/kodi-visualisation-waveforhue: remove packageGravatar Bernd Kuhls2019-09-211-0/+6
| | | | | | | | | | | | This package is incompatible with Kodi 18.x, configure is broken: CMake Error at output/host/x86_64-buildroot-linux-uclibc/sysroot/usr/share/kodi/cmake/AddonHelpers.cmake:197 (message): "@ADDON_DEPENDS@" not found in addon.xml.in. For details read PR 2857 of https://github.com/LibreELEC/LibreELEC.tv Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/kodi-audiodecoder-opus: remove packageGravatar Bernd Kuhls2019-09-211-0/+6
| | | | | | | | | | | | | This package is incompatible with Kodi 18.x, configure is broken: CMake Error at output/host/x86_64-buildroot-linux-uclibc/sysroot/usr/share/kodi/cmake/AddonHelpers.cmake:197 (message): "@ADDON_DEPENDS@" not found in addon.xml.in. This package is also not part of the upstream binary repo: https://github.com/xbmc/repo-binary-addons Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/mesa3d: add OSMesa classic needs dri swrastGravatar Romain Naour2019-09-211-1/+1
| | | | | | | | | | | | The meson build system now check if dri swrast is enabled when OSMesa classic is enabled. See: https://cgit.freedesktop.org/mesa/mesa/commit/?id=cbbd5bb889a2c271a504c379f36a7cb717a85af4 Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/mesa3d: rename OSMesa optionGravatar Romain Naour2019-09-211-0/+8
| | | | | | | | | This option is renamed in order to match the naming used by the meson buildsystem. Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/hostapd: remove support for Realtek driversGravatar Alexander Mukhin2019-09-071-0/+10
| | | | | | | | | | After hostapd update to 2.9, the patch provided no longer works, although applies. Moreover, AP support for Realtek chips is broken anyway in kernels > 4.9. Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com> [Thomas: add Config.in.legacy handling] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* Merge branch 'next'Gravatar Peter Korsgaard2019-09-031-0/+15
|\
| * package/wpa_supplicant: security bump version to 2.9Gravatar Bernd Kuhls2019-08-281-0/+15
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Fixes https://w1.fi/security/2019-6/ Removed patch applied upstream: http://w1.fi/cgit/hostap/commit/?id=f2973fa39d6109f0f34969e91551a98dc340d537 Removed all other upstream patches which are included in this release. Release notes: http://lists.infradead.org/pipermail/hostap/2019-April/039979.html http://lists.infradead.org/pipermail/hostap/2019-August/040373.html Support for the old dbus interface was removed upstream: http://w1.fi/cgit/hostap/commit/?id=6a8dee76d4090287c016680c009b1334e01b5fbd Removed Config.in option, removed _NEW from remaining dbus option, select BR2_PACKAGE_DBUS when needed and added Config.in.legacy options. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* | boot/ts4800-mrboot: remove packageGravatar Thomas Petazzoni2019-09-011-0/+8
| | | | | | | | | | | | | | | | | | Since the ts4800_defconfig has been removed, the ts4800-mrboot package is no longer useful, therefore we drop it. Cc: Patrick Keroulas <patrick.keroulas@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* | package/libamcodec: remove packageGravatar Bernd Kuhls2019-08-111-0/+7
| | | | | | | | | | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* | package/odroid-scripts: remove packageGravatar Bernd Kuhls2019-08-111-0/+7
| | | | | | | | | | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* | package/odroid-mali: remove packageGravatar Bernd Kuhls2019-08-111-0/+7
| | | | | | | | | | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* | package/kodi: remove AMLogic supportGravatar Bernd Kuhls2019-08-111-0/+7
|/ | | | | | | | | | | Kodi 19 will remove specific support for AMLogic: https://github.com/xbmc/xbmc/pull/16043 Also buildroot dropped support for the odroid2c defconfig: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gcc: remove version 6.5Gravatar Romain Naour2019-08-041-0/+7
| | | | | | | | | | gcc 9.1 is around, gcc 8.3 is the default version, so drop 6.5 in order to reduce the gcc choice. Keep gcc 5.5 since it still used by beaglebone_qt5_defconfig. Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gcc: remove gcc 4.9Gravatar Romain Naour2019-08-041-0/+7
| | | | | | | | | | | | | | | | | | | In order to reduce the number of choice in gcc selection, remove the gcc 4.9 version. This version was kept due to libstdc++ ABI-incompatible changes and other build issues with kernel and bootloader as reported by Arnout [1]. Since then, gcc 4.9 is not supported any more since glibc 2.29 [2] and recent kernel and bootloaders has been fixed to use more recent compiler version. [1] http://lists.busybox.net/pipermail/buildroot/2017-June/194374.html [2] https://www.sourceware.org/ml/libc-alpha/2019-01/msg00723.html Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gdb: remove gdb 7.12.1Gravatar Romain Naour2019-08-021-0/+7
| | | | | | | | | | | | | | | gdb 7.12.1 was released on 21 Jan 2017 [1] and is the last version that doesn't requires a C++11 compiler. Since Buildroot now support three other gdb versions (8.1, 8.2 and 8.3), reduce the number of choice by dropping 7.12.1. Remove BR2_PACKAGE_GDB_NEEDS_CXX11 symbol since it's not useful anymore. [1] https://lists.gnu.org/archive/html/info-gnu/2017-01/msg00009.html Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/x11r7/xapp_mkfontdir: remove packageGravatar Bernd Kuhls2019-06-201-0/+9
| | | | | | | | app_mkfontscale now includes the mkfontdir script: https://lists.x.org/archives/xorg-announce/2019-March/002988.html Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/linux-headers: drop support for 5.x headersGravatar Peter Korsgaard2019-06-201-0/+7
| | | | | | | The 5.0.x series is now EOL and vulnerable to the "TCP SACK PANIC" issue. Drop support for it in linux-headers. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: add legacy entry for 4.20.x headersGravatar Peter Korsgaard2019-06-201-0/+7
| | | | | | | | Commit b3bba8e4254 (package/linux-headers: drop support 4.20 headers) removed the option for 4.20.x kernel headers, but forgot to add a legacy option. Add that now. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gdb: remove gdb 8.0.xGravatar Romain Naour2019-06-061-0/+9
| | | | | | | | | 8.3 is around and 8.2 is the default version, so drop 8.0. Keep 7.12 which is the latest version that doesn't requires C++11 support. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: fix check-package warningsGravatar Thomas Petazzoni2019-06-011-4/+4
| | | | | | | | | | | | | | | Fixes the following warnings: Config.in.legacy:153: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:154: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:155: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:156: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) which were introduced in commit 55c642287819a062d52e7f290c76ada778772fba ("arch/csky: remove BR2_CSKY_DSP option") Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch/csky: add support for VDSP extensionsGravatar Guo Ren2019-05-311-1/+3
| | | | | | | | | | | | VDSP is C-SKY enhanced extension instruction set for SIMD, AI and DSP operation. It is supported by abiv2, used by the ck807, ck810, ck860 cores. Signed-off-by: Guo Ren <ren_guo@c-sky.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [Thomas: update help text in Config.in.legacy about the BR2_CSKY_DSP option.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch/csky: remove BR2_CSKY_DSP optionGravatar Guo Ren2019-05-311-0/+7
| | | | | | | | | | The DSP extention is in fact no longer used for C-SKY, nor supported by C-SKY gcc, so we remove it. Signed-off-by: Guo Ren <ren_guo@c-sky.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [Thomas: split from the VDSP patch, add Config.in.legacy] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* Config.in.legacy: fix check-package warningGravatar Arnout Vandecappelle (Essensium/Mind)2019-05-051-1/+1
| | | | | | Order is type, depends, select. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/gstreamer1/gst1-plugins-{base, good, bad, ugly}: bump to 1.16.0Gravatar Adam Duskett2019-05-051-0/+37
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Group these patches because of several changes to the plugin packages. Changes: - Remove upstreamed patches: - 0001-fdkaacenc-Remove-MODE_2_1.patch - 0002-fdkaacdec-Use-WAV-channel-mapping-instead-of-interle.patch - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_COMPOSITOR to Config.in.legacy as this plugin is moved to gst1-plugins-base. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA to Config.in.legacy as this the plugin is now removed. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENCV to Config.in.legacy as the plugin now requires opencv3 with the bgsegm opencv_contrib module, which is not in Buildroot. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_STEREO to Config.in.legacy as this plugin is merged with the audiofx plugin in gst1-plugins-good. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VCD to Config.in.legacy as this plugin is removed. - Remove COPYING.LIB from gst-plugins-base mk file and hash file as it no longer exists. - Add BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_COMPOSITOR to gst1-plugins-base.mk - Add BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OVERLAYCOMPOSITION to gst1-plugins-base. - Add mjpegtools to the dependencies of BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEG2ENC - Remove BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA because it now depends on the package dssim which isn't available in Buildroot. - Remove upstream patch 0001-gstrtspconnection-Security-loophole-making-heap-over.patch Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lunit: remove packageGravatar Francois Perrad2019-04-031-0/+8
| | | | | | | it was replaced by its fork lunitx which supports all versions of Lua. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/ffmpeg: bump to version 4.1.2Gravatar Louis-Paul Cordier2019-03-251-0/+6
| | | | | | | | | | | FFserver is not supported anymore Remove patch 0001: fixed upstream in cae6f806a6367c7760ab6ed059d343d4a8eebd56 Remove patch 0002 to 0004: accepted upstream Signed-off-by: Louis-Paul Cordier <lpdev@cordier.org> [Bernd: bump to 4.1.2] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst1-plugins-bad: add webrtc optionGravatar Peter Seiderer2019-03-181-10/+0
| | | | | | | | | | | - remove old webrtc Config.in.legacy entry introduced by [1] (misnamed webrtc option was introduced with 2017.02, renamed to webrtcdsp for 2017.08 and although backported to 2017.02.4) [1] https://git.buildroot.net/buildroot/commit/?id=4c06d2490a07f0b88f42c56c7409899fd2f5608a Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libump: remove packageGravatar Francois Perrad2019-03-151-0/+7
| | | | | | | This library was previously a part of sunxi-mali. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/sunxi-mali: remove packageGravatar Francois Perrad2019-03-151-0/+9
| | | | | | | The package sunxi-mali-mainline is available for recent kernels. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/binutils: remove version 2.29Gravatar Romain Naour2019-03-141-0/+8
| | | | | | | | We are back with 3 binutils version in Buildroot. Now CFI support is always present for NIOSII. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/binutils: remove version 2.28Gravatar Romain Naour2019-03-141-0/+8
| | | | | Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst-plugins-bad: remove apexsink supportGravatar Fabrice Fontaine2019-03-071-0/+8
| | | | | | | | | | | | apexsink does not build with OpenSSL 1.1.x so remove this option especially because there is no more apexsink option in gstreamer1 (since version 1.12) Fixes: - http://autobuild.buildroot.org/results/a29e8a8509190fc4b3c419dae2301cf72a601f62 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mongodb: new packageGravatar Fabrice Fontaine2019-02-121-6/+0
| | | | | | | | | | | | | | | | | | | | | | | Here is the list of the changes compared to the removed mongodb 3.3.4 version: - Remove patch (not applicable anymore) - Add patch (sent upstream) to fix openssl build with gcc 7 and -fpermissive - Remove 32 bits x86 platforms, removed since version 3.4: https://docs.mongodb.com/manual/installation/#supported-platforms - Change license: since October 2018, license is SSPL: - https://www.mongodb.com/community/licensing - https://jira.mongodb.org/browse/SERVER-38767 - gcc must be at least 5.3 so add a dependency on gcc >= 6 - Add a dependency on host-python-xxx modules: https://github.com/mongodb/mongo/blob/r4.0.6/docs/building.md - Use system versions of boost, pcre, snappy, sqlite, yaml-cpp and zlib instead of embedded mongodb ones - Add hash for license files Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Tested-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mongodb: remove packageGravatar Peter Korsgaard2019-02-071-0/+6
| | | | | | | | | | | | | | | | | | | | | | | | | | Fixes: http://autobuild.buildroot.net/results/dd4/dd412fae45a84e44e7e6a49f8cdb124d0851c1df/ The mongodb version used (3.3.4) is no longer supported by upstream and fails to build with openssl 1.1.1x. On top of that it uses internal copies of boost, pcre and zlib instead of the system ones. Bumping the version to 3.4.19 (which is still supported until September 2019) has been tried, but it: - No longer builds for 32bit ARM - Doesn't build without extra patches, E.G.: https://git.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/mongodb/mongodb/0002-d_state.cpp-Add-missing-dependenncy-on-local_shardin.patch?h=rocko - Doesn't build with the system version of boost (1.69.0) - Also fails to build with openssl-1.1.1x So it looks like mongodb needs to be bumped to the 3.6.x series (which changes the license to the SSPL) - Or simply dropped. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/qt: remove packageGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | | | | | Qt4 has been marked obsolete for close to 1 year, since commit 3538b5fb10 (qt: mark as obsolete) and is no longer supported upstream since December 2015: https://blog.qt.io/blog/2015/05/26/qt-4-8-7-released/ So now finally remove it as the in tree users have been removed. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/qtuio: remove packageGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | The qtuio package uses the obsolete qt4 package, which we are about to remove, so remove qtuio as well. CC: Stephan Hoffmann <sho@relinux.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/pinentry: remove qt4 optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt4 option uses the obsolete qt4 package, which we are about to remove, so remove the pinentry-qt4 option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/poppler: remove qt optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt option uses the obsolete qt4 package, which we are about to remove, so remove the poppler qt option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>