aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
Commit message (Collapse)AuthorAgeFilesLines
* package/libamcodec: remove packageGravatar Bernd Kuhls7 days1-0/+7
| | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/odroid-scripts: remove packageGravatar Bernd Kuhls7 days1-0/+7
| | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/odroid-mali: remove packageGravatar Bernd Kuhls7 days1-0/+7
| | | | | | | | Package is not needed anymore after support for odroid2c was dropped: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/kodi: remove AMLogic supportGravatar Bernd Kuhls7 days1-0/+7
| | | | | | | | | | | Kodi 19 will remove specific support for AMLogic: https://github.com/xbmc/xbmc/pull/16043 Also buildroot dropped support for the odroid2c defconfig: https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gcc: remove version 6.5Gravatar Romain Naour2019-08-041-0/+7
| | | | | | | | | | gcc 9.1 is around, gcc 8.3 is the default version, so drop 6.5 in order to reduce the gcc choice. Keep gcc 5.5 since it still used by beaglebone_qt5_defconfig. Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gcc: remove gcc 4.9Gravatar Romain Naour2019-08-041-0/+7
| | | | | | | | | | | | | | | | | | | In order to reduce the number of choice in gcc selection, remove the gcc 4.9 version. This version was kept due to libstdc++ ABI-incompatible changes and other build issues with kernel and bootloader as reported by Arnout [1]. Since then, gcc 4.9 is not supported any more since glibc 2.29 [2] and recent kernel and bootloaders has been fixed to use more recent compiler version. [1] http://lists.busybox.net/pipermail/buildroot/2017-June/194374.html [2] https://www.sourceware.org/ml/libc-alpha/2019-01/msg00723.html Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gdb: remove gdb 7.12.1Gravatar Romain Naour2019-08-021-0/+7
| | | | | | | | | | | | | | | gdb 7.12.1 was released on 21 Jan 2017 [1] and is the last version that doesn't requires a C++11 compiler. Since Buildroot now support three other gdb versions (8.1, 8.2 and 8.3), reduce the number of choice by dropping 7.12.1. Remove BR2_PACKAGE_GDB_NEEDS_CXX11 symbol since it's not useful anymore. [1] https://lists.gnu.org/archive/html/info-gnu/2017-01/msg00009.html Signed-off-by: Romain Naour <romain.naour@smile.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/x11r7/xapp_mkfontdir: remove packageGravatar Bernd Kuhls2019-06-201-0/+9
| | | | | | | | app_mkfontscale now includes the mkfontdir script: https://lists.x.org/archives/xorg-announce/2019-March/002988.html Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/linux-headers: drop support for 5.x headersGravatar Peter Korsgaard2019-06-201-0/+7
| | | | | | | The 5.0.x series is now EOL and vulnerable to the "TCP SACK PANIC" issue. Drop support for it in linux-headers. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: add legacy entry for 4.20.x headersGravatar Peter Korsgaard2019-06-201-0/+7
| | | | | | | | Commit b3bba8e4254 (package/linux-headers: drop support 4.20 headers) removed the option for 4.20.x kernel headers, but forgot to add a legacy option. Add that now. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gdb: remove gdb 8.0.xGravatar Romain Naour2019-06-061-0/+9
| | | | | | | | | 8.3 is around and 8.2 is the default version, so drop 8.0. Keep 7.12 which is the latest version that doesn't requires C++11 support. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in.legacy: fix check-package warningsGravatar Thomas Petazzoni2019-06-011-4/+4
| | | | | | | | | | | | | | | Fixes the following warnings: Config.in.legacy:153: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:154: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:155: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) Config.in.legacy:156: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in) which were introduced in commit 55c642287819a062d52e7f290c76ada778772fba ("arch/csky: remove BR2_CSKY_DSP option") Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch/csky: add support for VDSP extensionsGravatar Guo Ren2019-05-311-1/+3
| | | | | | | | | | | | VDSP is C-SKY enhanced extension instruction set for SIMD, AI and DSP operation. It is supported by abiv2, used by the ck807, ck810, ck860 cores. Signed-off-by: Guo Ren <ren_guo@c-sky.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [Thomas: update help text in Config.in.legacy about the BR2_CSKY_DSP option.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* arch/csky: remove BR2_CSKY_DSP optionGravatar Guo Ren2019-05-311-0/+7
| | | | | | | | | | The DSP extention is in fact no longer used for C-SKY, nor supported by C-SKY gcc, so we remove it. Signed-off-by: Guo Ren <ren_guo@c-sky.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [Thomas: split from the VDSP patch, add Config.in.legacy] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* Config.in.legacy: fix check-package warningGravatar Arnout Vandecappelle (Essensium/Mind)2019-05-051-1/+1
| | | | | | Order is type, depends, select. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/gstreamer1/gst1-plugins-{base, good, bad, ugly}: bump to 1.16.0Gravatar Adam Duskett2019-05-051-0/+37
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Group these patches because of several changes to the plugin packages. Changes: - Remove upstreamed patches: - 0001-fdkaacenc-Remove-MODE_2_1.patch - 0002-fdkaacdec-Use-WAV-channel-mapping-instead-of-interle.patch - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_COMPOSITOR to Config.in.legacy as this plugin is moved to gst1-plugins-base. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA to Config.in.legacy as this the plugin is now removed. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENCV to Config.in.legacy as the plugin now requires opencv3 with the bgsegm opencv_contrib module, which is not in Buildroot. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_STEREO to Config.in.legacy as this plugin is merged with the audiofx plugin in gst1-plugins-good. - Add BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VCD to Config.in.legacy as this plugin is removed. - Remove COPYING.LIB from gst-plugins-base mk file and hash file as it no longer exists. - Add BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_COMPOSITOR to gst1-plugins-base.mk - Add BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_OVERLAYCOMPOSITION to gst1-plugins-base. - Add mjpegtools to the dependencies of BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPEG2ENC - Remove BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_IQA because it now depends on the package dssim which isn't available in Buildroot. - Remove upstream patch 0001-gstrtspconnection-Security-loophole-making-heap-over.patch Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lunit: remove packageGravatar Francois Perrad2019-04-031-0/+8
| | | | | | | it was replaced by its fork lunitx which supports all versions of Lua. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/ffmpeg: bump to version 4.1.2Gravatar Louis-Paul Cordier2019-03-251-0/+6
| | | | | | | | | | | FFserver is not supported anymore Remove patch 0001: fixed upstream in cae6f806a6367c7760ab6ed059d343d4a8eebd56 Remove patch 0002 to 0004: accepted upstream Signed-off-by: Louis-Paul Cordier <lpdev@cordier.org> [Bernd: bump to 4.1.2] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst1-plugins-bad: add webrtc optionGravatar Peter Seiderer2019-03-181-10/+0
| | | | | | | | | | | - remove old webrtc Config.in.legacy entry introduced by [1] (misnamed webrtc option was introduced with 2017.02, renamed to webrtcdsp for 2017.08 and although backported to 2017.02.4) [1] https://git.buildroot.net/buildroot/commit/?id=4c06d2490a07f0b88f42c56c7409899fd2f5608a Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libump: remove packageGravatar Francois Perrad2019-03-151-0/+7
| | | | | | | This library was previously a part of sunxi-mali. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/sunxi-mali: remove packageGravatar Francois Perrad2019-03-151-0/+9
| | | | | | | The package sunxi-mali-mainline is available for recent kernels. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/binutils: remove version 2.29Gravatar Romain Naour2019-03-141-0/+8
| | | | | | | | We are back with 3 binutils version in Buildroot. Now CFI support is always present for NIOSII. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/binutils: remove version 2.28Gravatar Romain Naour2019-03-141-0/+8
| | | | | Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/gst-plugins-bad: remove apexsink supportGravatar Fabrice Fontaine2019-03-071-0/+8
| | | | | | | | | | | | apexsink does not build with OpenSSL 1.1.x so remove this option especially because there is no more apexsink option in gstreamer1 (since version 1.12) Fixes: - http://autobuild.buildroot.org/results/a29e8a8509190fc4b3c419dae2301cf72a601f62 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/mongodb: new packageGravatar Fabrice Fontaine2019-02-121-6/+0
| | | | | | | | | | | | | | | | | | | | | | | Here is the list of the changes compared to the removed mongodb 3.3.4 version: - Remove patch (not applicable anymore) - Add patch (sent upstream) to fix openssl build with gcc 7 and -fpermissive - Remove 32 bits x86 platforms, removed since version 3.4: https://docs.mongodb.com/manual/installation/#supported-platforms - Change license: since October 2018, license is SSPL: - https://www.mongodb.com/community/licensing - https://jira.mongodb.org/browse/SERVER-38767 - gcc must be at least 5.3 so add a dependency on gcc >= 6 - Add a dependency on host-python-xxx modules: https://github.com/mongodb/mongo/blob/r4.0.6/docs/building.md - Use system versions of boost, pcre, snappy, sqlite, yaml-cpp and zlib instead of embedded mongodb ones - Add hash for license files Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Tested-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mongodb: remove packageGravatar Peter Korsgaard2019-02-071-0/+6
| | | | | | | | | | | | | | | | | | | | | | | | | | Fixes: http://autobuild.buildroot.net/results/dd4/dd412fae45a84e44e7e6a49f8cdb124d0851c1df/ The mongodb version used (3.3.4) is no longer supported by upstream and fails to build with openssl 1.1.1x. On top of that it uses internal copies of boost, pcre and zlib instead of the system ones. Bumping the version to 3.4.19 (which is still supported until September 2019) has been tried, but it: - No longer builds for 32bit ARM - Doesn't build without extra patches, E.G.: https://git.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/mongodb/mongodb/0002-d_state.cpp-Add-missing-dependenncy-on-local_shardin.patch?h=rocko - Doesn't build with the system version of boost (1.69.0) - Also fails to build with openssl-1.1.1x So it looks like mongodb needs to be bumped to the 3.6.x series (which changes the license to the SSPL) - Or simply dropped. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/qt: remove packageGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | | | | | Qt4 has been marked obsolete for close to 1 year, since commit 3538b5fb10 (qt: mark as obsolete) and is no longer supported upstream since December 2015: https://blog.qt.io/blog/2015/05/26/qt-4-8-7-released/ So now finally remove it as the in tree users have been removed. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/qtuio: remove packageGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | The qtuio package uses the obsolete qt4 package, which we are about to remove, so remove qtuio as well. CC: Stephan Hoffmann <sho@relinux.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/pinentry: remove qt4 optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt4 option uses the obsolete qt4 package, which we are about to remove, so remove the pinentry-qt4 option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/poppler: remove qt optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt option uses the obsolete qt4 package, which we are about to remove, so remove the poppler qt option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/opencv3: remove qt backend optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt backend option uses the obsolete qt4 package, which we are about to remove, so remove the qt backend option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/opencv: remove qt backend optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The qt backend option uses the obsolete qt4 package, which we are about to remove, so remove the qt backend option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/amd-catalyst: remove control center optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The control center option uses the obsolete qt4 package, which we are about to remove, so remote the cccle option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/sdl: remove qtopia video driver optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | The qtopia option uses the obsolete qt4 package, which we are about to remove, to remove the qtopia option as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> [Arnout: move the enable-qtopia=no option to the beginning] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/python-pyqt: remove packageGravatar Peter Korsgaard2019-02-061-0/+7
| | | | | | | | | The python-pyqt package uses the obsolete qt4 package, which we are about to remove, so remove python-pyqt as well. CC: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/gnuradio: remove qtgui optionGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | The gr-qtgui option uses python-pyqt/Qt4, which we are about to remove, so remove the option. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/luacrypto: remove packageGravatar Peter Korsgaard2019-02-061-0/+6
| | | | | | | | | | | | | | | | | | | | Fixes: http://autobuild.buildroot.net/results/afd/afdc598b80356a8301d890232466de421f7779d5/ Luacrypto fails to build with openssl 1.1.x. The package has not seen any functional changes since it was added in 2013 and has no reverse dependencies. The upstream repository (https://github.com/starius/luacrypto) explicitly states: this project is deprecated, use luaossl So remove the package. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Reviewed-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/fftw: remove as regular packageGravatar Thomas Petazzoni2019-02-061-0/+35
| | | | | | | | | | | | | fftw is no longer a package: only fftw-single, fftw-double, fftw-long-double and fftw-quad are. fftw.mk only contains some common definitions that are used by the different fftw variants. The old BR2_PACKAGE_FFTW_PRECISION_* options, which are no longer used anywhere, are moved to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/tn5250: remove packageGravatar Peter Korsgaard2019-02-051-0/+6
| | | | | | | | | | | | | | The latest (0.17.4) tn5250 release is from 2008, doesn't build with openssl 1.1.x and was dropped from Debian in 2011 because nobody cared to maintain it: https://packages.qa.debian.org/t/tn5250.html Given all of that, it is unlikely to be used much, so remove it. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/boost: bump to version 1.69.0Gravatar Fabrice Fontaine2019-01-131-0/+8
| | | | | | | | | | - Remove fifth patch (already in version) - Remove BR2_PACKAGE_BOOST_SIGNALS as signals is now removed. Its removal was announced in 1.68 and its deprecation was announced in 1.54. Users are encouraged to use Signals2 instead. Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/linux-headers: drop obsolete 3.2.x / 4.{1, 16, 18}.x versionsGravatar Peter Korsgaard2019-01-031-0/+28
| | | | | | | According to https://www.kernel.org/category/releases.html, these kernel versions are no longer supported, so drop them now that we have added 4.20.x Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* system cfg: remove mkpasswd MD5 format optionGravatar Matt Weber2018-12-151-0/+8
| | | | | | | | | | | | | | | | | | | | As SHA256 is now default, removing weak MD5 option. C libraries now all support the SHA methods. glibc 2.7+ uclibc (bdd8362a88 package/uclibc: defconfig: enable sha-256...) musl 1.1.14+ One issue this would prevent, is a host tool issue with a FIPS enabled system where weak ciphers/methods are disabled. It seems the crypt(3) call is impacted by /proc/sys/crypto/fips_enabled (per crypt(3) man page). It results in mkpasswd returning "(EPERM) crypt failed." Rather then create a Buildroot host dependency check, this patch removes the potential corner case from being selected. Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lua: remove 5.2.x versionGravatar Francois Perrad2018-12-091-0/+9
| | | | | | | | | | | | | | | | | | At this time : - Lua 5.3.5 will be the last one of its serie. - Lua 5.4 is up coming (lua-5.4.0-work2 is already available). - Lua 5.2.4 was released on 2015. For various reasons in the Lua ecosystem, the Lua 5.1 will stay. On BR, Lua 5.3 is the default version since 2016.02. So, the serie which could be removed is the 5.2.x. We could wait some days for other user feedback. Note: see discussion when 5.3.x was introduced : http://lists.busybox.net/pipermail/buildroot/2015-January/117638.html Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/docker-engine: split docker-{cli, engine}, bump to v18.09.0Gravatar Christian Stewart2018-12-031-0/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Docker upstream has split the Docker daemon and CLI into separate codebases: - github.com/docker/engine: daemon, "dockerd" binary - github.com/docker/cli: "docker" command line interface This commit splits the docker-engine package into docker-engine and docker-cli. Conveniently, the Docker project has begun maintaining two separate release-tagged repositories for the CLI and daemon as of v18.06-ce-rc1. Previous versions were tagged in a common "docker-ce" repository which makes compilation awkward for Buildroot, especially due to some limitations in the new Go package infrastructure. Docker repositories "engine" and "cli" recently started tagging releases. Select the latest stable release, v18.09.0. The CLI is no longer automatically included with the engine. Users will need to select BR2_PACKAGE_DOCKER_CLI to produce a both docker and dockerd target binaries. Docker CLI can be statically compiled. This enables usage of the system docker client binary to access the parent daemon API from within containers, where shared libraries are not available. While at it, drop the useless host-go dependency from docker-engine, since it's already added by the golang-package infrastructure. Signed-off-by: Christian Stewart <christian@paral.in> [Thomas: drop the host-go dependency from both docker-cli and docker-engine] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* libnftnl: drop useless BR2_PACKAGE_LIBNFTNL_XMLGravatar Baruch Siach2018-11-191-0/+6
| | | | | | | | | | Commit fa0d1ebff99 (libnftnl: bump to version 1.0.9) removed the mxml dependency. Remove the redundant BR2_PACKAGE_LIBNFTNL_XML config symbol as well. Cc: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* boot/xloader: remove packageGravatar Matt Weber2018-10-261-0/+7
| | | | | | | | | | U-boot has provided SPL support as a viable replacement for the 2nd stage bootloader on TI platforms. The X-loader project hasn't had a commit in the log since 12-05-2011. (https://gitorious.org/x-loader/x-loader) Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/tidsp-binaries: remove packageGravatar Matt Weber2018-10-261-0/+6
| | | | | | | | | | | The suit of TI OMAP3 dsp tools/libraries are being removed as the upstream projects are no longer active. Suggest using Buildroot 2018.02.x LTS if the feature is still required. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/dsp-tools: remove packageGravatar Matt Weber2018-10-261-0/+6
| | | | | | | | | | | | | The suit of TI OMAP3 dsp tools/libraries are being removed as the upstream projects are no longer active. The dsp-tools package used the tidsp-binaries package. Suggest using Buildroot 2018.02.x LTS if the feature is still required. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gst-dsp: remove packageGravatar Matt Weber2018-10-261-0/+6
| | | | | | | | | | | | | The suit of TI OMAP3 dsp tools/libraries are being removed as the upstream projects are no longer active. The gst-dsp package used the tidsp-binaries package. Suggest using Buildroot 2018.02.x LTS if the feature is still required. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/linux-headers: really drop the 4.17 choiceGravatar Yann E. MORIN2018-10-071-0/+7
| | | | | | | | | | | | | | | | | | | | | Currently, the build fails when the kernel headers 4.17 are selected: package/linux-headers/linux-headers.mk:149: *** LINUX_HEADERS_SITE cannot be empty when LINUX_HEADERS_SOURCE is not. Stop. This is caused by an hickup during the last merge of the next branch, where the value for 4.17 got dropped from BR2_DEFAULT_KERNEL_HEADERS, but the choice entry was left in. The correct fix against that hickup would be to restore the 4.17 value. But since 4.17 is no longer maintained, the proper fix is to really drop 4.17 altogether. For good this time! ;-) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>