aboutsummaryrefslogtreecommitdiff
path: root/package/gcc/Config.in.host
Commit message (Expand)AuthorAgeFilesLines
* package/binutils: remove version 2.30Gravatar Romain Naour10 days1-2/+1
* package/gcc: bump to version 7.5.0Gravatar Romain Naour10 days1-1/+1
* toolchain: bump ARC tools to arc-2019.09-rc1Gravatar Evgeniy Didin2019-11-061-1/+1
* toolchain: bump ARC tools to arc-2019.09-eng002Gravatar Evgeniy Didin2019-10-271-3/+3
* package/gcc: properly order properties of BR2_GCC_SUPPORTS_DLANGGravatar Thomas Petazzoni2019-10-251-2/+2
* package/gcc: add support for D languageGravatar Eric Le Bihan2019-10-251-0/+22
* package/gcc: or1k allow gcc 9.2 with uClibc-ngGravatar Romain Naour2019-10-201-3/+0
* Merge branch 'next'Gravatar Peter Korsgaard2019-09-031-3/+3
|\
| * package/glibc: bump to version 2.30Gravatar Romain Naour2019-08-171-2/+2
| * package/gcc: bump to version 9.2.0Gravatar Romain Naour2019-08-151-1/+1
* | package/gcc: allow uclibc only for gcc or1k (5.x)Gravatar Romain Naour2019-08-211-0/+3
* | package/gcc: gcc 9.x for or1k needs binutils >= 2.32Gravatar Romain Naour2019-08-211-0/+3
|/
* package/gcc: remove version 6.5Gravatar Romain Naour2019-08-041-9/+0
* package/gcc: remove gcc 4.9Gravatar Romain Naour2019-08-041-17/+1
* package/gcc: remove libmudflap optionGravatar Romain Naour2019-08-021-16/+0
* package/gcc: drop negative conditions on C-SKY for older versionsGravatar Yann E. MORIN2019-08-011-5/+0
* arch/csky: restrict ck610 to the C-SKY gcc portGravatar Yann E. MORIN2019-08-011-0/+3
* package/gcc: enable gcc 9.1 for ork1 (openrisc)Gravatar Romain Naour2019-07-131-2/+0
* package/gcc: switch to gcc 8.x as the defaultGravatar Romain Naour2019-06-221-1/+1
* arch: add BR2_ARCH_NEEDS_GCC_AT_LEAST_9Gravatar Romain Naour2019-06-221-0/+1
* package/gcc: add support for gcc 9.1Gravatar Romain Naour2019-06-221-0/+10
* toolchain: bump ARC tools to arc-2019.03 releaseGravatar Evgeniy Didin2019-06-191-1/+1
* Merge branch 'next'Gravatar Peter Korsgaard2019-06-021-1/+14
|\
| * package/gcc: add C-SKY specific gcc versionGravatar Guo Ren2019-05-311-0/+13
| * toolchain: bump ARC tools to arc-2019.03-rc1Gravatar Evgeniy Didin2019-05-141-1/+1
* | package/gcc: don't build a toolchain for powerpc with spe ABI with gcc >= 8.xGravatar Romain Naour2019-06-011-0/+3
|/
* package/gcc: select BR2_TOOLCHAIN_HAS_OPENMP if BR2_GCC_ENABLE_OPENMPGravatar Ed Blake2019-03-261-0/+1
* package/glibc: bump to version 2.29Gravatar Romain Naour2019-03-151-4/+2
* package/gcc: bump to version 8.3.0Gravatar Romain Naour2019-02-261-1/+1
* package/gcc: bump to version 6.5.0Gravatar Romain Naour2018-12-081-1/+1
* package/gcc: bump to version 7.4.0Gravatar Romain Naour2018-12-081-1/+1
* toolchain: fix URLs for ARC gcc/binutils/gdbGravatar Evgeniy Didin2018-12-061-1/+1
* toolchain: bumb ARC tools to arc-2018.09 releaseGravatar Evgeniy Didin2018-11-291-1/+1
* toolchain: Bump ARC tools to arc-2018.09-rc2Gravatar Evgeniy Didin2018-11-201-1/+1
* toolchain: Bump ARC tools to arc-2018.09-rc1Gravatar Evgeniy Didin2018-11-181-3/+3
* package/gcc: remove BR2_GCC_SUPPORTS_FINEGRAINEDMTUNEGravatar Thomas Petazzoni2018-10-211-4/+0
* package/gcc: introduce BR2_GCC_SUPPORTS_LIBCILKRTSGravatar Thomas Petazzoni2018-10-211-0/+6
* package/gcc: glibc >= 2.27 needs gcc >= 5 on aarch64Gravatar Romain Naour2018-09-161-0/+2
* package/gcc: bump to version 8.2.0Gravatar Romain Naour2018-07-271-1/+1
* toolchain: bump ARC tools to arc-2018.03 releaseGravatar Evgeniy Didin2018-06-251-1/+1
* package/gcc: switch to gcc 6.x as the defaultGravatar Romain Naour2018-05-301-1/+1
* package/gcc: add support for gcc 8.1.0Gravatar Romain Naour2018-05-301-0/+8
* toolchain: Bump ARC tools to arc-2018.03-rc2Gravatar Evgeniy Didin2018-05-261-1/+1
* toolchain, gcc, gdb, binutils, uclibc: remove Blackfin codeGravatar Thomas Petazzoni2018-04-151-7/+0
* toolchain: Bump ARC tools to arc-2018.03-rc1Gravatar Evgeniy Didin2018-04-121-1/+1
* gcc: or1k: use 20170218 tag instead of branchGravatar Peter Korsgaard2018-02-051-1/+1
* package/gcc: bump 7.x series to 7.3.0Gravatar Romain Naour2018-01-281-1/+1
* gcc: allow the selection of upstream GCC 7.x for ARCGravatar Alexey Brodkin2017-11-291-1/+0
* package/gcc: slight cleanup and reorg in remaining arch dependsGravatar Yann E. MORIN2017-11-241-7/+6
* arch/arm: some variants need different gcc versionsGravatar Yann E. MORIN2017-11-241-5/+0