aboutsummaryrefslogtreecommitdiff
path: root/package/glib-networking
Commit message (Collapse)AuthorAgeFilesLines
* packages: rename FOO_CONF_OPT into FOO_CONF_OPTSGravatar Thomas De Schampheleire2014-10-041-2/+2
| | | | | | | | | | | | To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* glib-networking: add license informationGravatar Gustavo Zacarias2014-07-011-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: drop <PKG>_VERSION_MINOR variableGravatar Jerzy Grzegorek2014-03-171-2/+1
| | | | | | | | Since <PKG>_VARIABLE_MINOR variable in some packages is used only once, so it is unusable. This patch removes it. Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: unification of name <pkg>_VERSION_MINOR variableGravatar Jerzy Grzegorek2013-12-081-2/+2
| | | | | | | | | Currently there are two different names of the minor version variable: <PKG>_MINOR_VERSION and <PKG>_VERSION_MINOR This patch unifies them to <PKG>_VERSION_MINOR Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: unification of name <pkg>_VERSION_MAJOR variableGravatar Jerzy Grzegorek2013-12-081-3/+3
| | | | | | | | | Currently there are two different names of the major version variable: <PKG>_MAJOR_VERSION and <PKG>_VERSION_MAJOR This patch unifies them to <PKG>_VERSION_MAJOR Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libglib2: needs MMU supportGravatar Thomas De Schampheleire2013-11-221-0/+2
| | | | | | | Fixes http://autobuild.buildroot.net/results/2e0/2e032c6e44e10f2912935715741c3680a19b9b51/ Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Config.in files: unify comments of toolchain option dependenciesGravatar Thomas De Schampheleire2013-10-141-1/+1
| | | | | | | | This patch lines up the comments in Config.in files that clarify which toolchain options the package depends on. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* glib-networking: bump to version 2.36.2Gravatar Jerzy Grzegorek2013-10-061-1/+1
| | | | | Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libglib2: needs threadsGravatar Spenser Gilliland2013-07-271-2/+3
| | | | | | | | | | | | | | This commit adds a dependency of the libglib2 package on thread support in the toolchain, since upstream libglib2 doesn't build without thread support. The commit is rather large as it involves propagating the dependency on thread support to all reverse dependencies of the libglib2 package. [Thomas: squash all patches into one, make a few minor fixes, the most important one being to not add comments about MMU requirement when a package doesn't work on !MMU platforms.] Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
* libglib2: Bump libglib2 to 2.36.1Gravatar Spenser Gilliland2013-06-081-2/+2
| | | | | | | | This patch bumps libglib2 to version 2.36.1. In addition this bumps glibmm and glib-networking to 2.36.1. Signed-off-by: Spenser Gilliland <spenser at gillilanding.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* Normalize separator size to 80Gravatar Alexandre Belloni2013-06-061-2/+2
| | | | | Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* glib-networking: fix a typo in the .mk fileGravatar Henrique Camargo2013-02-191-2/+2
| | | | | | | The variable GLIB_NETWORKING_MINOR_VERSION had a typo. Signed-off-by: Henrique Camargo <henrique@henriquecamargo.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* glib-networking: fix build failure with gnutls3Gravatar Gustavo Zacarias2012-12-281-0/+7
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* packages: switch to host-pkgconfGravatar Gustavo Zacarias2012-10-291-1/+1
| | | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* Remove all references to libintlGravatar Thomas Petazzoni2012-09-202-2/+1
| | | | | | | | | | | | | | | From now on, packages only need to select the BR2_PACKAGE_GETTEXT option and depend on the 'gettext' package to get the necessary i18n libraries installed on the target. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> [yann.morin.1998@free.fr: remove BR2_PACKAGE_LIBINTL] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> CC: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* all packages: rename XXXTARGETS to xxx-packageGravatar Arnout Vandecappelle (Essensium/Mind)2012-07-171-1/+1
| | | | | | | | | | | | | Also remove the redundant $(call ...). This is a purely mechanical change, performed with find package linux toolchain boot -name \*.mk | \ xargs sed -i -e 's/$(eval $(call GENTARGETS))/$(eval $(generic-package))/' \ -e 's/$(eval $(call AUTOTARGETS))/$(eval $(autotools-package))/' \ -e 's/$(eval $(call CMAKETARGETS))/$(eval $(cmake-package))/' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* glib-networking: add missing host-intltool dependencyGravatar Thomas Petazzoni2012-03-191-1/+5
| | | | | | | | | | | | | Fixes the following problem: checking whether NLS is requested... yes checking for intltool >= 0.35.0... ./configure: line 12323: intltool-update: command not found found configure: error: Your intltool is too old. You need intltool 0.35.0 or later. make: *** [/home/test/test/output/build/glib-networking-2.30.2/.stamp_configured] Error 1 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* glib-networking: fix build without gnutlsGravatar Peter Korsgaard2012-03-041-1/+3
| | | | | | | configure errors out when it doesn't find gnutls unless explicitly disabled. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* glib-networking: new packageGravatar Sven Neumann2012-02-282-0/+33
glib-networking provides network-related GIO modules for glib. It is used by newer versions of libsoup to implement SSL/TLS support. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>