aboutsummaryrefslogtreecommitdiff
path: root/package/libgtk2/Config.in
Commit message (Collapse)AuthorAgeFilesLines
* libgtk2: bump to version 2.22.0 and undeprecate Gtk/DirectFBGravatar Thomas Petazzoni2010-10-181-6/+2
| | | | | | | | | | | | | | | | | | | | | | | Finally, we bump Gtk from the old and ancient 2.12 version to the latest 2.22.0 version currently available. The DirectFB support is Gtk 2.22 compiles again thanks to the work of Lionel Landwerlin (it was broken in every Gtk version between 2.12 and 2.20). Therefore, Gtk on DirectFB is no longer marked as deprecated. In addition to this, we : * Upgrade the "reduce-dependencies" patch * Remove the "configure" and "no-tests" patches which do not seem to be useful anymore * Add a libtool patch We also remove references to a non-existant 2.15 gtk version in libgtk2.mk. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: add gdk-pixbuf package (splitted out from GTK+)Gravatar Thomas Petazzoni2010-10-181-0/+1
| | | | Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
* pango: needs C++ for freetype handlingGravatar Peter Korsgaard2010-08-301-2/+3
| | | | | | | | | Pango was recently updated to v1.28 as a dependency of webkit, but its freetype support has unfortunately been rewritten with parts in C++ (since pango 1.25), so adjust dependencies of pango and users of it to require C++ support. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libgtk2: mark DirectFB backend as deprecatedGravatar Thomas Petazzoni2010-07-281-1/+6
| | | | | | | | | libgtk2 on DirectFB is deprecated because it is no longer supported in recent versions of Gtk. We will remove support for Gtk over DirectFB in the next Buildroot version unless support for DirectFB in mainline Gtk is improved in the mean time. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: gettext needs WCHAR supportGravatar Peter Korsgaard2010-05-251-0/+4
| | | | | | | | gettext needs WCHAR support in the toolchain, and as libglib2 depends on gettext and lots of stuff depends on libglib2, quite a lot of packages needs to have their dependencies adjusted. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xorg: simplify dependencies on X.orgGravatar Thomas Petazzoni2009-07-171-1/+1
| | | | | | | | | | | | | | Many packages used to depend on BR2_PACKAGE_XORG||BR2_PACKAGE_XORG7, but this is useless since BR2_PACKAGE_XORG is a non-existing configuration option. So, these depencies gets simplified to BR2_PACKAGE_XORG7 only. Some others were depending on BR2_PACKAGE_TINYX (which doesn't) exist or BR2_PACKAGE_XSERVER_xorg || BR2_PACKAGE_XSERVER_tiny || BR2_PACKAGE_XSERVER_x11r7. Replace all that mess by a simple dependency on BR2_PACKAGE_XORG7. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* pkgconfig: add pkgconfig package for targetGravatar Peter Korsgaard2009-03-181-1/+0
| | | | | | | | | | | | | The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
* cairo: more fine grained configutation and fix dependenciesGravatar Peter Korsgaard2009-03-121-0/+2
|
* libgtk: don't list cups/png/jpeg/tiff as hard dependenciesGravatar Peter Korsgaard2008-12-261-4/+0
| | | | | | GTK can be compiled without the above, so don't list them as hard dependencies, and simply adjust the build depending on what the user has enabled.
* select CUPS if XORG/XORG7/TINYX.Gravatar Daniel Laird2008-08-261-0/+1
| | | | | | | | | | This makes the behaviour the same as before for X users. Although is CUPS a necessary dependancy? Daniel Laird
* The changes below add better support for DirectFB and libgtk2.Gravatar Daniel Laird2008-08-261-2/+1
| | | | | | | | | | | | | | | | | | | | | | | Should be no different for X builds. Config.in | 3 +-- libgtk2.mk | 7 +++---- 2 files changed, 4 insertions(+), 6 deletions(-) Signed-off-by: daniel.j.laird@nxp.com package/libgtk2/Config.in Allow DirectFB to turn on LIBGTK2 support without X being enabled. Disable autoselection of cups. May not be wanted (Can cause crosscompilation issues). package/libgtk2/libgtk2.mk Remove unnessary redefine of PKG_CONFIG_* Pass $(DISABLE_LARGEFILE) to configure (supports large file or not) Move 'cups' to X extra dependencies instead of general.
* Kconfig: remove 'default n'Gravatar Peter Korsgaard2008-07-171-1/+0
| | | | 'default n' is the default, so there's no need to say it explicitly.
* Remove duplicated select LIBPNG and use alphabetical order for selectsGravatar Ulf Samuelsson2008-07-071-6/+5
|
* packages: fix pkgconfig depencies and select pkgconfig where neededGravatar Peter Korsgaard2008-06-141-0/+1
|
* updated libgtk2Gravatar John Voltz2008-03-061-0/+3
|
* Reintroduce dependencies on tinyx for libgtk[1]2 and cairoGravatar Ulf Samuelsson2007-08-111-1/+1
|
* Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn'tGravatar Eric Andersen2007-08-101-1/+1
| | | | | | quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
* PNG package is called BR2_PACKAGE_LIBPNGGravatar Peter Korsgaard2007-01-171-1/+1
|
* select XORG rather than depend on it.Gravatar Eric Andersen2007-01-171-1/+1
|
* add Gtk+ version 2Gravatar Eric Andersen2007-01-111-0/+14