aboutsummaryrefslogtreecommitdiff
path: root/package/lua
Commit message (Collapse)AuthorAgeFilesLines
* package/lua: allow host-lua to find installed modulesGravatar Francois Perrad2020-04-121-0/+5
| | | | | | | | We need to set LUA_ROOT to allow the host-lua interpreter to find installed modules. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/lua: allow to load native modules from host-luaGravatar Francois Perrad2020-04-121-1/+4
| | | | | | | | | | | | | | | In order to allow the host Lua interpreter to load native modules, we need to enable building liblua.so, by switching from BUILDMODE=static to BUILDMODE=dynamic. In addition, since some modules need Lua 5.2 functions, we build the host Lua interpreter with -DLUA_COMPAT_5_2, when the Lua interpreter version is 5.3. Note that we are testing the target option BR2_PACKAGE_LUA_5_3, but this is OK: the host and target Lua interpreters have the same version. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/l*: add license file hashesGravatar Heiko Thiery2020-02-031-0/+2
| | | | | Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/lua: remove 5.2.x versionGravatar Francois Perrad2018-12-096-137/+1
| | | | | | | | | | | | | | | | | | At this time : - Lua 5.3.5 will be the last one of its serie. - Lua 5.4 is up coming (lua-5.4.0-work2 is already available). - Lua 5.2.4 was released on 2015. For various reasons in the Lua ecosystem, the Lua 5.1 will stay. On BR, Lua 5.3 is the default version since 2016.02. So, the serie which could be removed is the 5.2.x. We could wait some days for other user feedback. Note: see discussion when 5.3.x was introduced : http://lists.busybox.net/pipermail/buildroot/2015-January/117638.html Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* lua: fix dynamic library installGravatar Fabrice Fontaine2018-10-011-0/+31
| | | | | | | | | | | | | | | | | | | | | | | | In 0002-shared-libs-for-lua.patch, revision number is used to set library name: TO_SOLIB = liblua.so.$(R) However, library is built using PKG_VERSION which is passed only during build step: $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $? As a result, dynamic library is not installed in staging or target paths since bump to lua 5.3.5 So, instead of replacing R by PKG_VERSION and passing this variable in all steps, simply update R to 5 Fixes: - http://autobuild.buildroot.net/results/28b6672188bb0082ac1467d3b45904880e3634f3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Acked-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Fabrice Fontaine &lt;<a href="mailto:fontaine.fabrice@gmail.com" target="_blank">fontaine.fabrice@gmail.com</a>&gt;<br></blockquote><div><br></div><div>Acked-by: Francois Perrad &lt;<a href="mailto:francois.perrad@gadz.org" target="_blank">francois.perrad@gadz.org</a>&gt;</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: bump to version 5.3.5Gravatar Francois Perrad2018-07-105-3/+3
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: always use host-lua for host-luainterpreterGravatar Peter Korsgaard2018-03-311-3/+3
| | | | | | | | | | | | | | | | | | Similar to how we do for openssl. host-luainterpreter is only used by the luarocks infrastructure, and there is afaik no specific reason why the host lua variant must match the target one. Luajit only supports a limited number of architectures, so building it for the host limits the architectures Buildroot can be used on (E.G. powerpc64 autobuilders). To fix this, always use host-lua. Slightly rework lua.mk to ensure host-lua-5.1 is used when luajit is selected, and drop the logic for using host-luajit. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* lua: refactor with a common template lua.pc.inGravatar Francois Perrad2017-10-124-90/+34
| | | | | | | | lua.pc is generated from a common template in the build step. install steps are restored like in BR 2017.05 Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: ensure pkgconfig directory exists before installing filesGravatar Thomas Petazzoni2017-08-141-0/+2
| | | | | | | | | | | | | | | | The lua staging and host installation commands generate a file in usr/lib/pkgconfig, without first making sure that this directory exists, which causes build failures if it doesn't. This commit adjusts those installation commands to create this directory if needed. Fixes: http://autobuild.buildroot.net/results/101c89e1d6aee942a0b1c4e4f3daf8ac2414a56c/ Based on investigation and initial (more complicated) fix provided by Francois Perrad <francois.perrad@gadz.org>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: fix pkg-config fileGravatar Jörg Krause2017-08-103-6/+10
| | | | | | | | | | | | | | | | | | | When Lua is linked with additional libraries, these libraries should go into the pkg-config file as well. Otherwise, linking swupdate with the lua library fails: ``` /home/buildroot/output/host/arm-buildroot-linux-gnueabihf/sysroot/usr/lib/liblua.so: undefined reference to `dlopen' /home/buildroot/output/host/arm-buildroot-linux-gnueabihf/sysroot/usr/lib/liblua.so: undefined reference to `dlclose' /home/buildroot/output/host/arm-buildroot-linux-gnueabihf/sysroot/usr/lib/liblua.so: undefined reference to `dlerror' /home/buildroot/output/host/arm-buildroot-linux-gnueabihf/sysroot/usr/lib/liblua.so: undefined reference to `dlsym' ``` Fixes http://autobuild.buildroot.net/results/1c3/1c349cc5904868e4def292b9fbfa164828e46156 Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/l*: fix wrapping of Config.in help textGravatar Adam Duskett2017-07-311-1/+2
| | | | | | | | | | | | | | The check-package script when ran gives warnings on text wrapping on all of these Config files. This patch cleans up all warnings related to the text wrapping for the Config files starting with the letter l in the package directory. The appropriate indentation is: <tab><2 spaces><62 chars> See http://nightly.buildroot.org/#writing-rules-config-in for more information. Signed-off-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Globally replace $(HOST_DIR)/usr with $(HOST_DIR)Gravatar Arnout Vandecappelle2017-07-051-1/+1
| | | | | | | | | | | Since things are no longer installed in $(HOST_DIR)/usr, the callers should also not refer to it. This is a mechanical change with git grep -l '\$(HOST_DIR)/usr' | xargs sed -i 's%\$(HOST_DIR)/usr%$(HOST_DIR)%g' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Globally replace $(HOST_DIR)/usr/lib with $(HOST_DIR)/libGravatar Arnout Vandecappelle2017-07-051-1/+1
| | | | | | | | | | | Since things are no longer installed in $(HOST_DIR)/usr, the callers should also not refer to it. This is a mechanical change with git grep -l '$(HOST_DIR)/usr/lib' | xargs sed -i 's%$(HOST_DIR)/usr/lib%$(HOST_DIR)/lib%g' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: use target LDFLAGSGravatar Baruch Siach2017-05-111-0/+1
| | | | | | | | | | This adds '-static' to the link command when BR2_STATIC_LIBS=y, making the lua binary really static. Cc: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Acked-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: clean up indentation warnings in Config.in filesGravatar Adam Duskett2017-04-291-6/+6
| | | | | | | | | | The check-package script when ran gives warnings on indentation issues on all of these Config.in files. This patch cleans up warnings related to the indentation of the Config.in files in the package directory Signed-off-by: Adam Duskett <Adamduskett@outlook.com> [Thomas: do not change package/kodi/Config.in and package/x11r7/Config.in.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: bump to version 5.3.4Gravatar Francois Perrad2017-01-307-37/+6
| | | | | | [Peter: drop MESSAGE call] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: use $(HOST_MAKE_ENV) when calling $(MAKE)Gravatar Gustavo Zacarias2016-10-221-2/+2
| | | | | | Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: use $(TARGET_MAKE_ENV) when calling $(MAKE)Gravatar Gustavo Zacarias2016-10-221-3/+3
| | | | | | Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: remove empty host dependencies definitionGravatar Julien Floret2016-07-031-3/+0
| | | | | Signed-off-by: Julien Floret <julien.floret@6wind.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: add upstream patch to fix 5.3.3 loop parserGravatar Francois Perrad2016-06-221-0/+31
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: bump to version 5.3.3Gravatar Francois Perrad2016-06-076-5/+5
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: switch to 5.3.x as default versionGravatar Francois Perrad2016-01-121-1/+1
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: bump to version 5.3.2Gravatar Francois Perrad2015-12-176-8/+6
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: bump to version 5.3.1Gravatar Francois Perrad2015-06-186-8/+8
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: kill pointless text justificationGravatar Gustavo Zacarias2015-04-231-1/+1
| | | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* packages: remove (non-)lfs dependencies and tweaksGravatar Gustavo Zacarias2015-04-011-4/+0
| | | | | | | | Now that largefile is mandatory removes package dependencies and conditionals. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* packages: indentation cleanupGravatar Jerzy Grzegorek2015-03-311-13/+13
| | | | | | | This commit doesn't touch infra packages. Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: bump to version 5.2.4Gravatar Francois Perrad2015-03-087-22/+3
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: add missing hash for lua 5.3.0Gravatar Francois Perrad2015-02-021-0/+3
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: add option 32bitsGravatar Francois Perrad2015-02-022-0/+19
| | | | | | [Peter: tweak config/help text] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: add 5.3.x serieGravatar Francois Perrad2015-02-026-3/+177
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: add a upstream patchGravatar Francois Perrad2015-01-101-0/+19
| | | | | | | [Thomas: fix minor typo in commit title.] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: rename patches to the new conventionGravatar Francois Perrad2014-12-248-0/+0
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBSGravatar Thomas Petazzoni2014-12-111-1/+1
| | | | | | | | | | | | | | | | | | | | | | | Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* lua: add hashGravatar Francois Perrad2014-09-191-0/+6
| | | | | | [Peter: fixup hash file syntax] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: fix license path for lua 5.2Gravatar Frank Hunleth2014-09-131-0/+4
| | | | | | | | | The file containing the license for lua 5.1 was removed and the license text was added to the readme in 5.2. [Peter: swap 5.1/5.2 logic] Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* host-lua: compat mode not longer needed by the newest luarocksGravatar Francois Perrad2014-09-061-4/+0
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: make providers declare what they provideGravatar Yann E. MORIN2014-05-211-0/+2
| | | | | | | | | | | | | | | Fixes: http://autobuild.buildroot.org/results/285/2851069d6964aa46d26b4aabe7d84e8c0c6c72ce http://autobuild.buildroot.net/results/9b7/9b7870354d70e27e42d3d9c1f131ab54706bf20e [...] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lua: rename config optionsGravatar Yann E. MORIN2014-04-052-7/+7
| | | | | | | | | | | | | | | | | | | Package's options should be named after the package. Lua is an interpreter, but the package is named 'lua'. So we want to name the config option with '_LUA_', not with '_LUA_INTERPRETER_' Besides, naming them with '_LUA_INTERPRETER_' might be confusing, since there is a package named 'luainterpreter'. Since the renamed options are part of a choice, we can't use the legacy options to select the new ones. So we instead instruct the user to go select the appropriate option in the choice. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Francois Perrad <fperrad@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/luainterpreter: rename the _HAS and _PROVIDES variablesGravatar Yann E. MORIN2014-04-051-2/+2
| | | | | | | | | | | | | | | | | | The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch luainterpreter to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Francois Perrad <fperrad@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* lua: handles BR2_PREFER_STATIC_LIBGravatar Francois Perrad2014-02-263-20/+41
| | | | | | | | | fix compilation with Blackfin FLAT see http://autobuild.buildroot.net/results/b41/b4146bf821d59f694546f6e3a341394cc8fa43ce/ Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: refactor install stepsGravatar Francois Perrad2014-02-263-27/+47
| | | | | | | | since the comeback of version in module path (see commit ccd68a51) the upstream Makefiles are usable for install. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: remove LUA_INSTALLED_FILESGravatar Francois Perrad2014-02-261-11/+0
| | | | | | | | Useless since the uninstall commands were removed in eb7bd9ef Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: add an upstream patchGravatar Francois Perrad2014-01-211-0/+46
| | | | | | | from http://www.lua.org/bugs.html Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: choice between 5.1.x & 5.2.xGravatar Francois Perrad2014-01-219-1/+167
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua*: restore version in module pathsGravatar Francois Perrad2014-01-131-17/+4
| | | | | | | | (like in upstream) Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* luainterpreter: create virtual packageGravatar Francois Perrad2014-01-131-0/+4
| | | | | | | | | | | | | | | | This patch introduces the luainterpreter virtual package, which is provided either by 'lua' or by 'lua-jit'. Packages that require a Lua interpreter can then depend on BR2_PACKAGE_LUAINTERPRETER (in their Config.in) and luainterpreter (in their .mk). Signed-off-by: Francois Perrad <francois.perrad@gadz.org> [yann.morin.1998@free.fr: switch to package-defined providers, apply Thomas' comments] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lua: remove a too invasive patchGravatar Francois Perrad2013-12-251-97/+0
| | | | | | | | | | the static version of luac is enough Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* packages: remove package clean commandsGravatar Thomas De Schampheleire2013-12-081-8/+0
| | | | | Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: remove uninstall commandsGravatar Thomas De Schampheleire2013-12-061-18/+0
| | | | | Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>