aboutsummaryrefslogtreecommitdiff
path: root/package/metacity
Commit message (Collapse)AuthorAgeFilesLines
* package: indentation cleanupGravatar Jerzy Grzegorek2014-12-241-4/+7
| | | | | Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libxml-parser-perl: restore it like before perl infraGravatar Francois Perrad2014-10-171-1/+1
| | | | | | | | | intltool uses this package, and we don't want that it depends on host-perl, but on system perl Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: rename FOO_CONF_OPT into FOO_CONF_OPTSGravatar Thomas De Schampheleire2014-10-041-1/+1
| | | | | | | | | | | | To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* packages: no longer pass --disable-dependency-tracking in individual packagesGravatar Thomas Petazzoni2014-08-291-1/+0
| | | | | | | | | Now that --disable-dependency-tracking is passed by the autotools-package infrastructure, there's no longer any reason to pass it in individual packages. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* metacity: add license informationGravatar Gustavo Zacarias2014-06-271-0/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: replace command install by $(INSTALL)Gravatar Maxime Hadjinlian2014-06-081-1/+1
| | | | | | Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: drop <PKG>_VERSION_MINOR variableGravatar Jerzy Grzegorek2014-03-171-2/+1
| | | | | | | | Since <PKG>_VARIABLE_MINOR variable in some packages is used only once, so it is unusable. This patch removes it. Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* host-perl-xml-parser: rename and refactor with perl infrastructureGravatar Francois Perrad2014-02-231-1/+1
| | | | | | | | | | | | | | | | | | Even though libxml-parser-perl had a Config.in file with an option to enable it on the target, this option was hidden by a dependency on BR2_HOST_ONLY. So in practice, it was not possible to enable libxml-parser-perl on the target. This allows us to rename libxml-parser-perl to perl-xml-parser to follow the new naming convention of Perl packages, without having to introduce Config.in.legacy material. In addition to this rename, the package is converted to use the newly introduced Perl package infrastructure. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Normalize separator size to 80Gravatar Alexandre Belloni2013-06-061-2/+2
| | | | | Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* metacity: fix X.org dependenciesGravatar Thomas Petazzoni2013-01-122-1/+21
| | | | | | | | | | | | | | | Metacity is a X client application, so there is no reason to depend on the X.org server. Instead, depend on the appropriate X libraries. In addition to the X.org related dependencies, we also add the host-libxml-parser-perl dependency, otherwise: checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool make[1]: *** [/home/test/outputs/xorg/build/metacity-2.25.1/.stamp_configured] Error 1 make: *** [all] Error 2 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* metacity: fix link issue against libmGravatar Thomas Petazzoni2012-12-182-0/+96
| | | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* all packages: rename XXXTARGETS to xxx-packageGravatar Arnout Vandecappelle (Essensium/Mind)2012-07-171-1/+1
| | | | | | | | | | | | | Also remove the redundant $(call ...). This is a purely mechanical change, performed with find package linux toolchain boot -name \*.mk | \ xargs sed -i -e 's/$(eval $(call GENTARGETS))/$(eval $(generic-package))/' \ -e 's/$(eval $(call AUTOTARGETS))/$(eval $(autotools-package))/' \ -e 's/$(eval $(call CMAKETARGETS))/$(eval $(cmake-package))/' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: remove useless arguments from AUTOTARGETSGravatar Thomas Petazzoni2011-09-291-1/+1
| | | | | | | | | | Thanks to the pkgparentdir and pkgname functions, we can rewrite the AUTOTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* metacity: fix build, bump versionGravatar Peter Korsgaard2011-02-233-50/+33
| | | | | | | | | Metacity no longer built after libgtk2 was updated, so fix it by bumping the version. We unfortunately cannot move to the latest version, as these have extra dependencies we don't have in BR yet (libcanberra-gtk + gnome-doc-utils). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* metacity: use new style hookGravatar Thomas Petazzoni2010-09-121-4/+6
| | | | Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: don't select libgtk2 as it doesn't know what backend to useGravatar Peter Korsgaard2010-05-251-1/+1
| | | | | | | | libgtk2 can either use the X11 or directfb backend, depending on what is selected - But if other packages 'select' libgtk2 there is no guarantee that any backends are enabled, breaking the build. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* package: Remove unnecessary dependencies on uclibc.Gravatar Will Newton2009-09-031-1/+1
| | | | | | | | A C library will have been built by the toolchain makefiles, so there is no need for packages to explicitly depend on uclibc. Signed-off-by: Will Newton <will.newton@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* xorg: remove the XSERVER variableGravatar Thomas Petazzoni2009-07-241-1/+1
| | | | | | | | | | | | | The XSERVER variable used to be defined by package/Makefile.in because the X server package name was different depending on the type of X server that was choosen. Nowadays, the name of the package is always xserver_xorg-server, so there's no point in having this XSERVER intermediate variable. This patch makes all packages use xserver_xorg-server directly as a dependency, and removes the XSERVER variable from package/Makefile.in. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* xorg: simplify dependencies on X.orgGravatar Thomas Petazzoni2009-07-171-1/+1
| | | | | | | | | | | | | | Many packages used to depend on BR2_PACKAGE_XORG||BR2_PACKAGE_XORG7, but this is useless since BR2_PACKAGE_XORG is a non-existing configuration option. So, these depencies gets simplified to BR2_PACKAGE_XORG7 only. Some others were depending on BR2_PACKAGE_TINYX (which doesn't) exist or BR2_PACKAGE_XSERVER_xorg || BR2_PACKAGE_XSERVER_tiny || BR2_PACKAGE_XSERVER_x11r7. Replace all that mess by a simple dependency on BR2_PACKAGE_XORG7. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* metacity: bump version and convert to Makefile.autotools.in formatGravatar Peter Korsgaard2009-05-062-149/+31
| | | | | | Closes #167. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* libglib2: build host version for build-time binariesGravatar Peter Korsgaard2009-03-161-1/+0
| | | | | Build host version of glib in HOST_DIR and use the build-time binaries from there instead of relying on what is installed on the host.
* metacity: fix target install with tinyxGravatar Peter Korsgaard2009-03-141-1/+1
|
* package/: convert to DOWNLOAD helperGravatar Peter Korsgaard2009-01-161-2/+2
|
* package/: get rid of unneeded $(strip ..)Gravatar Peter Korsgaard2008-12-081-1/+1
|
* package: remove redundant pkg-config variablesGravatar Peter Korsgaard2008-10-261-1/+0
| | | | | | | Also remove some redundant or predefined configure/make args in these packages. Patch by Markus Heidelberg.
* Kconfig: remove 'default n'Gravatar Peter Korsgaard2008-07-171-1/+0
| | | | 'default n' is the default, so there's no need to say it explicitly.
* Use HOST_GLIB for packagesGravatar Ulf Samuelsson2008-07-051-1/+1
|
* fixed metacity makefileGravatar John Voltz2008-03-061-1/+1
|
* - just use the strip binary to avoid confusing libtool (quotes)Gravatar Bernhard Reutner-Fischer2007-10-011-1/+1
| | | | - use $(STRIPCMD) in packages to avoid clashes with $(STRIP)
* - sed -i -e "/;$/s/;$//g" $(egrep ";$" package/* package/*/*.mk toolchain/* ↵Gravatar Bernhard Reutner-Fischer2007-08-211-2/+2
| | | | toolchain/*/*.mk */Makefile.in -l)
* Remove switches if sstrip is runGravatar Ulf Samuelsson2007-08-211-1/+1
|
* Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn'tGravatar Eric Andersen2007-08-101-1/+1
| | | | | | quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
* Use <package>_VERSION in all <package>.mk instead of <package>_VERGravatar Ulf Samuelsson2007-07-111-4/+4
|
* - add endian handling, mmap, memcmp checks to TARGET_CONFIGURE_ARGSGravatar Bernhard Reutner-Fischer2007-06-271-3/+1
| | | | - use TARGET_CONFIGURE_ARGS where appropriate.
* fixup package LDFLAGS handlingGravatar Eric Andersen2007-03-131-0/+1
|
* - the $(XSERVER) target can be provided by different X server impls. Adjust ↵Gravatar Bernhard Reutner-Fischer2007-02-041-1/+1
| | | | | | users - rdesktop needs an xserver impl
* Use stable version 2.16.3, as 2.17.x misplaces topbar icons and whatnot.Gravatar Eric Andersen2007-01-251-5/+19
| | | | download and install the Clearlooks theme
* Add a somewhat basic window managerGravatar Eric Andersen2007-01-155-0/+193