aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5declarative/Config.in
Commit message (Collapse)AuthorAgeFilesLines
* package/{gnuradio|opencv3|python-matplotlib|qt5|qwt|wireshark}: drop ↵Gravatar Peter Seiderer2020-08-131-1/+0
| | | | | | | | | | | redundant BR2_PACKAGE_QT5BASE select Drop redundant BR2_PACKAGE_QT5BASE select as BR2_PACKAGE_QT5 already implies select BR2_PACKAGE_QT5BASE (see package/qt5/Config.in). Signed-off-by: Peter Seiderer <ps.report@gmx.net> Acked-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/qt5/qt5xmlpatterns: enable qml moduleGravatar Peter Seiderer2020-03-151-1/+0
| | | | | | | | | | | | qt5declarative: - remove unneded dependency on qt5mlpatterns qt5xmlpatterns: - add optional dependency on qt5declarative Reported-by: Nimai Mahajan <nimaim@gmail.com> Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/qt5declarative: drop 5.6 supportGravatar Peter Korsgaard2020-02-271-4/+0
| | | | | | And get rid of the 5.12.7 subdir now that the version selection is gone. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: remove Qt Quick dependency on openglGravatar Joshua Henderson2017-12-011-3/+3
| | | | | | | | | | | | | | | | | Qt Quick should no longer depend on opengl, and instead fallback to the limited functionality software renderer as a replacement [1] when not available. [1] http://blog.qt.io/blog/2016/08/15/the-qt-quick-graphics-stack-in-qt-5-8/ Cc: Peter Seiderer <ps.report@gmx.net> Cc: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Joshua Henderson <joshua.henderson@microchip.com> Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com> Tested-by: Peter Seiderer <ps.report@gmx.net> [Thomas: drop qt5declarative patch, since we have bumped to 5.9.3, which contains the patch.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/q*/Config.in: fix ordering of statementsGravatar Adam Duskett2017-05-021-2/+2
| | | | | | | | | | | | | The check-package script when ran gives warnings on ordering issues on all of these Config files. This patch cleans up all warnings related to the ordering in the Config files for packages starting with the letter q in the package directory. The appropriate ordering is: type, default, depends on, select, help See http://nightly.buildroot.org/#_config_files for more information. Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/qt5: add meaningful help texts and package URLsGravatar Zoltan Gyarmati2017-02-091-2/+4
| | | | | Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: update URLs to use Qt's new domainGravatar Fatih Aşıcı2015-02-021-1/+1
| | | | | Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5declarative: add an option for quick moduleGravatar Fatih Aşıcı2014-07-211-6/+11
| | | | | | | With this change, qt5declarative can be built without OpenGL. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libegl: rename the _HAS and _PROVIDES variablesGravatar Yann E. MORIN2014-04-051-2/+2
| | | | | | | | | | | | | | | | | | | The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libegl to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libgles: rename the _HAS and _PROVIDES variablesGravatar Yann E. MORIN2014-04-051-2/+2
| | | | | | | | | | | | | | | | | | | | The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libgles to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Acked-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: use a common option for JavaScriptCore dependenciesGravatar Fatih Aşıcı2013-12-311-10/+2
| | | | | | | | This will be used by other qt packages that contain a copy of JavaScriptCore. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: remove qt5jsbackend packageGravatar Fatih Aşıcı2013-12-251-3/+10
| | | | | | | | | | Upstream did not release a new version of this package since it is superseded by the builtin qml engine found in new qt5declarative. Fixes: http://autobuild.buildroot.net/results/3861aa91e03154c7d20f4157f0c3a1fa14838af1/ Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5declarative: eglfs depends on gui support, so select that as wellGravatar Peter Korsgaard2013-06-271-0/+1
| | | | Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5jsbackend: only available on ARM, x86, x86-64 and mipselGravatar Thomas Petazzoni2013-05-291-1/+3
| | | | | | | | | | | | | | The v8 Javascript virtual machine that is the core of qt5jsbackend is only available on certain architectures. At the moment, only ARM, x86, x86-64 and mipsel are supported. Fixes: http://autobuild.buildroot.org/results/a2e/a2e62e2deaa28ec9d4d957523a00ee0b7a634950/build-end.log [Peter: also add dependency for qt5graphicaleffects] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5/qt5declarative: new packageGravatar Thomas Petazzoni2013-04-111-0/+18
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>