aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5declarative
Commit message (Collapse)AuthorAgeFilesLines
* boot, package: use SPDX short identifier for GPLv3/GPLv3+Gravatar Rahul Bedarkar2017-04-011-2/+2
| | | | | | | | | | | | We want to use SPDX identifier for license string as much as possible. SPDX short identifier for GPLv3/GPLv3+ is GPL-3.0/GPL-3.0+. This change is done using following command. find . -name "*.mk" | xargs sed -ri '/LICENSE( )?[\+:]?=/s/\<GPLv3\>/GPL-3.0/g' Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* boot, linux, package: use SPDX short identifier for GPLv2/GPLv2+Gravatar Rahul Bedarkar2017-04-011-1/+1
| | | | | | | | | | | We want to use SPDX identifier for license strings as much as possible. SPDX short identifier for GPLv2/GPLv2+ is GPL-2.0/GPL-2.0+. This change is done by using following command. find . -name "*.mk" | xargs sed -ri '/LICENSE( )?[\+:]?=/s/\<GPLv2\>/GPL-2.0/g' Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5declarative: build and install examplesGravatar Gaël PORTAY2017-03-181-5/+13
| | | | | | | | | | | This patch builds and installs Qt examples for declarative module. It proceeds the same way as others Qt5 modules. Samples are installed under /usr/lib/qt/examples/qml directory (/usr/lib/qt/examples/quick for quick). Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: Rename version variable to include _PACKAGE_Gravatar Naumann Andreas2017-02-111-1/+1
| | | | | Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/qt5: add meaningful help texts and package URLsGravatar Zoltan Gyarmati2017-02-091-2/+4
| | | | | Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: add choice between version 5.6.2 and 5.8.0Gravatar Naumann Andreas2017-02-072-0/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | For 5.8.0 - add hashes - qt5 need C++11 compliant compiler since 5.7 ([1]) - use different licenses: since version 5.7 Qt removed the LGPL v2.1 option in favor of v3 with a different exception - qt5base: renamed library to EglFSDeviceIntegration ([2]) - qt5base: remove ras-pi patch, commit c0cc5052097c723d0331a7619d686af9eb93d33c fix it ([3]) - qt5base: remove 0007-eglfs-fix-eglfs_mali-compile-for-odroid-mali.patch (upstream committed [3b]) - qt5base: remove obsolete config-option -large ([4]) - qt5base: gstreamer support fully moved to qt5multimedia, so gstreamer related options are no longer passed ([5]) - add patch for python-pyqt5 to fix the build with Qt 5.8 - add tweak in libv4l to fix the build with Qt 5.8, originally provided by Peter Seiderer - add patch from Peter Seiderer fixing a build issue with freetype For 5.6.2 - moved patches to subdir, and renumber patches [1] http://blog.qt.io/blog/2016/06/16/qt-5-7-released/ [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=ec4eb4db61094179bc6a9ec26ec68fb710177053 [3] https://codereview.qt-project.org/#/c/167172/ [3b] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f1b4bd4790860e1ff5afcec111a359bc3a91cfda [4] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=84d3a21c9efe7efb2cce6d3bd14af1f9580b1108 [5] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=7d4da559afb62a779b3d90a65fb679cb5433f203 Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> [Thomas: - tweak commit log about GStreamer related changes, suggested by Arnout - move the gcc 4.8 dependency from the main qt5 option to just the qt5.8 selection, so that qt5.6 can still be built if gcc < 4.8 is used. Noticed by Arnout. - rename the options of the version selection to not include the version number itself so that we don't have to keep legacy symbols. Noticed by Arnout. - introduce changes to qt5quickcontrols2.mk needed to handle qt5.6 vs. qt5.8, borrowed from a later patch in the series. - add patch for python-pyqt5 to fix the build with Qt 5.8. - add fix to libv4l.mk from Peter Seiderer to fix the build with Qt 5.8. - renumber patches for 5.6.2, suggested by Arnout.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.2Gravatar Peter Seiderer2016-10-151-2/+2
| | | | | | | | | | | | | | | - qt5base: remove obsolete '-no-nis' configure parameter ([1]) - qt5base: remove upstream committed patch 0007-Remove-libudev-dependency-from-kms.pro.patch ([2]) - qt5imageformats: remove upstream committed patch 0001-tvOS-support.patch ([3]) [1] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=644d0e75240811212ed9fd0c21e3bd05db3ba5db [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=72492735b7b7770808fcc9fe067e8f03fab827fc [3] https://git.buildroot.net/buildroot/commit/package/qt5?id=9a55b996651fdfbc40e202cb4dd725dce624ca91 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.1-1Gravatar Peter Seiderer2016-06-251-2/+2
| | | | | | | | | | | | | | | | | Removed obsolete patches: - qt5base/0001-Disable-c-standard-compiler-flags-for-the-host-build.patch (upstream committed [1]) - qt5/qt5base/0007-build-with-explicitlib-after-all.patch (upstream committed [2]) - qt5tools/0001-Disable-qdoc-needs-qtdeclarative.patch (fixed upstream by [3]) - qt5webkit/0004-Fix-linking-with-libpthread.patch (upstream committed [4]) [1] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=e69e69519661954716d59bfa5bbd0626515cfda9 [2] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=523c7e3fd55c853dd424d57f28e225d57439cf89 [3] http://code.qt.io/cgit/qt/qttools.git/commit/?id=2b262fad86ef38a5fa692b4c73e6ec26a5d45a5f [4] http://code.qt.io/cgit/qt/qtwebkit.git/commit/?id=5f359baacdf92fabcece83f0a2b30f74c7c02a3c Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: add GPLv3 and GFDLv1.3 licensing informationsGravatar Julien CORJON2016-03-261-2/+2
| | | | | | | | All Qt5 packages gained the GPLv3 license option and all the documentation is now under GFDLv1.3 license (except qt5websocket and qt53d) Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.0Gravatar Julien CORJON2016-03-201-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Remove upstream committed patches (qt5base): - 0001-Force_egl_visual_ID_33.patch (see [1], [2]) - 0003-xcb-egl-fixes.patch (see [3]) - 0005-forkd-disable-eventfd-for-uclibc.patch (see [4], [5]) - 0009-fix-eglfs-for-sunxi-mali.patch (see [6]) - 0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch (see [7]) Remove MX6_WORKAROUND from qt5base.mk since we do not need to tweak EGL visual ID to 33. Remove upstream committed patch (qt5webchannel): - 0001-Fix-builds-without-qml-module.patch (see [8], [9]) Fix Qt5Enginio to 1.6.0 version (see [10]) [1] https://bugreports.qt.io/browse/QTBUG-44290 [2] https://codereview.qt-project.org/#/c/108849/ [3] https://codereview.qt-project.org/#/c/115438/ [4] https://bugreports.qt.io/browse/QTBUG-47337 [5] https://codereview.qt-project.org/#/c/121988/ [6] https://codereview.qt-project.org/#/c/125837/ [7] https://codereview.qt-project.org/#/c/126725/ [8] https://bugreports.qt.io/browse/QTBUG-47360 [9] https://codereview.qt-project.org/#/c/122086/ [10] https://bugreports.qt.io/browse/QTBUG-50111 Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.5.1Gravatar Peter Seiderer2016-02-031-4/+2
| | | | | | | | | | | | | | | | | | Reduce hash lists to strongest only (sha256). Remove upstream committed patches (qt5base): - 0004-no-gold-linker-for-host-build.patch (see [1], [2]) - 0007-big_endian-fix_destformat.patch (see [3]) - 0008-QtGui-force-image-dir-in-include_path.patch (see [4], [5]) [1] https://bugreports.qt.io/browse/QTBUG-46125 [2] https://codereview.qt-project.org/#/c/113563/ [3] https://codereview.qt-project.org/#/c/120654/ [4] https://bugreports.qt.io/browse/QTBUG-47400 [5] https://codereview.qt-project.org/#/c/122145/ Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: remove GPLv2 license from qt5declarative, qt5script and qt5svgGravatar Thomas Petazzoni2015-07-221-2/+2
| | | | | | | | Since Qt 5.5, those three modules have lost their GPLv2 licensing option. Remains the LGPLv2.1 with exception and LGPLv3 as the possible open-source licenses. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.5.0Gravatar Julien CORJON2015-07-211-4/+4
| | | | | | | | | | | | | | | | | | | | | QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES is no longer useful since eglfs does not depend on the device makespecs anymore. Instead, backends are autodetected by configure [1]. We still need specifics include path for rpi eglfs support. 0008-forkd-disable-eventfd-for-uclibc.patch disable missing eventfd in new Qt 3rd party forkd for uClibc toolchains. Remove patches commited in Qt mainline and update pending one [1] https://codereview.qt-project.org/#/c/107548/ Passed test : - Full compilation on ARM/uClibc - Partialy compiled and tested on i.MX6/linaro with OpenGL backend - Partialy compiled but not executed for Raspberry Pi (rpi-userland) Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: update hashes for 5.4.1Gravatar Will Wagner2015-04-021-4/+4
| | | | | | | When updating Qt to 5.4.1 the hash files were omitted Signed-off-by: Will Wagner <will_wagner@carallon.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: update URLs to use Qt's new domainGravatar Fatih Aşıcı2015-02-022-2/+2
| | | | | Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: bump to version 5.4.0Gravatar Fatih Aşıcı2015-02-022-7/+6
| | | | | | | | | | | | | | | | | | | | | | qt5base: - Add patches to fix uClibc build. qt5connectivity: - Add patches to fix build with -no-c++11 qt5declarative: - Remove the line that installs accessible plugin. The functionality is moved into the qtquick library. qt5webkit: - Remove egl patch. This should be fixed with CONFIG += egl option. qt5websockets: - Remove upstreamed patch. Changelogs: https://qt-project.org/wiki/Change-files-in-Qt-5.4.0 Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBSGravatar Thomas Petazzoni2014-12-111-1/+1
| | | | | | | | | | | | | | | | | | | | | | | Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
* qt5: add hashesGravatar Fatih Aşıcı2014-09-261-0/+4
| | | | | Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5declarative: add an option for quick moduleGravatar Fatih Aşıcı2014-07-212-8/+21
| | | | | | | With this change, qt5declarative can be built without OpenGL. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libegl: rename the _HAS and _PROVIDES variablesGravatar Yann E. MORIN2014-04-051-2/+2
| | | | | | | | | | | | | | | | | | | The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libegl to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libgles: rename the _HAS and _PROVIDES variablesGravatar Yann E. MORIN2014-04-051-2/+2
| | | | | | | | | | | | | | | | | | | | The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libgles to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Cc: Samuel Martin <s.martin49@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Acked-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5 packages: set correct PATH when running qmakeGravatar Thomas De Schampheleire2014-03-261-1/+1
| | | | | | | | | | | | | | | | | | The qmake step of qt5 packages may attempt to run pkg-config. If qmake is executed in an environment where the buildroot host directory is not in PATH, pkg-config from the build machine may be used (/usr/bin/pkg-config). This causes qt5 package compilation to fail on machines that do not have pkg-config installed. Refer to mailing list thread [1] for a specific error case. This patch prepends TARGET_MAKE_ENV (which sets PATH) to the qmake call. Reported-by: Marco Trapanese <marcotrapanese@gmail.com> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> [1] http://lists.busybox.net/pipermail/buildroot/2014-March/092283.html Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: use a common option for JavaScriptCore dependenciesGravatar Fatih Aşıcı2013-12-311-10/+2
| | | | | | | | This will be used by other qt packages that contain a copy of JavaScriptCore. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: remove qt5jsbackend packageGravatar Fatih Aşıcı2013-12-252-4/+11
| | | | | | | | | | Upstream did not release a new version of this package since it is superseded by the builtin qml engine found in new qt5declarative. Fixes: http://autobuild.buildroot.net/results/3861aa91e03154c7d20f4157f0c3a1fa14838af1/ Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump to 5.1.1Gravatar Fatih Aşıcı2013-10-261-0/+1
| | | | | | | | | | | | | Following patches are removed since they are upstreamed: - qt5base/qt5base-0001-eglconvenience-add-egl-to-CONFIG-to-get-correct-incl.patch - qt5jsbackend/qt5jsbackend-0002-fix-uclibc.patch Remove "-nomake demos" from configure options since "demos" directory is merged into examples. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Tested-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: remove configure options from module packagesGravatar Fatih Aşıcı2013-10-091-1/+0
| | | | | | | | These packages do not have configure scripts. Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: add _LICENSE_FILES where applicableGravatar Peter Korsgaard2013-06-281-3/+1
| | | | | | | Some (but not all) of the qt5 module tarballs contain license files, so let's reference them. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5declarative: eglfs depends on gui support, so select that as wellGravatar Peter Korsgaard2013-06-271-0/+1
| | | | Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* Normalize separator size to 80Gravatar Alexandre Belloni2013-06-061-2/+2
| | | | | Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5jsbackend: only available on ARM, x86, x86-64 and mipselGravatar Thomas Petazzoni2013-05-291-1/+3
| | | | | | | | | | | | | | The v8 Javascript virtual machine that is the core of qt5jsbackend is only available on certain architectures. At the moment, only ARM, x86, x86-64 and mipsel are supported. Fixes: http://autobuild.buildroot.org/results/a2e/a2e62e2deaa28ec9d4d957523a00ee0b7a634950/build-end.log [Peter: also add dependency for qt5graphicaleffects] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5: factor <pkg>_SITE variableGravatar Thomas Petazzoni2013-04-151-1/+1
| | | | | | | | | | | Each qt5 package was defining its own QT5<something>_SITE variable. Unfortunately, the download location has slightly changed for Qt 5.0.2, so we would have to change it for all packages. Instead, we factor the <pkg>_SITE variable as QT5_SITE in package/qt5/qt5.mk, just like we already do for QT5_VERSION. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
* qt5/qt5declarative: new packageGravatar Thomas Petazzoni2013-04-112-0/+72
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>