aboutsummaryrefslogtreecommitdiff
path: root/package/qt5/qt5sensors/qt5sensors.hash
Commit message (Collapse)AuthorAgeFilesLines
* package/qt5: bump latest version to 5.12.5Gravatar Bernd Kuhls2019-10-071-2/+2
| | | | | | | | | | | | | | | | Removed patches applied upstream: - package/qt5/qt5base/5.12.4/0005-Fix-dependency_libs-entry-of-.la-files.patch https://codereview.qt-project.org/gitweb?p=qt/qtbase.git;a=commitdiff;h=8c0787cfa1a906ebe25907515d86050303b127e7 - package/qt5/qt5multimedia/5.12.4/0001-Fix-compile-issue-when-no-opengl-in-QVideoSurfacePainter.patch https://codereview.qt-project.org/gitweb?p=qt/qtbase.git;a=commitdiff;h=8c0787cfa1a906ebe25907515d86050303b127e7 - package/qt5/qt5serialbus/5.12.4/0001-SocketCAN-Fix-compiler-error-SIOCGSTAMP-was-not-declared.patch https://code.qt.io/cgit/qt/qtserialbus.git/commit/?id=43d746c2c0c87c8694e835f3b052317c8fa02482 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/qt5: bump latest version to 5.12.4Gravatar Peter Seiderer2019-07-111-2/+2
| | | | | | | | | | | | | | | qt5multimedia: - remove 0001-Fix-compile-failure-with-gstreamer-0-10.patch (taken from upstream [1]) qt5webengine: - add one additional license hash (src/3rdparty/chromium/third_party/blink/renderer/build/scripts/license.pyc) [1] https://code.qt.io/cgit/qt/qtmultimedia.git/commit/?id=935967a453b47ae7c8e9ad3d94eef3813eab58db Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/qt5: bump latest version to 5.12.2Gravatar Peter Seiderer2019-03-181-2/+2
| | | | | Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/qt5: bump latest version to 5.12.1Gravatar Peter Seiderer2019-02-231-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | qt5base: - removed 0002-double-conversion-enable-for-aarch64_be.patch (superseded by upstream commits [1] and [2]) - removed 0003-double-conversion-enable-for-or1k.patch (superseded by upstream commits [1] and [2]) - rebased 0004-double-conversion-enable-for-microblaze.patch qt5location: - removed 0001-qdeclarativegeomap-fix-building-with-GCC-5.x.patch (superseded by upstream commit [3]) [1] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=6a39e49a6cdeb28a04a3657bb6a22f848d5dfa9d [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=4d40f09a45202dff901d4f970a6a7e939797138b [3] https://code.qt.io/cgit/qt/qtlocation.git/commit/?id=7bafbdc91f83165710ed74639b76b48b4494937a Signed-off-by: Peter Seiderer <ps.report@gmx.net> [Thomas: - update chromium-latest.inc with the list of license files that match qt5webengine 5.12.1 - drop patch in qt5location that has been upstreamed and therefore no longer applies to 5.12.1] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Reviewed-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* qt5: bump latest version to 5.11.3Gravatar Peter Seiderer2018-12-081-2/+2
| | | | | | | | | qt5base: remove 0005-Export-qt_open64-from-QtCore.patch (taken from upstream [1]) [1] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=4fc4f7b0ce0e6ee186a7d7fe9b5dd20e94efe432 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: bump latest version to 5.11.2Gravatar Peter Seiderer2018-09-301-2/+2
| | | | | | | | | | | | - qt5canvas3d: update license info - qt5serialbus: update license hash (LICENSE.FDL editorial change, see [1]) - qt5serialport: update license hash (LICENSE.FDL editorial change, see [2]) [1] https://code.qt.io/cgit/qt/qtserialbus.git/commit/?id=226bd2f84c807b5401a82832dafa48d34966052a [2] https://code.qt.io/cgit/qt/qtserialport.git/commit/?id=e0bd3949c30ce9c1988a6d6a3c0850d16a1fb33a Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: bump latest version to 5.11.1Gravatar Gaël PORTAY2018-07-011-2/+2
| | | | | | | | | | | | | qtwebengine: Remove 0001-Fix-build-with-GCC-8.1.0.patch (upstream since [1]). [1]: https://github.com/qt/qtwebengine/commit/08db7562bf7709122807f151cab710b3fd9d7c19 Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com> Reviewed-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* qt5: bump latest version to 5.11.0Gravatar Gaël PORTAY2018-06-171-2/+2
| | | | | | | | | | | | | | | | | | qtwayland: Remove 0001-Fix-compilation-for-Renesas-R-Car-M3.patch (upstream since [1]). qtwebengine: New 3rd-part 0001-Fix-build-with-GCC-8.1.0.patch (upstream in chromium [2]). [1]: https://github.com/qt/qtwayland/commit/8b204b2c56be5e7c1fd21144ae140c9b865dd86b [2]: https://codereview.qt-project.org/#/c/229160/ Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* qt5: bump latest version to 5.10.1Gravatar Gaël PORTAY2018-04-021-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The tarball filename has changed since 5.10. The module suffix *opensource-src* has changed to *everywhere-src*. I introduced the *QT5_SOURCE_TARBALL_PREFIX* variable to set the right filename according to the Qt version. qtwebengine: Select libnss. It is a requirement[1] because OpenSSL certificate validation[2] and NSS bundle[3] was dropped. Add host-libnss and host-libpng to satisfy new requirement to build an internal host-tool. Set ninja host pkg-config tool using environment variable $GN_PKG_CONFIG_HOST[4]. The build system uses pkg-config to get package data for both host and target architectures. Using the same call to pkg-config for both target and host leads to build mismatches: it tries to link a host-tool using target libraries. qt5base: sqlite plugin now uses sqlite3_column_table_name16() so select BR2_PACKAGE_SQLITE_ENABLE_COLUMN_METADATA to make sure it is available. qt5multimedia: libqgsttools was renamed to libQtMultimediaGstTools. The latter name matches the libQt5Multimedia*.so.* pattern so no additional copy command is needed for it anymore. qt5xmlpatterns: Names of the license files have changed: LICENSE.(L)GPLv3 -> LICENSE.(L)GPL3. The new files in fact already existed in 5.9.4 but the old ones were not removed yet. The new files are slightly different: there used to be a Qt header in front of it which is now removed. Also LICENSE.LGPL3 is rewrapped. qt5location, qt5quickcontrols, qt5serialport: Same license files issue, and for LICENSE.GPLv2 as well. LICENSE.GPL2 has the "How to Apply These Terms to Your New Programs" text appended to it. qt5script: Similar license file issues, but the new license files were not present yet. LICENSE.GPLv21 was removed so there is no longer a license file for the LGPL-2.1-covered Qt code. [1]: https://github.com/qt/qtwebengine/commit/9b449045fbd5fd3b58bcaff6cf0c5878cd6e64eb [2]: https://codereview.chromium.org/2862543003 [3]: https://codereview.chromium.org/1882433002 [4]: https://github.com/qt/qtwebengine/blob/v5.10.1/src/core/config/linux.pri#L111-L125 Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com> [Peter: - fix sqlite plugin support in qt5base; - fix target installation of qt5multimedia ] Signed-off-by: Peter Seiderer <ps.report@gmx.net> [Arnout: - create a local host-pkg-config tool instead of extending pkgconf; - pass the same options to host-pkg-config as we do for other packages; - carry the EGL mesa3d X11 headers patch; - update license file names and hashes ] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* qt5: bump latest version to 5.9.4Gravatar Sébastien Szymanski2018-02-271-2/+2
| | | | | | | | | | | | | | | | | | | | | | qt5connectivity: - removed 0001-Example-heartrate-server-needs-only-core-and-bluetoo.patch (upstream comitted [1]) qt5quickcontrols2: - removed 0001-Example-flatstyle-needs-widgets-module.patch (upstream comitted [2]) qt5webengine: - removed 0002-Load-libEGL-and-libGLES2-symbols-implicitly.patch (upstream comitted, reverted and recomitted [3]) [1] https://codereview.qt-project.org/211810 [2] https://codereview.qt-project.org/212583 [3] https://codereview.qt-project.org/209547 Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: bump latest version to 5.9.3Gravatar Peter Seiderer2017-12-011-2/+2
| | | | | | | | | | | | | | | | | | | | qt5connectivity: - moved 0001-Example-heartrate-server-needs-only-core-and-bluetoo.patch to 5.9.3 qt5declarative: - removed 0001-Fix-no-opengl-builds.patch to 5.9.3 (upstream committed, see [1]) qt5webengine: - keep 0002-Load-libEGL-and-libGLES2-symbols-implicitly.patch (upstream committed, see [2], but reverted afterwards, see [3]) [1] https://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=fa52bb665d6beb77a951c14c8edcba3541850afc [2] https://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=d4c621f6a6b87f2a86069fa393b9f7c4f9e7b9ad [3] https://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=c11c2c8981e647c1eb2c6753ce77d436b92fff87 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump LTS version to 5.6.3Gravatar Peter Seiderer2017-10-211-2/+2
| | | | | | | | | | | | | | | | | | | | | qt5base: - move hash file to 5.6.3 - move 0001-eglfs-rasp-pi-header-inclusion.patch to 5.6.3 - remove 0002-eglfs-fix-eglfs_mali-compile-for-odroid-mali.patch (upstream committed [1]) qt5declarative: - move patches to 5.6.3 qt5quickcontrols2: - move hash file to 5.6.3 qt5webkit: - move patches to 5.6.3 [1] http://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.6&id=f1b4bd4790860e1ff5afcec111a359bc3a91cfda Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump latest version to 5.9.2Gravatar Peter Seiderer2017-10-171-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | qt5base: - removed 0001-Fix-error-attribute-target-crc-is-unknown.patch (upstream committed, see [1]) - removed 0002-examples-fix-compile-without-opengl-support.patch (upstream committed, see [2]) qt5declarative: - removed 0001-Fix-alignment-issue-on-ARMv7.patch (upstream committed, see [3]) - moved 0001-examples-photoviewer-needs-widgets-support.patch to 5.6.2 only (upstream 5.9.2 committed, see [4]) - moved 0002-examples-qquickviewcomparison-and-quickwidget-needs-.patch to 5.6.2 only (similare patch upstream committed, see [5]) qt5location: - removed 0001-Fix-plugins-build-dependency.patch (upstream committed, see [6]) qt5webchannel: - fix webchannel.js installation to target (the locatinon of the file webchannel.js changed from src/webchannel/qwebchannel.js to examples/webchannel/shared/qwebchannel.js, see commit [7]) qt5webengine: - removed 0001-Always-compile-QWebEnginePage-print.patch (upstream committed, see [8]) - keep 0002-Load-libEGL-and-libGLES2-symbols-implicitly.patch (upstream committed, see [9], but reverted afterwards, see [10]) qt5webkit: - fall back to 5.9.1 (no 5.9.2 package provided, see [11] and [12]). [1] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=b7722c251c3a0938c7c71fc3da47fdbe920060b7 [2] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=6ce4b680cdde7827a6ed4d00dbeb7e7e91569433 [3] http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=03c2661b1243cc529fc3d8cfa65073f1da420307 [4] http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=452a78d0ac4a1579733a8ab641be24c9b7c0dd96 [5] http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=fa52bb665d6beb77a951c14c8edcba3541850afc [6] http://code.qt.io/cgit/qt/qtlocation.git/commit/?id=3ac051c4549575634cecc706175b019f4ed4c3bf [7] https://code.qt.io/cgit/qt/qtwebchannel.git/commit/?id=e7f150abaa8e81d3e404e9631a49341a7f7623d1 [8] http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=085c2c529473bbe9dd7c8c5698a45053520cc423 [9] http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=d4c621f6a6b87f2a86069fa393b9f7c4f9e7b9ad [10] http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=c11c2c8981e647c1eb2c6753ce77d436b92fff87 [11] https://blog.qt.io/blog/2017/10/06/qt-5-9-2-released/#comment-1200724 [12] https://blog.qt.io/blog/2017/10/06/qt-5-9-2-released/#comment-1200746 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Tested-by: Joshua Henderson <joshua.henderson@microchip.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: add license file hashes for all submodulesGravatar Joshua Henderson2017-10-171-0/+12
| | | | | | | | | | | | | Signed-off-by: Joshua Henderson <joshua.henderson@microchip.com> Reviewed-by: Peter Seiderer <ps.report@gmx.net> ---- Changes v2 --> v3: - use 'Hashes for license files:' instead of repeated 'Hash for license file' (suggested by Thomas Petazzoni) Changes v2: - add reviewed-by and minor commit title change (removed package prefix) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/qt5: bump latest version to 5.9.1Gravatar Joshua Henderson2017-07-201-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Qt 5.9 is a Long Term Support version [1]. Some license file changes are involved, a new dependency on pcre2, and some filename changes. qt5webkit popped back into the picture for 5.9.1 after being absent for 5.9.0 "officially." QT5_SNAPSHOTS_SITE is removed with this commit as it is not used for qtwebkit anymore. This removes the following patches that have been upstreamed for 5.9.1: - qt5base/5.8.0/0001-fix-parallel-builds-with-qt-freetype-system-libpng.patch [2] - qt5base/5.8.0/0002-fix-VNC-platform-plugin-build-on-big-endian-machines.patch [3] - qt5base/5.8.0/0003-QAtomic-pass-explicit-failure-mode-to-std-atomic-com.patch [4] - qt5base/5.8.0/0003-eglfs-fix-x11-header-related-compile-failure.patch [5] - qt5base/5.8.0/0004-examples-fix-compile-without-gui-module.patch [6] - qt5webkit/0003-Exclude-backtrace-API-for-non-glibc-libraries.patch [7] The qt5webkit patches no longer apply to both the LTS and latest version, so they are moved to per-version directories. [1] https://www.qt.io/qt5-9/ [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=4dcfd90e4fd7d4c49138038dbbcbda8794a9fbff [3] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=6f64bfa654fb7e20bb75ec3b0544b81482babb44 [4] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=5cc0de2e084cb887a75b076b82cf470ecdcd4dd3 [5] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=e9a7739e77f79baeb5452189b6d17e63de5b341d [6] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=18d49808db46add078d9d4bcffaac5361d5c7269 [7] https://code.qt.io/cgit/qt/qtwebkit.git/commit/?id=548380af096f8277e460383c81a4ecdf2b77523f Signed-off-by: Joshua Henderson <joshua.henderson@microchip.com> Cc: Julien Corjon <corjon.j@ecagroup.com> Cc: Brent Sink <brents_3@hotmail.com> Cc: Naoki Matsumoto <n-matsumoto@melcoinc.co.jp> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: add choice between version 5.6.2 and 5.8.0Gravatar Naumann Andreas2017-02-071-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | For 5.8.0 - add hashes - qt5 need C++11 compliant compiler since 5.7 ([1]) - use different licenses: since version 5.7 Qt removed the LGPL v2.1 option in favor of v3 with a different exception - qt5base: renamed library to EglFSDeviceIntegration ([2]) - qt5base: remove ras-pi patch, commit c0cc5052097c723d0331a7619d686af9eb93d33c fix it ([3]) - qt5base: remove 0007-eglfs-fix-eglfs_mali-compile-for-odroid-mali.patch (upstream committed [3b]) - qt5base: remove obsolete config-option -large ([4]) - qt5base: gstreamer support fully moved to qt5multimedia, so gstreamer related options are no longer passed ([5]) - add patch for python-pyqt5 to fix the build with Qt 5.8 - add tweak in libv4l to fix the build with Qt 5.8, originally provided by Peter Seiderer - add patch from Peter Seiderer fixing a build issue with freetype For 5.6.2 - moved patches to subdir, and renumber patches [1] http://blog.qt.io/blog/2016/06/16/qt-5-7-released/ [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=ec4eb4db61094179bc6a9ec26ec68fb710177053 [3] https://codereview.qt-project.org/#/c/167172/ [3b] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f1b4bd4790860e1ff5afcec111a359bc3a91cfda [4] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=84d3a21c9efe7efb2cce6d3bd14af1f9580b1108 [5] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=7d4da559afb62a779b3d90a65fb679cb5433f203 Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> [Thomas: - tweak commit log about GStreamer related changes, suggested by Arnout - move the gcc 4.8 dependency from the main qt5 option to just the qt5.8 selection, so that qt5.6 can still be built if gcc < 4.8 is used. Noticed by Arnout. - rename the options of the version selection to not include the version number itself so that we don't have to keep legacy symbols. Noticed by Arnout. - introduce changes to qt5quickcontrols2.mk needed to handle qt5.6 vs. qt5.8, borrowed from a later patch in the series. - add patch for python-pyqt5 to fix the build with Qt 5.8. - add fix to libv4l.mk from Peter Seiderer to fix the build with Qt 5.8. - renumber patches for 5.6.2, suggested by Arnout.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.2Gravatar Peter Seiderer2016-10-151-2/+2
| | | | | | | | | | | | | | | - qt5base: remove obsolete '-no-nis' configure parameter ([1]) - qt5base: remove upstream committed patch 0007-Remove-libudev-dependency-from-kms.pro.patch ([2]) - qt5imageformats: remove upstream committed patch 0001-tvOS-support.patch ([3]) [1] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=644d0e75240811212ed9fd0c21e3bd05db3ba5db [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=72492735b7b7770808fcc9fe067e8f03fab827fc [3] https://git.buildroot.net/buildroot/commit/package/qt5?id=9a55b996651fdfbc40e202cb4dd725dce624ca91 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.1-1Gravatar Peter Seiderer2016-06-251-2/+2
| | | | | | | | | | | | | | | | | Removed obsolete patches: - qt5base/0001-Disable-c-standard-compiler-flags-for-the-host-build.patch (upstream committed [1]) - qt5/qt5base/0007-build-with-explicitlib-after-all.patch (upstream committed [2]) - qt5tools/0001-Disable-qdoc-needs-qtdeclarative.patch (fixed upstream by [3]) - qt5webkit/0004-Fix-linking-with-libpthread.patch (upstream committed [4]) [1] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=e69e69519661954716d59bfa5bbd0626515cfda9 [2] http://code.qt.io/cgit/qt/qtbase.git/commit/?id=523c7e3fd55c853dd424d57f28e225d57439cf89 [3] http://code.qt.io/cgit/qt/qttools.git/commit/?id=2b262fad86ef38a5fa692b4c73e6ec26a5d45a5f [4] http://code.qt.io/cgit/qt/qtwebkit.git/commit/?id=5f359baacdf92fabcece83f0a2b30f74c7c02a3c Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.6.0Gravatar Julien CORJON2016-03-201-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Remove upstream committed patches (qt5base): - 0001-Force_egl_visual_ID_33.patch (see [1], [2]) - 0003-xcb-egl-fixes.patch (see [3]) - 0005-forkd-disable-eventfd-for-uclibc.patch (see [4], [5]) - 0009-fix-eglfs-for-sunxi-mali.patch (see [6]) - 0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch (see [7]) Remove MX6_WORKAROUND from qt5base.mk since we do not need to tweak EGL visual ID to 33. Remove upstream committed patch (qt5webchannel): - 0001-Fix-builds-without-qml-module.patch (see [8], [9]) Fix Qt5Enginio to 1.6.0 version (see [10]) [1] https://bugreports.qt.io/browse/QTBUG-44290 [2] https://codereview.qt-project.org/#/c/108849/ [3] https://codereview.qt-project.org/#/c/115438/ [4] https://bugreports.qt.io/browse/QTBUG-47337 [5] https://codereview.qt-project.org/#/c/121988/ [6] https://codereview.qt-project.org/#/c/125837/ [7] https://codereview.qt-project.org/#/c/126725/ [8] https://bugreports.qt.io/browse/QTBUG-47360 [9] https://codereview.qt-project.org/#/c/122086/ [10] https://bugreports.qt.io/browse/QTBUG-50111 Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.5.1Gravatar Peter Seiderer2016-02-031-4/+2
| | | | | | | | | | | | | | | | | | Reduce hash lists to strongest only (sha256). Remove upstream committed patches (qt5base): - 0004-no-gold-linker-for-host-build.patch (see [1], [2]) - 0007-big_endian-fix_destformat.patch (see [3]) - 0008-QtGui-force-image-dir-in-include_path.patch (see [4], [5]) [1] https://bugreports.qt.io/browse/QTBUG-46125 [2] https://codereview.qt-project.org/#/c/113563/ [3] https://codereview.qt-project.org/#/c/120654/ [4] https://bugreports.qt.io/browse/QTBUG-47400 [5] https://codereview.qt-project.org/#/c/122145/ Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: bump version to 5.5.0Gravatar Julien CORJON2015-07-211-4/+4
| | | | | | | | | | | | | | | | | | | | | QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES is no longer useful since eglfs does not depend on the device makespecs anymore. Instead, backends are autodetected by configure [1]. We still need specifics include path for rpi eglfs support. 0008-forkd-disable-eventfd-for-uclibc.patch disable missing eventfd in new Qt 3rd party forkd for uClibc toolchains. Remove patches commited in Qt mainline and update pending one [1] https://codereview.qt-project.org/#/c/107548/ Passed test : - Full compilation on ARM/uClibc - Partialy compiled and tested on i.MX6/linaro with OpenGL backend - Partialy compiled but not executed for Raspberry Pi (rpi-userland) Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* qt5: update hashes for 5.4.1Gravatar Will Wagner2015-04-021-4/+4
| | | | | | | When updating Qt to 5.4.1 the hash files were omitted Signed-off-by: Will Wagner <will_wagner@carallon.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: update URLs to use Qt's new domainGravatar Fatih Aşıcı2015-02-021-1/+1
| | | | | Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: bump to version 5.4.0Gravatar Fatih Aşıcı2015-02-021-4/+4
| | | | | | | | | | | | | | | | | | | | | | qt5base: - Add patches to fix uClibc build. qt5connectivity: - Add patches to fix build with -no-c++11 qt5declarative: - Remove the line that installs accessible plugin. The functionality is moved into the qtquick library. qt5webkit: - Remove egl patch. This should be fixed with CONFIG += egl option. qt5websockets: - Remove upstreamed patch. Changelogs: https://qt-project.org/wiki/Change-files-in-Qt-5.4.0 Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* qt5: add hashesGravatar Fatih Aşıcı2014-09-261-0/+4
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>