aboutsummaryrefslogtreecommitdiff
path: root/package/racehound
Commit message (Collapse)AuthorAgeFilesLines
* boot, linux, package: use SPDX short identifier for GPLv2/GPLv2+Gravatar Rahul Bedarkar2017-04-011-1/+1
| | | | | | | | | | | We want to use SPDX identifier for license strings as much as possible. SPDX short identifier for GPLv2/GPLv2+ is GPL-2.0/GPL-2.0+. This change is done by using following command. find . -name "*.mk" | xargs sed -ri '/LICENSE( )?[\+:]?=/s/\<GPLv2\>/GPL-2.0/g' Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* Replace (e)glibc by glibcGravatar Thomas Petazzoni2016-06-281-1/+1
| | | | | | | | | | | | | | | | Following the removal of eglibc support, this commit replaces all occurences of "(e)glibc" by just "glibc". Most of the occurences are in package Config.in comments. In addition, when the form "an (e)glibc ..." was used, it is replaced by "a glibc ...". [Peter: add new efi* packages, s/uclibc/uClibc as suggested by Romain, systemd / liquid-dsp tweaks as suggested by Yann] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Romain Naour <romain.naour@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/racehound: add hash fileGravatar Yann E. MORIN2016-06-191-0/+2
| | | | | Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/racehound: bump and fix dependenciesGravatar Yann E. MORIN2016-04-132-5/+3
| | | | | | | | | | | | | | | | As pointed out by Arnout, racehound does not require kernel headers 3.14-or-later. So, drop this depenency. It stills require a kernel >= 3.14 to build and run, but we really have no way to express that dependency as Kconfig options. Besides, racehound does not build with kernel 4.5 because the struct modules has been updated. Bump racehound to fix that build failure. Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/racehound: fix commentGravatar Yann E. MORIN2016-04-121-3/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | racehound requires a kernel >= 3.14 to be built and to run. However, the current conditions on the corresponding comments are wrong: - the comment about the kernel has a dependency on the requested headers - the comment on the toolchain features does not have this condition. Thus, the comments are not shown/hidden under the appropriate conditions, like in this situation: - toolchain with headers < 3.14 (e.g. Sourcery CodeBench x86/x86_64 2012.09 with headers 3.5) - kernel 4.5 enabled this comment is shown: racehound needs an Linux kernel >= 3.14 to be built So, this is incorrect, because: 1- a kernel >= 3.14 is indeed to be built 2- the headers version mismatch is not reported Fix that by moving the dependency on the kernel headers to the appropriate comment and enhance it. Since there is no way we can know the kernel version to be built, we can not add such a condition; still, we leave the kernel message as-is. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/racehound: require kernel modules from KconfigGravatar Yann E. MORIN2015-12-292-7/+2
| | | | | | | | And reorder 'select' after 'depends' Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* packages: ensure linux supports modules even when not using kernel-moduleGravatar Yann E. MORIN2015-09-041-0/+6
| | | | | | | | | | | | | | | | | | | | | | Some packages build kernel modules without using the kernel-module infra (because they use custom build systems); they do not automatically get the kernel to support modules which is ensured when using the infra. It must be done manually for all those packages, whenever they are enabled. Note: the nvidia-driver case does not need the ifeq-block other packages use, because it is already enclosed in a more stringent ifeq-block. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: NoƩ Rubinstein <nrubinstein@aldebaran.com> Cc: Jan Viktorin <viktorin@rehivetech.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Jan Viktorin <viktorin@rehivetech.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/elfutils: fix dependency on C libraryGravatar Yann E. MORIN2015-08-091-2/+2
| | | | | | | | | | | | | | | | | | As Thomas puts it: The comment can only be visible when a toolchain that is *not* uclibc and *not* glibc is used. I.e, the comment is now only visible when musl is used. Which is not what we want. Indeed, I completely borked the conditions. When a glibc or uClibc toolchain is selected, the comment is entirely hidden, and we don;t get the extra requirements (wchar, !static). Fix that with the solution proposed by Thomas. Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/elfutils: does not build with muslGravatar Yann E. MORIN2015-08-081-1/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | elfutils uses so many GNUisms in so many places that patching them out is a tedious task which would make us diverge so much from upstream that it would become a nightmare to bump elfutils in the future. Furthermore, elfutils needs argp, which is missing in musl, so it would need argp-standalone too (as when using a uClibc toolchain). Make elfutils depend on either glibc or uClibc. argp-standalone is already required when using a uClibc toolchain, but since we do not support musl, no need to add that to the condition. Fixes (configure failures due to missing argp): http://autobuild.buildroot.org/results/743/7432ccd0d060a70bc35f0ac21ec92ae0071592ae/ http://autobuild.buildroot.org/results/cc9/cc90bd9312f30f91daa50af4253629f58b82c486/ http://autobuild.buildroot.org/results/d5e/d5e583c695afbc2e686e3002765ce9e1937aa0d5/ [...] Fixes (build failures due to GNUisms): http://autobuild.buildroot.org/results/ee7/ee7eaf80247dd96548d66be9884b179e20204a98/ http://autobuild.buildroot.org/results/3f2/3f242853e600bb6bec6ce2f0598d304751ceb81a/ http://autobuild.buildroot.org/results/7f0/7f0c7c9cb746104f93907544247bc1008d6ad0dc/ [...] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* racehound: fix kernel module compileGravatar Peter Seiderer2015-07-263-3/+37
| | | | | | | | | | | | | | | - check for linux kernel >= 3.14 - add cross compile enviornment for linux kernel compile - add additional kernel config hint (CONFIG_KALLSYMS_ALL) - fix kernel module install path [Thomas: - fix Config.in dependency logic for the comment on the kernel version, as noticed by Baruch. - minor improvements in the .mk file.] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* racehound: new packageGravatar Peter Seiderer2015-07-112-0/+52
[Thomas: - indicate in the Config.in help text that CONFIG_KPROBES - add missing final double quote in one of the Config.in comment - normalize the Config.in comment dependencies - bump to the latest Git version.] Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>