aboutsummaryrefslogtreecommitdiff
path: root/package
Commit message (Collapse)AuthorAgeFilesLines
* openssl: security bump to version 1.0.2kGravatar Gustavo Zacarias2017-01-262-3/+3
| | | | | | | | | | Fixes: CVE-2017-3731 - Truncated packet could crash via OOB read. CVE-2017-3732 - BN_mod_exp may produce incorrect results on x86_64 CVE-2016-7055 - Montgomery multiplication may produce incorrect results Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/tor: bump version to 0.2.9.9Gravatar Bernd Kuhls2017-01-263-37/+37
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* graphite2: bump to version 1.3.9Gravatar Gustavo Zacarias2017-01-262-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux-headers: bump 4.{4, 9}.x seriesGravatar Gustavo Zacarias2017-01-261-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* sngrep: new packageGravatar Adam Duskett2017-01-264-0/+54
| | | | | | | | | | | | | | | | | | | | sngrep is a tool for displaying SIP calls message flows from terminal. It supports live capture to display realtime SIP packets and can also be used as PCAP viewer. Signed-off-by: Adam Duskett <aduskett@codeblue.com> [Thomas: - ncurses wide char and other sub-options are not needed to build sngrep, so they are removed, as well as the wchar dependency. ncurses with wchar support is only needed when --enable-unicode is passed, but even then, it doesn't work because the configure script searches <ncursesw/ncurses.h>, so unicode support has been explicitly disabled. - add optional dependencies on OpenSSL, GnuTLS and PCRE. This also makes sure they are explicitly enabled/disabled depending on the configuration. - add upstream URL in Config.in file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-mutagen: new packageGravatar Adam Duskett2017-01-264-0/+38
| | | | | | | | | | | | | | | | | | | | | | | | Mutagen is a Python module to handle audio metadata. It supports ASF, FLAC, MP4, Monkey’s Audio, MP3, Musepack, Ogg Opus, Ogg FLAC, Ogg Speex, Ogg Theora, Ogg Vorbis, True Audio, WavPack, OptimFROG, and AIFF audio files. All versions of ID3v2 are supported, and all standard ID3v2.4 frames are parsed. It can read Xing headers to accurately calculate the bitrate and length of MP3s. ID3 and APEv2 tags can be edited regardless of audio format. It can also manipulate Ogg streams on an individual packet/page level. Mutagen works with Python 2.7, 3.3+ (CPython and PyPy) on Linux, Windows and macOS, and has no dedependencies outside the Python standard library. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: - fix license, it's GPLv2, not LGPLv2+ - rewrap Config.in help text] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/bluez5_utils: Only CLI client depends on !uClibcGravatar Bernd Kuhls2017-01-261-5/+7
| | | | | | | | | | | | | Tested using this minimal defconfig BR2_KERNEL_HEADERS_3_4=y BR2_TOOLCHAIN_BUILDROOT_WCHAR=y BR2_PACKAGE_BLUEZ5_UTILS=y BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL=y BR2_PACKAGE_BLUEZ5_UTILS_TEST=y Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* ucl: Use -std=iso9899:1990 instead of -std=c90Gravatar Alexey Neyman2017-01-261-1/+1
| | | | | | | | The shorter alias, -std=c90, is not known by older versions of GCC. See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=20631. Signed-off-by: Alexey Neyman <stilor@att.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* arch: add OpenRISC architecture supportGravatar Waldemar Brodkorb2017-01-254-7/+21
| | | | | | | | | | | | | | | | | | | Add support for OpenRISC. See here for more details about OpenRISC http://openrisc.io. All buildroot included upstream binutils versions are supported. Gcc support is not upstream, to be able to enable musl C library support later, we use the branch with musl support. At the moment it is possible to build a musl based toolchain, but bootup in Qemu fails. Gdb is only working to debug bare-metal code, there is no support for gdbserver/gdb on Linux, yet. [Peter: drop ?= for GCC_SOURCE] Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Tested-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* micropython-lib: Indicate that pcre is a runtime dependencyGravatar Chris Packham2017-01-252-2/+1
| | | | | | | | libpcre is needed at runtime not a buildtime. Indicate this in Config.in and remove MICROPYTHON_LIB_DEPENDENCIES. Signed-off-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* python-jinja2: bump to version 2.9.4Gravatar Yegor Yefremov2017-01-252-5/+15
| | | | | | | | | | | | | While bumping fix async feature related issue: Both asyncsupport.py and asyncfilters.py use async feature, that is not available in Python 2 and some features available in Python 3.6. So in both cases *.py compilation would produce compiler errors. Hence remove both files after package extraction. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Tested-by: Lionel Flandrin <lionel@svkt.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libgpiod: bump version to v0.1.1Gravatar Bartosz Golaszewski2017-01-253-38/+2
| | | | | | | | | | This is a bug-fix release that addresses the musl libc compatibility issues encountered with buildroot. We can also remove the patch which got merged upstream. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mediastreamer: fix build by bumping to version 2.14.0Gravatar Jörg Krause2017-01-252-2/+10
| | | | | | | | | | | | | | | | | | | | | | | | | The current available version 2.12.1 of mediastreamer does not compile with the latest version 0.27 of oRTP, which was recently updated in Buildroot in [1]. Bump mediastreamer to latest version 2.14.0 to fix the incompatibility: ``` base/msfactory.c:169:3: error: too few arguments to function 'ortp_set_log_level_mask' ortp_set_log_level_mask(ORTP_MESSAGE|ORTP_WARNING|ORTP_ERROR|ORTP_FATAL); ``` Note that we need to fetch a patch from upstream to fix the build with the bctoolbox version 0.4.0. Fixes: http://autobuild.buildroot.net/results/9aa/9aa3cdad6e22ad1656eec59fc92fb7cb79afc4cd/ http://autobuild.buildroot.net/results/09e/09e8fabb72cafa284419f096da95299c51c03899/ http://autobuild.buildroot.net/results/29c/29c8ddd25c76f4c5b74f31a576c7ace9f76677db/ .. and some more. [1] http://patchwork.ozlabs.org/patch/718277/ Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* eudev: drop obsolete --with-firmware-path configure flagGravatar Peter Korsgaard2017-01-251-1/+0
| | | | | | | | | | | | | | | | | | | | | As recently discussed on the list: http://lists.busybox.net/pipermail/buildroot/2017-January/182147.html eudev no longer has legacy user space firmware loading and the --with-firmware-path configure flag since the 3.1.3 release: commit 3b717594600fa717cdf9bcfd0c7c1b703b245482 Author: Kay Sievers <kay@vrfy.org> Date: Mon Sep 1 09:07:49 2014 -0400 udev: remove userspace firmware loading support Signed-off-by: Anthony G. Basile <blueness@gentoo.org> So drop it from EUDEV_CONF_OPTS to limit confusion. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* Revert "tslib: disable raw input plugin under kernel < v3.12"Gravatar Baruch Siach2017-01-251-4/+0
| | | | | | | | | | | This reverts commit 46d6aa520f2490928f27da716356b00da357cc99. Since commit 7c60211ce382 (tslib: needs kernel headers 3.12) BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 is always enabled when building tslib. No need to check for that. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* udpxy: new packageGravatar David Bachelart2017-01-254-0/+34
| | | | | | | | | | | | Signed-off-by: David Bachelart <david.bachelart@bbright.com> [Thomas: - keep only sha256 hash, not needed to have md5 and sha1 when sha256 is provided - add BR2_USE_MMU dependency, since the program uses fork() - remove UDPXY_MAKE_OPTS, and use the appropriate options during the build and install steps directly - use TARGET_MAKE_ENV in the build and install steps] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* policycoreutils: bump version to 2.6Gravatar Adam Duskett2017-01-252-3/+3
| | | | | Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libsepol: bump version to 2.6Gravatar Adam Duskett2017-01-254-21/+3
| | | | | | | | Also removed patch 0003-add-stdarg-include.patch as this has been committed to upstream. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libsemanage: bump version to 2.6Gravatar Adam Duskett2017-01-252-3/+3
| | | | | Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* libselinux: bump version to 2.6Gravatar Adam Duskett2017-01-253-3/+50
| | | | | | | | | This commit also adds a patch that allows libselinux 2.6 to build properly with older compilers such as gcc 4.4. Signed-off-by: Adam Duskett <aduskett@codeblue.com> [Thomas: add patch to fix gcc 4.4 build issue.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* checkpolicy: bump version to 2.6Gravatar Adam Duskett2017-01-252-3/+3
| | | | | Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* ocrad: bump to version 0.25Gravatar Gilles Talis2017-01-252-2/+9
| | | | | | | | Signed-off-by: Gilles Talis <gilles.talis@gmail.com> [Thomas: - fix indentation.] - use $(TAR_OPTIONS) instead of hardcoding -xf.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/lcms2: remove empty variable LCMS2_CONF_OPTSGravatar Bernd Kuhls2017-01-251-2/+0
| | | | | | | | | | | Introduced 2013 with the commit adding this package https://git.buildroot.net/buildroot/commit/package/lcms2?id=901282aa6e330c5e61ab25a83ba68e443cb3aec2 without any notice why it is needed. The package compiles fine without it so let's remove it. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* util-linux: add selinux supportGravatar Matt Weber2017-01-252-0/+16
| | | | | | | | | | | | | | | | | | This patch adds optional libselinux support to the util-linux package, and also tweaks the PAM files instealled by util-linux to work properly in an SELinux context. Like was done for linux-pam, the tweak is done by having the SELinux related lines commented out in the original PAM file, and uncommented when SELinux support is enabled. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* linux-pam: adjust login pam file for SELinuxGravatar Thomas Petazzoni2017-01-252-0/+7
| | | | | | | | | | | | | When SELinux support is enabled, the login pam file installed by linux-pam should be adjusted to use the pam_selinux.so module. To achieve this in a reasonably simple manner, we introduce the SELinux related lines in login.pam as comments, and if SELinux support is enabled, turn those commented lines into real lines. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* jack2: fix NGREG build failuresGravatar Thomas Petazzoni2017-01-252-34/+84
| | | | | | | | | | | | | | | | | | | This commit replaces the patch adding nios2 "support" to jack2 by a more generic approach that solves the NGREG definition problem by using proper checks in the waf script. This allows to remove the architecture-specific compile time conditionals, and will solve build failures on other architectures than just nios2. Fixes: http://autobuild.buildroot.net/results/d15dc78cdd74b51b551512ce1ba88e4d61219e86/ (xtensa) http://autobuild.buildroot.net/results/8244e3fdda52d3f4f24d7199e8855c99a2a7b4b1/ (arc) http://autobuild.buildroot.net/results/badb9ec391f9f0438d593a2768f2f6c6a873c021/ (microblaze) This commit has been built tested with all the external toolchains used in the autobuilders. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* webp: bump to version 0.5.2Gravatar Gilles Talis2017-01-252-2/+2
| | | | | Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package: remove the default value of the $(PKG)_SOURCE variableGravatar Jerzy Grzegorek2017-01-2522-22/+0
| | | | | Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libasplib: fix build error on m68kGravatar Bernd Kuhls2017-01-251-0/+7
| | | | | | | | | | | | | | | Patch written by Waldemar Brodkorb: http://lists.busybox.net/pipermail/buildroot/2016-November/177726.html This patch however did not work: "Unfortunately libasplib cmake infrastructure ignores my CMAKE_CXX_FLAGS." To make this patch work libasplib needed to be bumped because the cmake infrastructure was updated back in August 2016 which fixed the problem: https://github.com/AchimTuran/asplib/commit/6326d1f5e8dad9fd9947b7f4688ddddda91e9e9e Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libasplib: bump versionGravatar Bernd Kuhls2017-01-252-2/+10
| | | | | | | | | | | | | | | | | | | | libasplib now contains modules, we enable only those for the moment which do not need external dependencies. We are not in a hurry to fully support all features of this package because the upcoming Kodi release 17.x-Krypton will not carry any ADSP add-ons: https://github.com/xbmc/repo-binary-addons/commit/db3b767309df25daae4f01f01dba85ca7b3464b0 -DASPLIB_MODULES_TO_BUILD=some looks hackish because the default is to enable all modules: https://github.com/AchimTuran/asplib/blob/master/CMakeLists.txt#L35 But -DASPLIB_MODULES_TO_BUILD=OFF does not disable the build of all modules as well because of https://github.com/AchimTuran/asplib/blob/master/asplib_modules/CMakeLists.txt#L19 so I added "some" as fake value. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* xdriver_xf86-video-sis: use += instead of = for CONF_OPTS assignmentGravatar Thomas Petazzoni2017-01-251-1/+1
| | | | | | | Using += is always a good idea in conditional assignments, as it prevents potential future mistakes if unconditional options are added; Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/x11r7/xdriver_xf86-video-sis: disable DRI support when not availableGravatar Bernd Kuhls2017-01-251-0/+4
| | | | | | | | Fixes http://autobuild.buildroot.net/results/ad8/ad861cb34c15a91e511042d8e47e2c3132cd5898/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libpjsip: drop path to staging to find libsrtpGravatar Yann E. MORIN2017-01-251-1/+1
| | | | | | | | | | | | As it happens, specifying the path where to look for libsrtp is not needed: pjsip does not use the argument to --with-external-srtp as a search path at all; it only checks whether it is 'no' or something else. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libpjsip: disable remaining unspecified optionsGravatar Yann E. MORIN2017-01-251-0/+21
| | | | | | | | | | | | | | | | | There are a bunch of options that are left unspecified; explicitly disable them. The epoll case is special: the configure script is broken, and will enable it whether we pass --enable-epoll or --disable-epoll. But that's OK because we prefer epoll over the alternative (select). So we do not need to fix it. Which is nice becasue the configure.ac is named aconfigure.ac (yes, with a leading 'a'), so it does not autoreconf nicely... :-/ Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/cbootimage: add patch to fix bct_dump crashGravatar Misha Komarovskiy2017-01-251-0/+43
| | | | | | | Patch from upstream until version 1.8 release. Signed-off-by: Misha Komarovskiy <zombah@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-flask-babel: new packageGravatar Lionel Flandrin2017-01-254-0/+30
| | | | | | | | | | | | Flask-Babel is an extension to Flask that adds i18n and l10n support to any Flask application with the help of babel, pytz and speaklater. It has builtin support for date formatting with timezone support as well as a very simple and friendly interface to gettext translations. Signed-off-by: Lionel Flandrin <lionel@svkt.org> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* python-babel: new packageGravatar Lionel Flandrin2017-01-254-0/+26
| | | | | | | | A collection of tools for internationalizing Python applications. Signed-off-by: Lionel Flandrin <lionel@svkt.org> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* janus-gateway: bump to version v0.2.1Gravatar Adam Duskett2017-01-252-2/+2
| | | | | Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* util-linux: bump version to 2.29.1Gravatar Vicente Olivert Riera2017-01-245-271/+2
| | | | | | | | | | | | | 0001-build-sys-prefer-pkg-config-for-ncurses.patch already included: http://git.kernel.org/cgit/utils/util-linux/util-linux.git/commit/?id=3f7429fd2d539c7f948f72bd829404b55ac19d9f 0002-build-sys-cleanup-UL_NCURSES_CHECK.patch already included: http://git.kernel.org/cgit/utils/util-linux/util-linux.git/commit/?id=862326451184bb0fe9c2b2b110fcfc986f9b1734 0003-build-sys-fix-compilation-with-ncurses-and-uClibc-or.patch already included: http://git.kernel.org/cgit/utils/util-linux/util-linux.git/commit/?id=9ea8ded37b648bbd538cbf9c4d144b8b1a93c1b5 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* micropython-lib: bump version to v1.8.6Gravatar Chris Packham2017-01-242-2/+2
| | | | | Signed-off-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* micropython-lib: needs pcreGravatar Chris Packham2017-01-242-0/+2
| | | | | | | | | The micropython libs load libpcre dynamically using the foreign function interface (libffi). Without pcre the build will succeed but at run time anything that uses the 're' module will have issues. Signed-off-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* micropython: bump version to v1.8.7Gravatar Chris Packham2017-01-242-6/+4
| | | | | | | | | The install step now requires CROSS_COMPILE as some C files are generated at install time. Also remove patches that have been applied upstream. Signed-off-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* harfbuzz: bump to version 1.4.2Gravatar Gustavo Zacarias2017-01-242-3/+3
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* samba4: bump to version 4.5.4Gravatar Gustavo Zacarias2017-01-243-11/+25
| | | | | | | | Drop libbsd support, it's problematic and doesn't bring in any greater benefit. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* collectd: bump to version 5.7.1Gravatar Gustavo Zacarias2017-01-242-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* wireshark: security bump to version 2.2.4Gravatar Gustavo Zacarias2017-01-242-3/+3
| | | | | | | | | Fixes: wnpa-sec-2017-01 - The ASTERIX dissector could go into an infinite loop. wnpa-sec-2017-02 - The DHCPv6 dissector could go into a large loop. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* rpm: disable static build supportGravatar James Knight2017-01-241-2/+3
| | | | | | | | | The RPM package requires dynamic linking support (dlfcn.h) for its capabilities related to plugins (and possibly more). The following commit adds a dependency to !BR2_STATIC_LIBS. Signed-off-by: James Knight <james.knight@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* openvpn: bump version to 2.4.0Gravatar Vicente Olivert Riera2017-01-243-14/+2
| | | | | | | | | | | | --enable-password-save option has been removed (https://github.com/OpenVPN/openvpn/commit/9ffd00e7541d83571b9eec087c6b3545ff68441f). Since it now defaults to "enabled" in the upstream package, there is no point in adding Config.in.legacy support for it: Config.in.legacy logic only kicks in when the option is enabled, but the upstream package precisely preserve the compatibility with this situation. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* rng-tools: Fix disabling package on non-x86 architectures.Gravatar Nicolas Cavallari2017-01-241-1/+1
| | | | | | | | | | | | | | | | | Commit 2f89476 ("package/libgpg-error: bump to version 1.23") introduced a BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS which was added as a dependency to all libgpg-error reverse dependencies. However, rng-tools only select libgpg-error if BR2_i386 || BR2_x86_64 (for RDRAND) but the rng-tools dependency was added as BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS && (BR2_i386 || BR2_x86_64), Therefore limiting rng-tools to the x86 architecture. This patch changes it as ..._ARCH_SUPPORT || !(BR2_i386 || BR2_x86_64). Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/terminology: bump to version 1.0.0Gravatar Romain Naour2017-01-242-3/+3
| | | | | | | | Announce: https://sourceforge.net/p/enlightenment/mailman/message/35600707/ Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>