aboutsummaryrefslogtreecommitdiff
path: root/package
Commit message (Collapse)AuthorAgeFilesLines
* zxing-cpp: new package, replacing zxingGravatar Maxime Hadjinlian2015-10-047-76/+59
| | | | | | | | | | | | | | | | | | | | | | | | | ZXing was hosted on Google Code, which is a closing. The current link was already redirecting to the github repo. But upstream is no longer supporting the cpp bindings, it's now a Java library/application. A fork has been created from the latest cpp source of the original upstream. So this commit creates a new package, zxing-cpp, and adds Config.in.legacy handling for the old zxing pakcage that is removed. [Thomas: - add a patch that improves the CMakeLists.txt file to add installation rules. This allows to remove the manual installation logic from zxing-cpp.mk. - make libiconv a normal optional dependency. No need to involve BR2_ENABLE_LOCALE in the condition, since libiconv can only be enabled when !BR2_ENABLE_LOCALE. - bump to the latest upstream version. - add hash file.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/freerdp: needs C++Gravatar Yann E. MORIN2015-10-041-2/+6
| | | | | | | | | | | | FreeRDP does not have a single C++ source file, however it insists on having a C++ compiler. Removing that requirement is a bit too much involving, so we just depend on it... Fixes: http://autobuild.buildroot.org/results/e5b/e5bee760d52e5ee433dcb6c8a7296f99312cfcf4/ Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/freerdp: fix missing defineGravatar Yann E. MORIN2015-10-041-0/+44
| | | | | | | | | | | | | | | | | | | | | | | | | | | | FreeRDP uses CMSPAR, which is defined by glibc in bits/termios.h . glibc has two flavours of bits/termios.h: a genmeric one and an architecture-specific one. When installing, glibc will install the architecture-specific file if it exists, otherwise it installs the generic file. Only Alpha, MIPS, PPC and Sparc have their own bits/termios.h. The generic bits/termios.h, as well as the Alpha, PPC and Sparc flavours do define CMSPAR. However, the MIPS flavour does not define it. We add a patch to FreeRDP that defines CMSPAR to the value from the generic value, which is also the value known to the Linux kernel for MIPS. Fixes: http://autobuild.buildroot.org/results/0b4/0b4793f0bf9f4c57933897f3480054a4e06528ad/ http://autobuild.buildroot.org/results/7a2/7a2284d0a2987158fa2e78f789b07c8c6fcdb974/ http://autobuild.buildroot.org/results/387/3874088c3ccd4bbf76ea0c911ca1ef64c7dc9d1c/ ... Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/iptables: fix build on muslGravatar Brendan Heading2015-10-043-0/+210
| | | | | | | | | | | | | | | Fixes: http://autobuild.buildroot.net/results/68b/68bf8830f87ab32f4fd650c9dd4a8c80592983a9/ http://autobuild.buildroot.net/results/d9b/d9bb677fb5510adf05ffb4afbc63ead83d7e18dd/ http://autobuild.buildroot.net/results/4b8/4b80b6d0131b624301a5cfcd5541897f411043c9/ .. and others. This patch includes two backported patches from iptables git, plus one pending patch not integrated yet. Signed-off-by: Brendan Heading <brendanheading@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* vim: bump to version 7.4.889Gravatar Vicente Olivert Riera2015-10-041-4/+3
| | | | | | | And also move to GitHub since Google Code is going to die soon. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/mesa3d: bump to version 11.0.2Gravatar Bernd Kuhls2015-10-044-6/+6
| | | | | | | | | | | | | | | Mesa3d 10.6.x is reaching end-of-life: http://lists.freedesktop.org/archives/mesa-announce/2015-October/000178.html "NOTE: It is anticipated that 10.6.9 will be the final release in the 10.6 series. Users of 10.6 are encouraged to migrate to the 11.0 series in order to obtain future fixes." Run-time testing with Kodi Isengard on an Intel GPU was positive. Rebased 0001-Fix-khrplatform.h-not-installed-if-EGL-is-disabled.patch. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* host-localdef fails under gcc5Gravatar Stephen Agate2015-10-041-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Building host-localdef fails under gcc5.1 reporting multiple definitions and undefined references: argp-help.o: In function `argp_fmtstream_write': argp-help.c:(.text+0x1dc0): multiple definition of `argp_fmtstream_write' argp-fmtstream.o:argp-fmtstream.c:(.text+0x750): first defined here argp-help.o: In function `argp_fmtstream_puts': argp-help.c:(.text+0x1e10): multiple definition of `argp_fmtstream_puts' argp-fmtstream.o:argp-fmtstream.c:(.text+0x810): first defined here argp-help.o: In function `argp_fmtstream_putc': argp-help.c:(.text+0x1e80): multiple definition of `argp_fmtstream_putc' argp-fmtstream.o:argp-fmtstream.c:(.text+0x7b0): first defined here argp-help.o: In function `argp_fmtstream_set_lmargin': argp-help.c:(.text+0x1ed0): multiple definition of `argp_fmtstream_set_lmargin' argp-fmtstream.o:argp-fmtstream.c:(.text+0x590): first defined here argp-help.o: In function `argp_fmtstream_set_rmargin': argp-help.c:(.text+0x1f00): multiple definition of `argp_fmtstream_set_rmargin' argp-fmtstream.o:argp-fmtstream.c:(.text+0x5c0): first defined here argp-help.o: In function `argp_fmtstream_set_wmargin': argp-help.c:(.text+0x1f30): multiple definition of `argp_fmtstream_set_wmargin' argp-fmtstream.o:argp-fmtstream.c:(.text+0x5f0): first defined here argp-help.o: In function `argp_fmtstream_point': argp-help.c:(.text+0x1f60): multiple definition of `argp_fmtstream_point' argp-fmtstream.o:argp-fmtstream.c:(.text+0x620): first defined here charmap.o: In function `cmlr_open.constprop.2': charmap.c:(.text+0x230a): undefined reference to `charmap_hash' charmap.o: In function `charmap_read': charmap.c:(.text+0x2397): undefined reference to `charmap_hash' locfile.o: In function `locfile_read': locfile.c:(.text+0x2e4): undefined reference to `locfile_hash' locfile.c:(.text+0x8f4): undefined reference to `locfile_hash' locfile.c:(.text+0x9b3): undefined reference to `locfile_hash' locfile.c:(.text+0xa36): undefined reference to `locfile_hash' collect2: error: ld returned 1 exit status Makefile:58: recipe for target 'localedef' failed Ref: http://permalink.gmane.org/gmane.comp.embedded.ptxdist.devel/12950 Signed-off-by: Stephen Agate <stephen.agate@talktalk.net> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Tested-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lz4: adjust homepage URLGravatar Peter Korsgaard2015-10-041-1/+1
| | | | | | Lz4 is no longer developed on google code. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* ibrdtn-tools: fix linking problem when building staticallyGravatar Vicente Olivert Riera2015-10-041-0/+4
| | | | | | | | | | | | | | | | | | The problem looks like this: /br/output/host/usr/mipsel-buildroot-linux-uclibc/sysroot/usr//lib/librt.a(timer_routines.os): In function `__start_helper_thread': timer_routines.c:(.text+0x2f4): undefined reference to `pthread_atfork' collect2: error: ld returned 1 exit status Adding -pthread to LDFLAGS fixes the problem. Fixes: http://autobuild.buildroot.net/results/a87/a87a764d3a28f835ed8645923594f7023a662ae8/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: Replace 'echo -n' by 'printf'Gravatar Maxime Hadjinlian2015-10-0472-176/+176
| | | | | | | | | | | | 'echo -n' is not a POSIX construct (no flag support), we shoud use 'printf', especially in init script. This patch was generated by the following command line: git grep -l 'echo -n' -- `git ls-files | grep -v 'patch'` | xargs sed -i 's/echo -n/printf/' Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/x11r7/xdriver_xf86-video-sis: bump to version 0.10.8Gravatar Bernd Kuhls2015-10-032-2/+5
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/x11r7/libxcb: bump version to 1.11.1Gravatar Bernd Kuhls2015-10-032-3/+3
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/x11r7/xlib_libXi: bump version to 1.7.5Gravatar Bernd Kuhls2015-10-032-3/+3
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/pixman: bump version to 0.32.8Gravatar Bernd Kuhls2015-10-032-3/+3
| | | | | | [Peter: fix .hash comment as pointed out by Vincent] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* linux-headers: bump 4.{1,2}.x seriesGravatar Vicente Olivert Riera2015-10-031-2/+2
| | | | | Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* dovecot: bump to version 2.2.19Gravatar Vicente Olivert Riera2015-10-032-2/+2
| | | | | | Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Acked-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gdb: do not build documentation for bfd and gprofGravatar Vicente Olivert Riera2015-10-031-0/+6
| | | | | | | | | | | | | | Our previous patch to disable the documentation in gdb wasn't complete. There are cases where the documentation under bfd and gprof directories is being built, causing the subsequent failure due to missing makeinfo. This patch fixes that problem. Fixes: http://autobuild.buildroot.org/results/244/2442e697d8a300496434fd42fcb1ee3941d13e06/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libcrossguid: new packageGravatar Bernd Kuhls2015-10-033-0/+44
| | | | | | | | | | Needed by Kodi 16.x-Jarvis: https://github.com/xbmc/xbmc/commit/6f8171f53992fc2eaabf71f6fa47ebed1da0d43d [Peter: needs GCC >= 4.7 for C+11, no need to install in target, Drop TARGET_CONFIGURE_OPTS, add TARGET_CXXFLAGS, wrap long lines] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* xdriver_xf86-video-fbturbo: new packageGravatar Scott Fan2015-10-034-0/+80
| | | | | | | | | | | | | | | Add the fbturbo video driver, which is based on xf86-video-fbdev (with none of the original features stripped), primarily optimized for the devices powered by the Allwinner SoC (A10, A13, A20). https://github.com/ssvb/xf86-video-fbturbo/ Signed-off-by: Scott Fan <fancp2007@gmail.com> [yann.morin.1998@free.fr: strip help text to the basics only] [Peter: needs libdrm/pixman, add patch to drop libdri2 dependency reformat and add optional libpciaccess support] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* gmock: new packageGravatar Carlos Santos2015-10-036-0/+118
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s specifics in mind, Google C++ Mocking Framework (or Google Mock for short) is a library for writing and using C++ mock classes. Google Mock: * lets you create mock classes trivially using simple macros, * supports a rich set of matchers and actions, * handles unordered, partially ordered, or completely ordered expectations, * is extensible by users, and * works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and Symbian. http://code.google.com/p/googlemock/ There are both host and target packages. The target one has include files required to compile the tests and the static libraries required to link/run them. The host package installs gmock_gen, a Python script used to generate code mocks. Notice that GMock 1.7.0 requires the Python 2 host package even if Python 3 is selected as a target package. Signed-off-by: Marcelo Barbosa <marcelo.barbosa@datacom.ind.br> Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* swupdate: provide sensible error message if no config file is specifiedGravatar Peter Korsgaard2015-10-031-0/+8
| | | | | | Similar to how we do it for the other kconfig packages. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/swupdate: new packageGravatar Jörg Krause2015-10-034-0/+224
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | swupdate provides a reliable way to update the software on an embedded system. Note that swupdates has a reworked Kbuild/Kconfig system. It has now support for the 'option' and 'env' symbols as well for the 'savedefconfig' target. This makes dependency handling much easier. We're now able to pass which dependencies are available through the environment, as suggested by Arnout Vandecappelle [1]. In previous version of this patch we had a configuration setting where all package dependencies except Lua were selected by default. This has changed with v7 as we are now able to pass dependencies to the swupdate build system through the environment. For useful operation swupdate requires a parser which depends by default on libconfig, but can be replaced by a json-c or Lua parser. To provide a reasonable firmware update system we enable the embedded webserver based on mongoose (also see notes about mongoose below), a parser as stated above and a handler for raw NAND or NOR flash. The user can modify this configuration by selecting the appropriate dependencies before running `make swupdate-menuconfig`. The help text contains information about which packages may be of interest for the user. The embedded web server requires a website for proper operation. We install the included website by default, however the user may choose to install a custom website on the post-build scripts. Note, swupdate includes some old versions of mongoose and lsqlite3: - mongoose is version 3.8 from year 2013 - lsqlite3 is version 0.8 from year 2011 Currently, swupdate does not provide a way to replace these with external packages. This patch is based on a WIP version submitted by Romain Naour, commented by Arnout Vandecappelle [2]. [1] http://lists.busybox.net/pipermail/buildroot/2015-March/122981.html [2] https://patchwork.ozlabs.org/patch/401270/ Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Cc: Romain Naour <romain.naour@openwide.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Yann E. MORIN <yann.morin.1998@free.fr> Tested-by: Mike Williams <mike@mikebwilliams.com> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* busybox: inittab: don't redirect output to /dev/nullGravatar Luca Ceresoli2015-10-031-6/+6
| | | | | | | | | | | | | | Several inittab steps are redirected to /dev/null. This means any error or warning printed by these crucial commands would be hidden from the user. There is no evident reason to hide this output, so stop doing that. Suggested by Thomas Petazzoni: http://lists.busybox.net/pipermail/buildroot/2015-September/139146.html Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* links: bump to version 2.12Gravatar Vicente Olivert Riera2015-10-032-2/+3
| | | | | | | And also use the .tar.bz2 tarball to save disk space and bandwidth. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* valgrind: build for the right MIPS ISA revision levelGravatar Vicente Olivert Riera2015-10-031-0/+13
| | | | | | | | | | | | | | | | | | | | | | | | | | When Valgrind detects a 32-bit MIPS architecture, it forcibly adds -march=mips32 to CFLAGS; when it detects a 64-bit MIPS architecture, it forcibly adds -march=mips64. This causes Valgrind to be built always for the first ISA revision level (R1), even when the user has configured Buildroot for the second ISA revision level (R2). Since R2 is backwards compatible with R1, you can run a Valgrind built for R1 in an R2 core. This is why nobody noticed about this problem, or at least nobody complained. But, since (I hope) we will support R6 in Buildroot in the near future, this problem will become very important because R6 is not backwards compatible with R1 or R2, so building Valgrind for R1 when your target is R6 will result in a non-working Valgrind. Override the CFLAGS variable (which Valgrind appends to its CFLAGS) and pass the right -march option, so they take precedence over Valgrind's wrongfully detected value. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/kodi-pvr-pctv: add jsoncpp reverse dependencyGravatar Bernd Kuhls2015-10-031-0/+4
| | | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/kodi-pvr-filmon: add jsoncpp reverse dependencyGravatar Bernd Kuhls2015-10-031-0/+4
| | | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/kodi-pvr-argustv: add jsoncpp reverse dependencyGravatar Bernd Kuhls2015-10-031-0/+5
| | | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/kodi-pvr-stalker: Needs jsoncppGravatar Bernd Kuhls2015-10-032-1/+6
| | | | | | | | | | Fixes http://autobuild.buildroot.net/results/56f/56fb98da27495f6a461bfdc7aa8c2de4d86dfdb8/ http://autobuild.buildroot.net/results/f98/f982b437935cf1f921559f5388fd4146eb9241bd/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* dhcpcd: move libexecdirGravatar Gustavo Zacarias2015-10-031-0/+1
| | | | | | | | | | | The default is $PREFIX/libexec which ends up in an ugly and non-standard /libexec dir in the target. Move it to $PREFIX/lib/dhcpcd which is far more nicer and suitable. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* dhcpcd: bump to version 6.9.3Gravatar Gustavo Zacarias2015-10-032-2/+2
| | | | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libnss: bump to version 3.20Gravatar Gustavo Zacarias2015-10-032-3/+3
| | | | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libnspr: bump to version 4.10.9Gravatar Gustavo Zacarias2015-10-034-25/+28
| | | | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/bluez_utils: fix musl compilation issueGravatar Brendan Heading2015-10-031-0/+61
| | | | | | | | | http://autobuild.buildroot.net/results/4e4/4e4cea0234e6abf5882296abd5ceeda6ccab89b0/ Signed-off-by: Brendan Heading <brendanheading@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* targetcli-fb: systemd supportGravatar Christophe Vu-Brugier2015-10-032-1/+21
| | | | | | | | | The systemd service file is taken from Fedora. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* targetcli-fb: bump versionGravatar Christophe Vu-Brugier2015-10-032-2/+3
| | | | | | | | | Also add new dependency to python-six. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* python-configshell-fb: bump versionGravatar Christophe Vu-Brugier2015-10-032-2/+3
| | | | | | | | | Also add new dependency to python-six. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* python-rtslib-fb: bump versionGravatar Christophe Vu-Brugier2015-10-032-1/+3
| | | | | | | | | Also add new dependency to python-six. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* python-pyparsing: bump versionGravatar Christophe Vu-Brugier2015-10-032-4/+5
| | | | | | | | | Also download tarball from PyPI instead of SourceForge. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* python-urwid: bump version and add checksumsGravatar Christophe Vu-Brugier2015-10-032-1/+4
| | | | | | | Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/freerdp: introduce the wayland clientGravatar Yann E. MORIN2015-10-032-4/+23
| | | | | | [Peter: use 'depends on' for wayland to match X11 client] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/freerdp: prepare for adding another clientGravatar Yann E. MORIN2015-10-032-13/+48
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, the only client we can build is the X11 client. FreeRDP now has support for building a wayland client. However, that means we need to rethink the way we build FreeRDP, because of some "inconsistencies" in its build system. This is because FreeRDP's buildsystem does not have orthogonal options; some of the options can be used for different components. For example, the set of X11 libraries needed to build the server is a superset of the X11 libraries needed to build the X11 client. So, whenever the server is enabled, it means the X11 libraries required to build the X11 client are available. Now, if the user also wants to build the waland client (but not the X11 client), there is no way to tell FreeRDP not to build the X11 client, because there is a single option, WITH_CLIENT, to drive whether any of the clients is built. The decision is made on the availability of the required libraries. And since the server is enabled, the X11 libs required to build the X11 client are available. So, we end up with the X11 client, even though it is not wanted. And conversely with wayland... So, we redesign the way we build FreeRDP. WE do not care what is actually built; we just build whatever is buildable with the current set of enabled libraries. But at install time (both in staging/ and target/) we remove whatever the user does not want. We also take the opportunity to rename the X11 client option, so it is coherent with the soon-to-be-introduced wayland client. Note: since FreeRDP has gained new dependencies, we can not just introduce the legacy option as-is, otherwise we run the risk that it selects the new option even though the new FreeRDP dependencies are not enabled, spitting out the infamous 'unmet direct dependencies" kconfig error. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/freerdp: re-add support for gstreamerGravatar Yann E. MORIN2015-10-032-1/+44
| | | | | | | | | | | | | | | | | | | | | | | | | | | Previously, we expected the user to select gstreamer-0.x on his own, to enable gstreamer support in FreeRDP. This could have been a bit confusing to the user, as he may have enabled gst-1.x but FreeRDP did only support gst-0.x. Also, gstreamer support needs xlib-libxrandr, which was missing in FreeRDP's dependencies, so it was never enabled (AFAICS). (Re-)introduce support for gstreamer-0.x and gstreamer-1.x, since both are supported. We're doing it in a choice, and select whichever version the user chooses, rather than automatically detect it as previosuly done. We can select the gstreamer packages, as their dependencies are anyway already covered by the ones of FreeRDP. This also now requires xlib-libxrandr, so hide the choice if X.org is not enabled, still offer the option of not using gstreamer if it is. [Peter: Hide option if gstreamer{,1} aren't enabled, Default to gstreamer{,1} support enabled GStreamer 0.10 support needs host-pkgconf and libxml2] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/weston: restore the freerdp backendGravatar Yann E. MORIN2015-10-021-4/+2
| | | | | | | | | | Now that we've switched to using FreeRDP from master, we can build weston's FreeRDP backend again. Propagate the new dependencies of FreeRDP. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/freerdp: bump to masterGravatar Yann E. MORIN2015-10-026-248/+38
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, we're packaging FreeRDP from the stable-1.1 branch, which has not evolved since march 2015 and hasn't seen any release (not even a tag) since July 2013. It is by all purpose and means, dead. Other packages that may use FreeRDP (like weston) are now migrating to, or have already migrated to using the API from master, which has changed a bit from what was available on the stable-1.1 branch. So, those packages now FTBFS. However, FreeRDP still has not done a release from their master branch; the last tag dates back to September 2014 and there are 1850+ changes on top of that tag. So, switch to using the currently-latest commit from master. This version can also use gstreamer-1.x (in addition to gst-0.x), which needs quite some rework on how we handle the dependency on gstreamer. Drop gstreamer support entirely, support for gst-0.x and gst-1.x will be re-added in a followup patch. Similarly, a wayland client can now be built, support for which will be added in a subsequent path; it is currently forcibly disabled. The way the libraries are built has changed: the previous single library has been split in multiple libraries, each implementing parts of the RDP protocol. Slight rewording of the prompts: - drop the 'install' for client and server. - drop 'freerdp' from the client and server comment The location of the server keys has changed, so copy them from the new location. Finally, drop patches 1 and 3, applied upstrem; rename remaining patches. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* pkg-perl: remove the dependency generated by scancpanGravatar Francois Perrad2015-10-0241-41/+20
| | | | | Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* pkg-perl: refactor perl infrastructureGravatar Francois Perrad2015-10-021-0/+8
| | | | | | | | the perl dependency of cpan module is no longer generated by scancpan, but added at the infrastructure level Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* smartmontools: bump to version 6.4Gravatar Gustavo Zacarias2015-10-022-3/+4
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* lftp: bump to version 4.6.4Gravatar Gustavo Zacarias2015-10-022-2/+2
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* minidlna: bump to version 1.1.5Gravatar Gustavo Zacarias2015-10-022-3/+4
| | | | | Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>