aboutsummaryrefslogtreecommitdiff
path: root/package
Commit message (Collapse)AuthorAgeFilesLines
* package/opentyrian-data: update the upstream URL in Config.inGravatar Mark Corbin2019-12-011-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(405)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/netperf: update the upstream URL in Config.inGravatar Mark Corbin2019-12-011-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(Err)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/oprofile: add an upstream URL to Config.inGravatar Mark Corbin2019-12-011-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/ortp: update the upstream URL in Config.inGravatar Mark Corbin2019-12-011-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(404)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/opkg: update the upstream URL in Config.inGravatar Mark Corbin2019-12-011-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(405)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/network-manager: add missing dependency on libglib2Gravatar Thomas Petazzoni2019-12-012-3/+7
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Commit 7643ab05de860011e749aa720c92d5de150bee0a ("package/network-manager: drop obsolete dependencies") was a bit too brutal in its dependency removal, as it forgot that removing dbus-glib as a dependency would make libglib2 no longer part of the dependencies of network-manager. However, network-manager does require libglib2. From configure.ac: PKG_CHECK_MODULES(GLIB, [gio-unix-2.0 >= 2.37.6 gmodule-2.0], [AC_SUBST(LOG_DRIVER, '$(top_srcdir)/build-aux/tap-driver.sh') AC_SUBST(AM_TESTS_FD_REDIRECT, '--tap')], [PKG_CHECK_MODULES(GLIB, gio-unix-2.0 >= 2.40 gmodule-2.0) AC_SUBST(LOG_DRIVER, '$(top_srcdir)/build-aux/test-driver')]) So this commit re-adds libglib2 as a dependency, and propagates the appropriate "depends on". Nothing selects BR2_PACKAGE_NETWORK_MANAGER, so we don't have to propagate these additional "depends on" anywhere. Fixes: http://autobuild.buildroot.net/results/2025b1bd721bb5c5fa6638ccf389d2fd8fd10339/ https://bugs.busybox.net/show_bug.cgi?id=12326 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Cc: Lubomir Rintel <lkundrak@v3.sk> Cc: Christian Stewart <christian@paral.in> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* {linux, linux-headers}: bump 4.{14, 19}.x seriesGravatar Bernd Kuhls2019-12-011-2/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/go: bump to 1.13.4Gravatar Christian Stewart2019-11-302-2/+2
| | | | | | | go1.13.4 (released 2019/10/31) with fixes to the net/http and syscall packages. Signed-off-by: Christian Stewart <christian@paral.in> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/opencv3: ensure the python module works when BR2_PACKAGE_PYTHON{, ↵Gravatar Thomas Petazzoni2019-11-301-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | 3}_PYC_ONLY=y The OpenCV Python module does a fairly strange thing to read a few configuration details: it uses Python's execfile() to execute two .py files and access a few variables. However, execfile() only works with .py files and not .pyc files. When BR2_PACKAGE_PYTHON{,3}_PYC_ONLY=y, the .py files are all removed, causing the OpenCV Python module to not work: File "usr/lib/python3.7/site-packages/cv2/__init__.py", line 89, in <module> File "usr/lib/python3.7/site-packages/cv2/__init__.py", line 58, in bootstrap File "usr/lib/python3.7/site-packages/cv2/__init__.py", line 56, in load_first_config ImportError: OpenCV loader: missing configuration file: ['config.py']. Check OpenCV installation. To fix this problem, this commit uses the newly introduced <pkg>_KEEP_PY_FILES mechanism, to ensure the important config*.py files are kept. Fixes: https://bugs.busybox.net/show_bug.cgi?id=12171 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/{pkg-generic, python, python3}: add mechanism to exclude .py files ↵Gravatar Thomas Petazzoni2019-11-303-2/+7
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | from removal When BR2_PACKAGE_PYTHON{,3}_PYC_ONLY=y, we force remove all .py files from the system, as they have all been byte-compiled into their .pyc variants. However, it turns out that some packages (e.g: OpenCV) do some funky things with a few .py files: they pass them through Python's execfile() facility, which only works with .py files and not .pyc files. It is used by OpenCV for example to read two small configuration files. In order to support such use cases, this commit introduces a very simple mechanism by which packages can exclude some path patterns from the .py removal: a per-package <pkg>_KEEP_PY_FILES variable that is collected into a global PYTHON_KEEP_PY_FILES variable, then used by the python/python3 target-finalize hooks. This variable is intentionally not documented, this is really a hack that we ideally would like to see go away, and we'd rather not see its usage spread too much. This is necessary to be able to fix bug #12171. [Peter: check if PYTHON_KEEP_PY_FILES contains non-white space] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* {linux, linux-headers}: bump 4.{4, 9}.x / 5.3.x seriesGravatar Bernd Kuhls2019-11-301-3/+3
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/perl-gdtextutil: add licenseGravatar Fabrice Fontaine2019-11-292-2/+4
| | | | | | | | | Dustismo.LICENSE contains the license for the Dustismo_Sans.ttf font file. The rest is licensed under the same terms as Perl as specified in README Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/lzma: add licenseGravatar Fabrice Fontaine2019-11-292-0/+5
| | | | | | | | | | | | | | | | - lzma program is licensed under GPL-2.0+ - lzmadec program has no license information in source file - lzmainfo program is licensed under LGPL-2.1+ - LzmaDecode.h is licensed under LGPL-2.1+ (or CPL) as stated in src/sdk/7zip/Compress/LZMA_C/LzmaDecode.{c,h}, other sdk files have no license information - lzmore and lzgrep scripts are licensed under GPL-2.0+ - lzdiff script has no license information - basic and perms tests are licensed under GPL-3.0+ - mkdtemp and test-lib.sh tests have no license information Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/tiff: security bump to 4.1.0Gravatar Michael Vetter2019-11-293-55/+2
| | | | | | | | | | | | | | | | Fixes the following security vulnerabilities: * CVE-2018-12900 * CVE-2018-17000 * CVE-2019-6128 * CVE-2019-7663 * CVE-2019-14973 * CVE-2018-19210 Remove because contained upstream: 0001-Fix-for-simple-memory-leak-that-was-assigned-CVE-2019-6128.patch Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libglob: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/pkg-generic.mk: make HOST_<pkg>_DL_OPTS inherit from <pkg>_DL_OPTSGravatar Thomas Petazzoni2019-11-291-0/+6
| | | | | | | | | | | | | | Just like _SITE, _SOURCE, _SITE_METHOD, it is very likely that if <pkg>_DL_OPTS is defined, the same value should be used for HOST_<pkg>_DL_OPTS, so let's have the same inheritance logic than the one we have for other variables. Fixes: https://bugs.busybox.net/show_bug.cgi?id=12321 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/gst1-plugins-bad: remove rpi-userland extra include pathsGravatar Peter Seiderer2019-11-291-8/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Fixes #12366 [1] The rpi-userland extra include paths where added with [2] including a rpi-userland dependency for the dispmanx option. The dispmanx option was moved to gst1-plugins-base with commit [3], including the rpi-userland dependency, excluding the extra include paths. Tested gst1-plugins-base with dispmanx enabled compiles without failures. It seems to be safe to remove the extra includes from gst1-plugins-bad. Fixes (from meson-log.txt): Sanity check compile stderr: arm-buildroot-linux-uclibcgnueabihf-gcc.br_real: error: /.../host/arm-buildroot-linux-uclibcgnueabihf/sysroot/usr/include/IL: No such file or directory arm-buildroot-linux-uclibcgnueabihf-gcc.br_real: error: /.../host/arm-buildroot-linux-uclibcgnueabihf/sysroot/usr/include/interface/vcos/pthreads: No such file arm-buildroot-linux-uclibcgnueabihf-gcc.br_real: error: /.../host/arm-buildroot-linux-uclibcgnueabihf/sysroot/usr/include/interface/vmcs_host/linux: No such file [1] https://bugs.busybox.net/show_bug.cgi?id=12366 [2] https://git.buildroot.net/buildroot/commit/?id=962ffda68cd9b0c4ab6055c97c14e762a5439571 [3] https://git.buildroot.net/buildroot/commit/?id=3f2aef56127fbe71378e6a2d55192a0835d962ab Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/python-cchardet: bump to version 2.1.5Gravatar James Hilliard2019-11-292-4/+4
| | | | | Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/oniguruma: security bump to version 6.9.4Gravatar Fabrice Fontaine2019-11-292-5/+5
| | | | | | | | | | | | | - Retrieve official tarball to drop autoreconf - Fixed CVE-2019-19012 - Fixed CVE-2019-19203 (Does not affect UTF-8, UTF-16 and UTF-32 encodings) - Fixed CVE-2019-19204 (Affects only PosixBasic, Emacs and Grep syntaxes) - Fixed CVE-2019-19246 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/most: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-2/+2
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(Err)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/perl-gdgraph: fix licenseGravatar Fabrice Fontaine2019-11-292-3/+4
| | | | | | | | | Dustismo.LICENSE contains the license for the Dustismo_Sans.ttf font file. The rest is licensed under the same terms as Perl as specified in README so add README to license files and add GPL-2.0+ to license Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/wolfssl: add upstream security fix for CVE-2019–18840Gravatar Peter Korsgaard2019-11-291-0/+84
| | | | | | | | | | | | | | | | Fixes the following security vulnerability: - CVE-2019-18840: In wolfSSL 4.1.0 through 4.2.0c, there are missing sanity checks of memory accesses in parsing ASN.1 certificate data while handshaking. Specifically, there is a one-byte heap-based buffer overflow inside the DecodedCert structure in GetName in wolfcrypt/src/asn.c because the domain name location index is mishandled. Because a pointer is overwritten, there is an invalid free. For details, see the writeup: https://medium.com/@social_62682/heap-overflow-in-wolfssl-cve-2019-18840-185d233c27de Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libvorbis: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libsexy: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(500)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libsecret: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(404)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libpciaccess: update help text in Config.inGravatar Mark Corbin2019-11-291-0/+4
| | | | | | | | Add a short package description. Add an upstream URL to address the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/haproxy: security bump to version 2.0.10Gravatar Peter Korsgaard2019-11-292-3/+3
| | | | | | | | | | | | | | | | Fixes the following security vulnerabilities: - CVE-2019-19330: The HTTP/2 implementation in HAProxy before 2.0.10 mishandles headers, as demonstrated by carriage return (CR, ASCII 0xd), line feed (LF, ASCII 0xa), and the zero character (NUL, ASCII 0x0), aka Intermediary Encapsulation Attacks. In addition, 2.0.6..10 fixes a number of bugs. See the changelog for details: https://www.haproxy.org/download/2.0/src/CHANGELOG Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/liblockfile: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libiscsi: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. Removing the trailing comment from the URL line addresses the 'Missing' status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libhid: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(Err)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mii-diag: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/mediastreamer: update the upstream URL in Config.inGravatar Mark Corbin2019-11-291-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(404)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/metacity: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/musl: add an upstream URL to Config.inGravatar Mark Corbin2019-11-291-0/+2
| | | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. [Peter: also add URL to BR2_TOOLCHAIN_BUILDROOT_MUSL help] Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libselinux: fix build on old glibc with <fts.h> incompatible with LFSGravatar Thomas Petazzoni2019-11-291-3/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | glibc versions prior to 2.23 have a <fts.h> implementation that is not compatible with large file support, causing build failures such as: In file included from selinux_restorecon.c:17:0: /home/naourr/work/instance-0/output-1/host/arm-buildroot-linux-gnueabi/sysroot/usr/include/fts.h:41:3: error: #error "<fts.h> cannot be used with -D_FILE_OFFSET_BITS==64" # error "<fts.h> cannot be used with -D_FILE_OFFSET_BITS==64" Prior to commit 3fce6f1c150dbe4be58d083008ca8dbe7257836e ("package/libselinux: fix the build with Python 3.8"), we were not passing PKG_PYTHON_DISTUTILS_ENV in the environment. But with 3fce6f1c150dbe4be58d083008ca8dbe7257836e, we are now passing the PKG_PYTHON_DISTUTILS_ENV variable, provided by pkg-python.mk, into the build environment. While this is part of fixing the build of libselinux with Python 3.8, it breaks the build because we are no longer filtering out the -D_FILE_OFFSET_BITS=64 option from CFLAGS. Indeed, while we do so at the beginning of libselinux.mk, it gets overridden later by the addition of $(PKG_PYTHON_DISTUTILS_ENV). To avoid this, we pass CFLAGS/LDFLAGS *after* $(PKG_PYTHON_DISTUTILS_ENV) has been added. In practice, the CFLAGS/LDFLAGS passed by $(PKG_PYTHON_DISTUTILS_ENV) are just $(TARGET_CFLAGS) and $(TARGET_LDFLAGS), so we are not missing anything specific. Fixes: http://autobuild.buildroot.net/results/ef6ff91086a094eb25b145d66d072c6d2fc60154/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* {linux, linux-headers}: bump 4.{4, 9}.x seriesGravatar Bernd Kuhls2019-11-291-2/+2
| | | | | Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/am33x-cm3: disable PIEGravatar Fabrice Fontaine2019-11-281-0/+33
| | | | | | | | Fixes: - http://autobuild.buildroot.org/results/418a40b995e91bc66e692dfbc4b0521db3fa5fbb Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/am33x-cm3: disable SSPGravatar Fabrice Fontaine2019-11-281-0/+35
| | | | | | | | Fixes: - http://autobuild.buildroot.net/results/3a3a21f3c35ea025e9b93e09c2454aed0ad31034 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/collectd: rename --with-yajlGravatar Fabrice Fontaine2019-11-281-1/+1
| | | | | | | | | | | | --with-yajl is not recognized so replace it by the correct --with-libyajl option The option is named --with-libyajl since a very long time (since at least version 4.8.0 and https://github.com/collectd/collectd/commit/f154fb21fbb1fee2f2262d421eca32e7e340f420) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/nodejs: properly pass HOST_LDFLAGS when building host toolsGravatar Thomas Petazzoni2019-11-281-5/+3
| | | | | | | | | | | | | | | | | | | | | | | | After building host tools, we currently run a pass of patchelf to add the proper RPATH to these tools so that they are able to find the libraries they depend on. Unfortunately, the "torque" host tool is used during the build itself, before we have a chance to run "patchelf" on it. Since it is linked against libcrypto.so available in $(HOST_DIR)/lib, the build aborts because the RPATH is not set. To fix this, we make sure that $(HOST_LDFLAGS) are properly taken into account: since they contain the -Wl,-rpath option, the host tools will have the correct RPATH. This both fixes the build failure, and makes the patchelf hack no longer necessary. Fixes: https://bugs.busybox.net/show_bug.cgi?id=12211 http://autobuild.buildroot.net/results/a1f5e336ddaf386ba08eb5a7a299a48e2bdfe2d9/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/nodejs: use --with-arm-fpu option on ARMGravatar Thomas Petazzoni2019-11-281-0/+14
| | | | | | | | | | | | | | | | | | | | | nodejs can use some FPU instructions on ARM, but it needs to know that thanks to the --with-arm-fpu option. Without this, it may use the wrong FPU setting, such as use VFPv3 even if only a VFPv3-D16 is available. This has been reported as bug #12166, where the compiled node binary had some floating point instructions using floating point registers above 16 on a VFPv3-D16 system. This commit makes sure we pass the appropriate --with-arm-fpu value when it makes sense. Note that NodeJS only has explicit support for a subset of the FPUs, for the ones that are not explicitly supported, we simply pass no --with-arm-fpu value. Fixes: https://bugs.busybox.net/show_bug.cgi?id=12166 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/nodejs: properly pass the --with-arm-float-abi on ARMGravatar Thomas Petazzoni2019-11-281-2/+2
| | | | | | | | | | | | | | | | | | | | | When commit 0064132ba032da39cefa4fffe59c31a71d1f1ddb introduced ARM64 support in nodejs.mk, it incorrectly kept the NODEJS_ARM_FP definition. This variable is used to pass --with-arm-float-abi, which in NodeJS's configure.py script is only used when --dest-cpu=arm, and not when --dest-cpu=arm64. So we are passing --with-arm-float-abi=<something> for ARM64, which has no effect, and we are no longer passing it on ARM. This commit fixes that by putting the NODEJS_ARM_FP definition back at the right location. Fixes: 0064132ba032da39cefa4fffe59c31a71d1f1ddb Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libstrophe: bump to version 0.9.3Gravatar Michael Vetter2019-11-282-2/+2
| | | | | | | | | | | | | | | Changes: * PLAIN mechanism is used only when no other mechanisms are supported * Legacy authentication is disabled by default, can be enabled with connection flag XMPP_CONN_FLAG_LEGACY_AUTH * Session is not established if it is optional * Fixed a bug causing a reused connection not to cleanup properly * Improved debug logging in OpenSSL module * Few memory leaks fixed Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/liberation: add an upstream URL to Config.inGravatar Mark Corbin2019-11-281-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libdvdnav: update the upstream URL in Config.inGravatar Mark Corbin2019-11-281-1/+1
| | | | | | | | Update the upstream URL in the help text in Config.in as it is pointing to an old page. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libdvdread: update the upstream URL in Config.inGravatar Mark Corbin2019-11-281-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(404)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libbson: add an upstream URL to Config.inGravatar Mark Corbin2019-11-281-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libass: update the upstream URL in Config.inGravatar Mark Corbin2019-11-281-1/+1
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(405)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/leafnode2: update the upstream URL in Config.inGravatar Mark Corbin2019-11-281-2/+2
| | | | | | | | | Update the upstream URL in the help text in Config.in. This addresses the 'Invalid(Err)' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/kf5: add an upstream URL to Config.inGravatar Mark Corbin2019-11-281-0/+2
| | | | | | | | | Add an upstream URL to the help text in Config.in. This addresses the 'Missing' URL status in the package stats web page output. Signed-off-by: Mark Corbin <mark@dibsco.co.uk> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>