aboutsummaryrefslogtreecommitdiff
path: root/package/avrdude/Config.in
blob: 1433d2b5c81628291decca90d841609063a930e8 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
config BR2_PACKAGE_AVRDUDE
	bool "avrdude"
	select BR2_PACKAGE_ELFUTILS
	select BR2_PACKAGE_LIBUSB
	select BR2_PACKAGE_LIBUSB_COMPAT
	select BR2_PACKAGE_NCURSES
	depends on BR2_TOOLCHAIN_HAS_THREADS
	depends on BR2_LARGEFILE # elfutils
	depends on BR2_USE_WCHAR # elfutils
	depends on !BR2_STATIC_LIBS # elfutils
	depends on !BR2_bfin # elfutils
	help
	  avrdude is a programmer for Atmel AVR microcontrollers
	  this package provides a version with new linuxspi driver

	  https://github.com/kcuzner/avrdude

comment "avrdude needs a toolchain w/ threads, largefile, wchar, dynamic library"
	depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_LARGEFILE || !BR2_USE_WCHAR || BR2_STATIC_LIBS
	depends on !BR2_bfin