aboutsummaryrefslogtreecommitdiff
path: root/package/ifupdown/Config.in
blob: 1e11e4ee0ad704b8462567d983b31c2bb6f3e121 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
config BR2_PACKAGE_IFUPDOWN
	bool "ifupdown"
	depends on BR2_USE_MMU # fork()
	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # iproute2
	# Default/our uclibc lacks wordexp()
	depends on !BR2_TOOLCHAIN_USES_UCLIBC
	# runtime for ip binary
	select BR2_PACKAGE_IPROUTE2 if !BR2_PACKAGE_BUSYBOX
	# runtime for run-parts
	select BR2_PACKAGE_DEBIANUTILS if !BR2_PACKAGE_BUSYBOX
	help
	  High level tools to configure network interfaces.

	  https://tracker.debian.org/pkg/ifupdown

comment "ifupdown needs an (e)glibc or musl toolchain w/ headers >= 3.0"
	depends on BR2_USE_MMU
	depends on BR2_TOOLCHAIN_USES_UCLIBC || \
		!BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0