aboutsummaryrefslogtreecommitdiff
path: root/package/libgtk2/Config.in
blob: bc4ca9d768ed3a566329b342adaf671e00f9fb6a (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
config BR2_PACKAGE_LIBGTK2
	bool "libgtk2"
	select BR2_PACKAGE_ATK
	select BR2_PACKAGE_CAIRO
	select BR2_PACKAGE_CAIRO_PS
	select BR2_PACKAGE_CAIRO_PDF
	select BR2_PACKAGE_LIBGLIB2
	select BR2_PACKAGE_PANGO
	# libgtk2 on DirectFB is deprecated because it is no longer
	# supported in recent versions of Gtk. We will remove support
	# for Gtk over DirectFB in the next Buildroot version unless
	# support for DirectFB in mainline Gtk is improved in the mean
	# time.
	depends on BR2_PACKAGE_XORG7||(BR2_PACKAGE_DIRECTFB && BR2_DEPRECATED)
	depends on BR2_USE_WCHAR # glib2
	depends on BR2_INSTALL_LIBSTDCPP # pango
	help
	  The GTK+ version 2 graphical user interface library

	  http://www.gtk.org/

comment "libgtk2 requires a toolchain with WCHAR and C++ support"
	depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP