aboutsummaryrefslogtreecommitdiff
path: root/package/libupnpp/Config.in
blob: a0565fe7563ee53ea2417c3f5cb1eea97a56ed54 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
config BR2_PACKAGE_LIBUPNPP
	bool "libupnpp"
	select BR2_PACKAGE_EXPAT
	select BR2_PACKAGE_LIBCURL
	select BR2_PACKAGE_LIBUPNP
	depends on BR2_INSTALL_LIBSTDCPP
	depends on BR2_TOOLCHAIN_HAS_THREADS # libupnp
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
	# Triggers the _gp link issue
	depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
	depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
	help
	  The libupnpp C++ library wraps libupnp for easier use by upmpdcli and
	  upplay.

	  http://www.lesbonscomptes.com/upmpdcli/

comment "libupnpp needs a toolchain w/ C++, threads"
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
	depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
	depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
	depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS