aboutsummaryrefslogtreecommitdiff
path: root/package/lzo/lzo-cross-compile.patch
blob: 68a3d0449e5099acb798fdc2cb25a2512bb0d7d1 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
For some reason the lzo autoconf script uses a local macro that does
a test for cross-compiles, and assumes that if the build target name
and the host target name are the same that --host was not specified to
the configure script. In the uClibc buildroot, this is not the case.

--- lzo-1.08/aclocal.m4	2002-07-12 18:31:52.000000000 -0700
+++ lzo-1.08/aclocal.m4.new	2004-03-10 15:32:42.000000000 -0700
@@ -205,12 +205,6 @@
 [
 AC_REQUIRE([AC_PROG_CC])
 
-if test "X$cross_compiling" = Xyes; then
-  if test "X$build" = "X$host"; then
-    AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
-  fi
-fi
-
 ])
 
 
--- lzo-1.08/configure-dist	2004-03-11 02:18:28.000000000 -0600
+++ lzo-1.08/configure	2004-03-11 02:19:16.000000000 -0600
@@ -2282,13 +2282,13 @@
 
 
 
-if test "X$cross_compiling" = Xyes; then
-  if test "X$build" = "X$host"; then
-    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
-   { (exit 1); exit 1; }; }
-  fi
-fi
+#if test "X$cross_compiling" = Xyes; then
+#  if test "X$build" = "X$host"; then
+#    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
+#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
+#   { (exit 1); exit 1; }; }
+#  fi
+#fi