aboutsummaryrefslogtreecommitdiff
path: root/package/orbit/Config.in
blob: 8df42a8380a2a716f59bf0c138eea8d2305931b6 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
config BR2_PACKAGE_ORBIT
	bool "orbit"
	depends on BR2_PACKAGE_LUA_5_1 || BR2_PACKAGE_LUAJIT
	# These are runtime dependencies
	select BR2_PACKAGE_LPEG
	select BR2_PACKAGE_LUAFILESYSTEM
	select BR2_PACKAGE_WSAPI_XAVANTE
	help
	  An MVC web framework for Lua. The design is inspired by
	  lightweight Ruby frameworks such as Camping

	  http://keplerproject.github.com/orbit

comment "orbit needs a Lua 5.1 interpreter"
	depends on !BR2_PACKAGE_LUA_5_1
	depends on !BR2_PACKAGE_LUAJIT