aboutsummaryrefslogtreecommitdiff
path: root/package/python-pam/Config.in
blob: 02865d00d64323019afe6fd142d3414558f9017e (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
comment "python-pam needs a uClibc or glibc toolchain w/ wchar, locale, dynamic library"
	depends on BR2_PACKAGE_PYTHON
	depends on !BR2_ENABLE_LOCALE || !BR2_USE_WCHAR || BR2_STATIC_LIBS || \
		BR2_TOOLCHAIN_USES_MUSL

config BR2_PACKAGE_PYTHON_PAM
	bool "python-pam"
	depends on BR2_PACKAGE_PYTHON # C extension not compatible with python3
	depends on BR2_ENABLE_LOCALE # linux-pam
	depends on BR2_USE_WCHAR # linux-pam
	depends on BR2_USE_MMU # linux-pam
	depends on !BR2_STATIC_LIBS # linux-pam
	depends on !BR2_TOOLCHAIN_USES_MUSL # linux-pam
	select BR2_PACKAGE_LINUX_PAM
	help
	  PAM (Pluggable Authentication Module) bindings for Python.

	  https://admin.fedoraproject.org/pkgdb/package/PyPAM/